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Safety precautions 

The user must have read and understood this documentation as well as those listed in the Section 
Related documents before carrying out any operation with this software. Please contact ETEL S.A. 
or authorized distributors in case of missing information or questions regarding the installation 
procedures, safety or any other topic. 

ETEL S.A. disclaims all responsibility for accidents and damages if the safety instructions, 
procedures and usage described in the present User’s Manual and in the documentation listed in 
the Section Related documents are not followed. 

ComET4 software is not designed or intended for use in the on-line air traffic control, aircraft 
navigation and communications, as well as critical components in life support systems or in the 
design, construction, operation and maintenance of any nuclear facility. 
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1. Introduction 

ComET4 is a user-friendly software environment for commissioning and maintaining ETEL’s motion 
control products: 

• AccurET and ACCURET+ (since firmware version 3.50A) position controllers; and 

• UltimET motion controllers. 

ComET4 intuitive interface guides the user through the process of setting up a Controller. In just a 
few minutes, an auto-setting wizard tool provides an initial set of controller parameters. 

 

 
 

ComET4 includes a comprehensive set of tools for: 

• Configuration, monitoring and diagnostics; 

• Embedded programming, execution and debugging; and 

• System configuration management and backup. 

For more information about the AccurET position controllers, please refer to the corresponding 

Operation & Software Manual available under the Help menu. 

For more information about the UltimET Light and ADVANCED motion controllers, please refer to 

the corresponding User’s Manuals available under the Help menu. 

 

 
 

1.1. System requirements 

The system requirements for installing ComET4 are: 

 

 Minimum Recommended 

Operating System Windows 10, 64-bit 

Processor Intel Core i3  

System memory (RAM) 4 GB 16 GB 

Disk storage (HDD / SDD) 7 GB  

Monitor resolution 1280x1024 1920x1080 

NOTE 

In general, the term Controller is used indistinctly to identify an AccurET/ACCURET+ 
position controller and an UltimET motion controller in this User’s Manual. The 
exceptions can be easily understood from the context of the topic under discussion. 

Furthermore, for sake of simplicity, it is implicitly considered that all references to 
AccurET position controllers also apply to ACCURET+ position controllers. The 
exceptions will be noted. 

TIP 
Updates between two successive versions of this User’s Manual are highlighted with a 
modification stroke in the left margins. 
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In addition, the Adobe® Acrobat® Reader software must be installed for accessing ETEL’s product 

documentation available under the Help menu. 

 

1.2. Software installation 

Follow these steps to install the ComET4 software: 

1. Run the “Setup.exe” executable file provided by ETEL. 

2. Read and accept ETEL’s license agreement. 

3. Choose the installation folder 
a. By default it is “C:\Program Files (x86)\ETEL SA”. 
b. By default, the program folder is named ComET-4.xxY 

4. Wait a few minutes until the installation is completed. 

 

 
 

A shortcut named ComET-4.xxY is created on the Desktop. In addition, a folder with the same name 
is created in the Windows Start Menu containing the following shortcuts: 

• ComET4 software; 

• ComET4 software running in verbose mode; 

• Documentation; 

• ETND software; 

• Uninstaller. 

For more information about the ETND software, please refer to the corresponding ETND-ETNE 

Technical Note available under the Help menu. 

 

 

NOTE 
By default, program shortcuts created during the installation procedure are named as 
ComET-4.xxY, where xx and Y correspond respectively to the software release minor 
number and revision letter (e.g. ComET-4.24A). 
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2. Interface overview 

To start ComET4 software double-click on the program shortcut that can be found on the Desktop 

or select the program shortcut that can be found in Windows Start Menu → ComET-xxY folder. 

The ComET4 mainframe is divided in four areas: 

1. Menu bar; 

2. Toolbar; 
3. Desktop area composed of four regions for docking tools; and 

4. Status bar. 

 

 
 

In the desktop area, each region can contain docked tools following a standard tab arrangement 

and Drag & Drop mechanism. For each tab, the following functions are provided: 

• Close; 

• Undock; 

• Maximize (also available double-clicking on the tab); and 

• Close all tabs in the region. 

 

 
 

1 

2 

3 

4 
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2.1. Menu bar 

ComET4 Menu bar gives access to the menus: 

• File; 

• Edit; 
• View; 

• Execute; 

• Controller; 
• Tools; 

• Help. 

 

2.1.1. File 

Some of the options under this Menu are disabled depending on the tool detaining the focus: 

New Create a new window in the Editor tool. Equivalent to Tools → Editor → New. 

For this option to be enabled the focus must be on the Editor tool. 

Open Opens a file in the Editor tool. The supported file types are: 
- Parameters (*.par); 
- Sequences (*.seq); 
- Compiled Sequences (*.cseq); 
- Generic text files (*.txt). 

For this option to be enabled the focus must be on the Editor tool. 

Save Save the file being edited in the Editor tool. 

For this option to be enabled the focus must be on the Editor tool. 

Save As Save the file being edited in the Editor tool under a new name. 

For this option to be enabled the focus must be on the Editor tool. 

Save Acquisition Save an acquisition uploaded from the Controller. 
An error is displayed if no acquisition is available for saving. 

For this option to be enabled the focus must be on the Scope or Identification tools. 
Refer to Chapter §7 for further information about Controller acquisitions. 

Export Acquisition to Excel Save to Excel an acquisition uploaded from the Controller. 
An error is displayed if no acquisition is available for saving. 

For this option to be enabled the focus must be on the Scope or Identification tools. 
Refer to Chapter §7 for further information about Controller acquisitions. 

Page Setup Page formatting for hardcopy prints. 

For this option to be enabled the focus must be on the Editor tool. 

Print Print file being edited in the Editor tool. 

For this option to be enabled the focus must be on the Editor tool. 

Recent Files List of most recent files that can be opened in the Editor tool. 

Recover last Downloaded Sequence Display in the Editor tool the last Sequence downloaded from the Controller. 

For this option to be enabled the focus must be on the Editor tool. 

Preferences Configuration of user preferences. 
Refer to Section §2.5 for further information about user preferences. 

Change User Change user profile. 
Refer to Section §2.6 for further information about user profiles. 

Close Tool Close the tool with the focus. 

Exit ComET Exit ComET4. 
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2.1.2. Edit 

The options grouped under this Menu are linked to the Editor tool: 

Undo Reverse the last editing action. 

Redo Restore the last editing action if no other actions have occurred since the last Undo. 

Cut Remove the selected text and place it on the Clipboard. 

Copy Copy the selected text onto the Clipboard. 

Paste Insert the contents of the Clipboard at the current location. 

Select All Select all the text. 

Find Search for the specified text in the Find dialog box. 

Find Again Find and select the next occurrence of the text specified in the Find dialog box. 

Replace Search for the specified text and replace it with the new text specified in the Replace 

dialog box. 

Comment Block Add the comment character to each line of the selected block of text. 

Uncomment Block Remove the comment character from each line of a selected block of text. 

Indent Block Shift all lines in the selection to the next tab stop. 

Unindent Block Shift all lines in the selection to the previous tab stop. 

Insert ISO Header Insert the ISO header above the first line 

Insert Version Header Insert Version header above the first line related to: 
- Sequences 
- K, KL, KF and KD registers 
- C, CL, CF and CD registers 
- X, XK, XF and XD registers 
- LD lookup table 
- EL trigger 
- W, WL, WF and WD registers 

 

2.1.3. View 

The options grouped under this Menu are linked to the Registers Editor tool (refer to Section §11.1 
for further information about this tool): 

Display in ISO Units Display information in the Registers Editor tool in ISO units. 

Display in Incremental Units Display information in the Registers Editor tool in Incremental units. 

Display all Registers Display in the Registers Editor tool all registers of ETEL’s controllers. 

Display all Depths of all Registers Display in the Registers Editor tool all the depths of all registers of ETEL’s controllers. 

Display only used Registers Display in the Registers Editor tool the registers of the Controller with which the 
connection is established. 

Refresh Refresh the information displayed in the Registers Editor tool. 

Full/Normal Scope View Modify the view of the Scope tool. 
Refer to Section §7.1 for further information on this topic. 
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2.1.4. Execute 

Emergency Stop Execute an emergency stop of the movement (equivalent to pressing the Esc key). 

The behavior of the Emergency Stop can be configured under File → Preferences → 
Emergency Stop (refer to Section §2.5.13 for further details). 

Relative Move FORWARDS Execute a relative movement of the axis in the forward direction. Distance to move is 
defined on the toolbar relative position control (refer to Section §2.2.10 for further 

details). Motion settings can be configured under File → Preferences → Console 
parameters (refer to Section §2.5.4 for further details). 

Relative Move BACKWARDS Execute a relative movement of the axis in the backward direction. Distance to move 
is defined on the toolbar relative position control (refer to Section §2.2.10 for further 

details). Motion settings can be configured under File → Preferences → Console 
parameters (refer to Section §2.5.4 for further details). 

Absolute Move Execute an absolute movement of the axis to the position defined on the toolbar target 
position control (refer to Section §2.2.10 for further details). Motion settings can be 

configured under File → Preferences → Console parameters (refer to Section §2.5.4 

for further details). 

Start/Stop Single Acquisition Start/Stop a single acquisition in the Scope tool. 
Refer to Section §7.1 for further details. 

Start/Stop Continuous Acquisition Start/Stop a continuous acquisition in the Scope tool. 
Refer to Section §7.1 for further details. 

Start/Stop Roll Acquisition Start/Stop a roll acquisition in the Scope tool. 
Refer to Section §7.1 for further details. 

 

2.1.5. Macros 

The options grouped under this Menu correspond to the macros that can be defined in the user 
preferences dialog box. Refer to Section §2.5.5 for further information on this topic. 

 

2.1.6. Controller 

The options grouped under this Menu imply in one way or another the exchange of information with 
the Controller: 

• Download refers to the transmission of information to the Controller; 

• Upload refers to retrieving information from the Controller. 

 

Registers Download/Upload Registers to/from the Controller. 

Registers can be read from/saved to a file or read from/opened in the Editor tool. 
Refer to Section §10.1 for further information on this topic. 

Sequence Download/Upload Sequence (program) to/from the Controller. 

Sequence can be read from/saved to a file or read from/opened in the Editor tool. 
Refer to Section §10.2 for further information on this topic. 

Pre-compile Sequence (program). 

Sequence to pre-compile can be read from a file or from the Editor tool. 
Refer to Section §8.4.2 for further information on this topic. 

Save Configuration to Controller Save configuration (Registers and Sequence) to the Controller. 
Refer to Section §10.3 for further information on this topic. 
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Download Firmware Download a new firmware to the Controller. 
Refer to Section §10.4 for further information on this topic. 

Controller Backup Backup Controller configuration and firmware. 
Refer to Section §10.5 for further information on this topic. 

System Configuration Manager Download/Upload system configuration (UltimET Light/ADVANCED motion 
controller and one or multiple AccurET position controllers). 
Refer to Section §10.6 for further information on this topic. 

Download Customer Software Module Download Customer Software Module to an ULTIMET ADVANCED motion controller. 
Refer to Section §8.2.2 for further information on this topic. 

Upload Logs Upload log files from the ULTIMET ADVANCED motion controller. 
Refer to Section §7.6 for further information on this topic. 

 

2.1.7. Tools 

Startup Wizard Launches the Startup Wizard tool. Refer to Section §2.4 for further details. 

Settings Several tools can be launched from this Menu option: 

- Setting (refer to Section §4.1 for further details); 

- Regulation (refer to Sections §4.2.1 and §4.2.2 for further details); 

- Filter Design (refer to Section §4.2.3 for further details); 

- Advanced Feedforward Tuning (refer to Section §4.2.4 for further details); 

- Scale Mapping (refer to Section §4.2.5 for further details); 

- Stage Mapping (refer to Section §4.2.6 for further details); 

- Force Control (refer to Section §5.1 for further details); 

- QuiET (refer to Section §5.2 for further details); 

- ZxT (refer to Section §5.3 for further details). 

Motion Several tools can be launched from this Menu option: 

- S-Curve Profile (refer to Section §6.1 for further details); 

- Console (Point-to-Point) (refer to Section §6.2 for further details). 

Acquisition Several tools can be launched from this Menu option: 

- Scope (refer to Section §7.1 for further details); 

- Viewer (refer to Section §7.2 for further details); 

- Identification (refer to Section §7.3 for further details); 

- Monitor (refer to Section §7.4 for further details); 

- Logging (refer to Section §7.5 for further details). 

Editor Executes actions related to the Editor tool: 

- Open: sets the scope to the last opened window; 

- New: opens a new window. 

I/O Several tools related to I/O can be launched from this Menu option: 

- Control; 
- Configuration. 
Refer to Chapter §9 for further details. 

Registers Editor Launches the Registers Editor tool. Refer to Section §11.1 for further details. 

Terminal Launches the Terminal tool. Refer to Section §11.2 for further details. 

Unit Converter Launches the Unit Converter tool. Refer to Section §11.3 for further details. 

System Reporting Launches the System Reporting tool. Refer to Section §11.4 for further details. 

Processor Load Launches the Processor Load tool. Refer to Section §11.5 for further details. 

Add-ons Tools reserved for advanced users (super user profile). 
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2.1.8. Help 

Error List Open in the default Web browser (HTML format) the list of Controller errors. 
Besides short description of the error, it includes hints to possible root causes. 

Warning List Open in the default Web browser (HTML format) the list of Controller warnings. 
Besides short description of the warning, it includes hints to possible root causes. 

Software Documentation Collection of software related documentation of ETEL motion control products. 
These documents are in PDF format requiring Adobe Acrobat Reader. 

Hardware Documentation Collection of hardware related documentation of ETEL motion control products. 
These documents are in PDF format requiring Adobe Acrobat Reader. 

Technical Notes Collection of technical notes related to very specific topics. 
These documents are in PDF format requiring Adobe Acrobat Reader. 

License ComET4 and Firmware license agreements. 
These documents are in PDF format requiring Adobe Acrobat Reader. 

About ComET ComET4 about dialog box. 

 

 

 

2.2. Toolbar 

The toolbar controls are organized in 11 groups according to their functionality. 

 

 
 

2.2.1. Connection 

 

 

Local connection drop-down list 
List of available local connections. The user can configure which options are visible in this drop-down 

list under File → Preferences →Start-up → Available connections (refer to Section §2.5.1 for 

further details). 

 
 

 

Axis drop-down list 
List of available axes for the selected connection. When the user selects an option from the Local 
connection drop-down list, ComET4 tries to establish communication with the first available axis 

on this connection. Refer to Section §3.1 for further details. 
 
When two axes are configured to work in Gantry mode, a square bracket is displayed to indicate that 
both axes are “linked”. 

 
Connection to Host 

NOTE Contact an ETEL representative to obtain the latest version of the documentation. 

§2.2.1 

§2.2.3 §2.2.5 §2.2.6 §2.2.7 §2.2.8 §2.2.9 §2.2.10 
§2.2.11 

§2.2.2 §2.2.4 
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Open connection with a remote host. Refer to Section §3.1 for further details. 

 
Close Bus 
Close the connection. 

 

2.2.2. Emergency stop 

 
Emergency Stop 
Execute an emergency stop of the movement (equivalent to pressing the Esc key). 

The behavior of this button can be configured under File → Preferences → Emergency Stop (refer 

to Section §2.5.13 for further details). 

 

2.2.3. Tools 

 

 
The Setting tool is used to rapidly configure the parameters of the position controllers and to 
automatically set the protections of the system. When performing a new setting, the user is guided 
through a wizard to follow a step-by-step process of configuring the Controller. 

 
The Regulation tool is usually used after the Setting tool to fine tune the regulation parameters of the 
position controllers. 

 
The Scope tool can be used to monitor the parameters (K registers), monitoring (M registers) and 

user variables (X registers) of any axis. It supports up to 4 simultaneous channels. 

 
The I/O Control tool is used to monitor and manage the different inputs and outputs of the Controller 
and/or its optional board. Additionally, it allows the user to set specific functions dedicated to the 
inputs and outputs. 

 
The Editor tool is used to write and debug a Sequence for a Controller. It includes all basic features 
of a simple text processing application and an automatic syntax coloring feature. 

 
The Registers Editor tool is used to view and/or modify the Controller’s Registers which are organized 
by categories. 

 
The Terminal tool is used to directly send commands, inquire and modify the value of Registers of 
the motion controller and of one or several position controllers. 

 

2.2.4. Save configuration to controller 

 
Save configuration (Registers and Sequence) to the Controller. 
Refer to Section §10.3 for further information on this topic. 

 

2.2.5. Editor 

 

 
Create a new window in the Editor tool. 

 
Open a file in the Editor tool. 

 
Save the file being edited in the Editor tool. 

 
Print file being edited in the Editor tool. 
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Refer to Section §2.1.1 for further information. 

 

2.2.6. Macros 

 

 
Execute the HLT macro. 

 
Execute the SAV macro. 

 
Execute the RSD macro. 

 
Execute the RST macro. 

 
Execute the ON macro. 

 
Execute the OFF macro. 

 
Execute the IND macro. 

 

Refer to Section §2.5.5 for further information about the configuration of Macros. 

 

2.2.7. Registers/Sequence 

 

 
Download Sequence (program) to the Controller. Sequence is read from the Editor tool. 
Refer to Section §10.2 for further information on this topic. 

 
Download Registers (parameters) to the Controller. Registers are read from the Editor tool. 
Refer to Section §10.1 for further information on this topic. 

 
Upload Sequence (program) from the Controller. Sequence is opened in the Editor tool. 
Refer to Section §10.2 for further information on this topic. 

 
Upload Registers (parameters) from the Controller. Registers are opened in the Editor tool. 
Refer to Section §10.1 for further information on this topic. 

 

2.2.8. Edit 

 

 
Remove the selected text in the Editor window and place it on the Clipboard. 

 
Copy the selected text in the Editor window onto the Clipboard. 

 
Insert the contents of the Clipboard at the current location in the Editor window. 

 
Search in the Editor window for the specified text in the Find dialog box. 
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Find and select the next occurrence in the Editor window of the text specified in the Find dialog box. 

 
Search in the Editor window for the specified text and replace it with the new text specified in the 

Replace dialog box. 

 

2.2.9. View 

 

 
Display information in the Registers Editor tool in ISO units. 

 
Display information in the Registers Editor tool in Incremental units. 

 
Display in the Registers Editor tool all registers of ETEL’s controllers. 

 
Display in the Registers Editor tool all the depths of all registers of ETEL’s controllers. 

 
Display in the Registers Editor tool the registers of the Controller with which the connection is 
established. 

 
Refresh the information displayed in the Registers Editor tool. 

 

Refer to Section §11.1 for further information about the Registers Editor tool. 

 

2.2.10. Motion 

 

 
Execute a jog movement of the axis in the backward direction. Motion settings can be configured 

under File → Preferences → Console parameters (refer to Section §2.5.4 for further details). 

 
Execute a jog movement of the axis in the forward direction. Motion settings can be configured under 

File → Preferences → Console parameters (refer to Section §2.5.4 for further details). 

 
Execute a relative movement of the axis in the backward direction. Distance to move is defined on 

the relative position control. Motion settings can be configured under File → Preferences → Console 
parameters (refer to Section §2.5.4 for further details). 

 
Execute a relative movement of the axis in the forward direction. Distance to move is defined on the 

relative position control. Motion settings can be configured under File → Preferences → Console 
parameters (refer to Section §2.5.4 for further details). 

 
Execute an absolute movement of the axis to the position defined on the target position control. 

Motion settings can be configured under File → Preferences → Console parameters (refer to 

Section §2.5.4 for further details). 

 Dual-purpose control: 
Relative position control: distance to move for relative movements; or 
Target position control: target position for an absolute movement. 
Select the units accordingly. 

 

2.2.11. Interface layout 

Group of buttons for organizing ComET4’s desktop interface layout according to preferences. 
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Interface layout of a single region (layout 1x1). 

 
Interface layout divided in two regions (layout 1x2). 

 
Interface layout divided in two regions (layout 2x1). 

 
Interface layout divided in three regions (layout 2-1x2). 

 
Interface layout divided in three regions (layout 1-2x2). 

 
Interface layout divided in four regions (layout 2x2). 

 

2.3. Status bar 

The status of the position and motion controllers is displayed in the Status bar at the bottom area of 

ComET4 application. The information displayed on the Status bar can be grouped by 6 topics. 

 

 
 

2.3.1. General status 

 ComET4 general status. 

 

2.3.2. Editor 

 Line:Column where the cursor is placed in the Editor window. 

 

2.3.3. Units 

 Selected default position unit of the current axis (refer to Section §2.5.3 for further information on 
how to configure the default units used by ComET4). 

 

2.3.4. Status of the selected controller 

 

 Controller status. 

 If the axis is powered on, the axis number is displayed in bold. 

 If the selected axis is in warning, a full orange circle and warning message are displayed (there are 
many types of warning that can be raised by the Controller; for further information press the F9 key 

to open a list of the most common warnings). 

§2.3.1 §2.3.4 

§2.3.6 

§2.3.2 §2.3.3 §2.3.5 
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 If the selected axis is in error, a full red circle and error message are displayed (there are many types 
of error that can be raised by the Controller; for further information press the F2 key to open a list of 

the most common errors). 

 Temperature of the Controller. 

 /  Power off / on 

 /  Homing not done / done 

 /  Initial phasing not done / done 

 /  Stopped / In motion 

 /  Not in-window / In-window 

 
 

  

Sequence thread #1 not used / used, but not running / running (the number identifies the Sequence 
line being executed). Refer to Section §8.1 for further information about Sequence programming. 

 
 
 

Sequence thread #2 not used / used, but not running / running (the number identifies the Sequence 
line being executed). Refer to Section §8.1 for further information about Sequence programming. 

 
 
 

Sequence thread #3 not used, used, but not running / running (the number identifies the Sequence 
line being executed). Refer to Section §8.1 for further information about Sequence programming. 
Only UltimET Light motion controllers can have 3 threads. 

 

2.3.5. Status of communication 

 Connection is well established with a Controller. 

 A TCP/IP connection is established with an AccurET position controller, but it is momentarily 
irresponsive; or multiple parallel USB connections are established with AccurET position controllers, 
but the axis identifiers are not unique. 

 Connection with a Controller is interrupted (the error is specified in the text that follows the icon). 

 Connection is well established with an UltimET motion controller (TransnET master) and ComET4 
is downloading firmware to AccurET position controller(s) (TransnET slave(s)); or multiple parallel 
USB connections are established with AccurET position controllers and ComET4 is downloading 
firmware. 

 Connection is well established with an UltimET motion controller (TransnET master) and ComET4 
is downloading firmware to this Controller. 

 

2.3.6. Status of all controllers 

 

 Identifies an axis of an AccurET position controller (contains an alphanumeric character). 

 Identifies an UltimET Light/ADVANCED motion controller (contains the * character). 

 Axis powered off (axis number in plain text). 

 Axis powered on (axis number in bold text). 

 Axis in warning (full orange circle on left lower corner). 

 Axis in error due to another axis (empty red circle on left lower corner). 
Occurs when the error propagation feature is enabled and another axis is in error. 

 Axis in error (full red circle on left lower corner). 

 Two axis are configured to work in Gantry mode (black square in the background). 
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2.4. Startup wizard 

By default, the Startup Wizard tool is executed automatically at start-up of ComET4. This 5-panel 
wizard is particularly useful for beginners, guiding through the steps of configuring the desktop 
layout, establishing a connection with a Controller, performing a basic setting, sending initial 
commands, moving an axis, performing regulation fine tuning, editing parameters, etc. 

 

 
 

2.4.1. Panel #1: Layout definition 

On this first panel, the user can set the preferences for the desktop’s interface layout. This area can 
be sub-divided up to 4 regions (refer to §2) and the user can select which tools to display at start-

up. The options are the Terminal, Editor, Registers Editor, Scope, Viewer and Identification. 

 

 
 

To proceed to the next panel, click on the Next button. Alternatively, close the wizard by clicking on 

the Close button. 

 

2.4.2. Panel #2: Connection 

On the second panel the user can establish a connection with a Controller. 

 

TIP 

To prevent the Startup Wizard tool from executing automatically at start-up, check the 

option Do not show wizard again. 

It is always possible to revert this action by launching the Startup Wizard tool from Tools 
→ Startup Wizard and unchecking the option Do not show this wizard again. 
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The Controller can be selected from the Local Hardware drop-down list: 

 

 
 

Or, the user can click on the Remote Hardware button, select a Controller from the Available Hosts 

list on the Host selection dialog box and click the Open button to establish the connection. 

 

 

 

TIP 
The Toolbar Connection group buttons can also be used to establish a connection with 

a Controller. For further information, refer to Section §2.2.1. 
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When the communication is successfully established, the selected local or remote hardware is 

displayed in the corresponding panel drop-down list and in the top left corner of the Toolbar (USB 

in this example). 

 

 
 

However, if the selected Controller is not reachable, the following error is displayed: 

 

 

 

 
 

NOTE 
Check if the Controller is powered on, if there are no problems with the cabling (power 
and communication cables), USB or PCI/PCIe drivers’ installations. If necessary, contact 
ETEL’s technical support team. 
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To proceed to the next panel, click on the Next button. Alternatively, close the wizard by clicking on 

the Close button. 

 

2.4.3. Panel #3: Setup Controller 

On this third panel the user can launch the Setting tool to configure the Controller. For further 
information on how to use this tool, please refer to Section §4.1. 

 

  

 

2.4.4. Panel #4: Initial commands 

On the fourth panel the user can select a set of basic commands to send to the Controller. 

 

 
 

The three commands that can be selected are: 

Commands Description 

RST Reset the Controller 

PWR = 1 Power on the position controller axis 

IND Execute a homing of the position controller axis 
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Click on the Execute button to send the selected commands to the Controller. These are executed 

one by one on the same order as they are displayed.  

 

 
 

For more information about these commands, please refer to the AccurET Modular Position 

Controller Operation & Software Manual available under the Help menu. 

To proceed to the next panel, click on the Next button. Alternatively, close the wizard by clicking on 

the Close button. 

 

2.4.5. Panel #5: Use Controller 

On the last panel of the Startup Wizard tool, the user can perform several operations: 

1. Move an axis using the Motion controls. These controls are the same as the Motion controls 

on the toolbar (refer to Section §2.2.10 for further details); 
2. Perform fine tuning of the Controller’s motion control parameters (refer to Section §4.2 for 

further details); 

3. Edit Controller parameters using the Registers Editor tool (refer to Section §11.1 for further 
details); and 

4. Edit a Sequence using the Editor tool (refer to Chapter §8 for further details). 

 

 

 

 
 

NOTE 

If the connection is established with a Controller that does not support these commands 
(e.g. PWR and IND are not supported by the UltimET Light/ADVANCED motion 

controllers), these are simply ignored. 

No warning or error is raised by the Startup wizard tool while sending these commands 
if the connection with the Controller has been lost for some reason in the meantime. 

1 

2 

3 

4 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 



 ComET4 – Commissioning Software 
32 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

2.5. User preferences 

To customize ComET4 interface select the Menu option File → Preferences. 

 

 
 

2.5.1. Startup 

Configure the behavior of ComET4 at start-up: 

- Automatic connection: automatically establish connection with the last hardware connected during the previous session. 

- Available connections: configure which connections are available for selection in the connection combo box located in the 

toolbar left side (refer to Section §2.2.1 for further details about the Communication controls located on the Toolbar). 

- Automatic tools loading: automatically load all tools being executed last during the previous session. 
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2.5.2. Users 

Modify the configuration of the user profiles, more specifically: 
- Username and password; 
- Selection of tools that can be used by the corresponding profile. 
 
The username of the “SuperUser” profile cannot be modified. The password of the “Default user” profile cannot be modified. 
ComET4 will start-up with the first user profile not having any password defined. If all users have a password defined, ComET4 
will use the “Default user” profile. 

 

 

 

 

 

 
  

IMPORTANT 

Make sure the “SuperUser” password is stored in a secure location, as it cannot be 
recovered nor reset. ComET4 software needs to be reinstalled if the “SuperUser” 
password is lost. Other passwords can be reset only if the “SuperUser” password is 
known. 
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2.5.3. ISO Units 

Modify the units (linear and rotary axis) used by the Terminal tool. 

 

 

 

 

 

2.5.4. Console parameters 

Modify the parameters values for the Toolbar motion controls and Startup Wizard tool: 
- Continuous jog; 
- Relative move; 
- Absolute move. 
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2.5.5. Macros 

Define customized buttons on the Toolbar for executing one or several commands. The default macros are: 
- !HLT: (urgent) command for stopping the movement with maximum deceleration supported by the Controller and interrupting 

the execution of the Sequence running; 
- SAV.x = 0: command for saving Sequence, Registers (LD, K, C, EL, X), P stage error mapping variables and axis number 

to Controller flash memory; 
- RSD.x = 255: command for resetting Controller hardware; 

- RST.x: command for resetting Controller error flags; 

- PWR.x = 1: command for powering on the axis; 

- PWR.x = 0: command for powering off the axis; 

- IND.x: command for performing a homing of the axis. 

 
For more information about these commands, refer to the AccurET Modular Position Controller Operation & Software Manual. 

 

 

 

2.5.6. Export options 

Configure the layout of the data exported to file: 
- Header definition: configure the header information to be included on every file; 
- Scope layout options: configure how to save data acquired with a mix of sampling rates; 
- Separator definition: configure the character used to separate information saved to file. 
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2.5.7. Logging tool 

Configure the behavior of the Logging tool: 
- Should the log file be erased at each start-up of ComET4; 
- What is the maximum file size (when the maximum file size is reached a new log file is created); 
- What information to display and log. 
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2.5.8. Colors 

Configure the color scheme used by the Scope tool. 

 

 

 

2.5.9. Semiautomatic input 

Configure the use of the semiautomatic input feature when typing commands in the Editor and Terminal tools. 
Refer to Sections §8.1.1 and §11.2 for further information on this topic. 

 

 

 

2.5.10. Aliases 

Configure the use of registers’ alias in the Terminal tool. Refer to Section §11.2 for further information on this topic. 
For more information about alias, refer to the AccurET Modular Position Controller Operation & Software Manual and UltimET Light 
Motion Controller User’s Manual. 

 

 

 

2.5.11. Tabulation 

Configure the tab settings used in the Editor tool for text alignment. 
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2.5.12. Directory 

Configure ComET4’s default folder for data files. 

 

 

 

2.5.13. Emergency stop 

Configure the action performed when using the Emergency Stop button or hitting the Esc button. 

For more information about these options, refer to the AccurET Modular Position Controller Operation & Software Manual. 

 

 

 

2.6. User profile 

ComET4 software supports multiple user profiles. Each user profile has its own privilege settings for 
executing ComET4 tools. This feature is particularly useful for deploying ComET4 for different use 
cases and roles (e.g. R&D, Support, Maintenance, Operations…). Refer to Section §2.5.2 for further 
details about setting user profiles. 

 

 

 

To change to a different user, go to File → Change User, select the user name, type in the 

corresponding password and press the OK button. 

 

NOTE 
ComET4 will start-up with the first user profile not having a password defined. If all users 

have a password defined, ComET4 will use the Default user profile. 
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NOTE 

Any tools running for which the selected user has no execution rights will close 
automatically. 

If ComET4 is restarted, it will not login with the last selected user. Instead, it will login 
with the first user profile not having any password defined. If all users have a password 

defined, ComET4 will use the Default user profile. 
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3. Quick start 

3.1. Connecting to a controller 

A connection must be established with a Controller prior executing any operation with the Tools 
included in ComET4. There are two ways of establishing communication with a Controller, namely 
the following: 

 

1. In the Startup Wizard tool, ‘Panel #2 – Connection’, select either a local hardware from the 

drop-down list or a remote hardware by clicking on the button . 

 

2. On the Toolbar Connection group, select either a local hardware from the corresponding drop-

down list or a remote hardware by clicking on the button . 

 

 

3.1.1. Local hardware 

Select the local hardware from the drop-down list: 

 

Startup Wizard tool Toolbar Connection group 
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Once the selection is done, ComET4 will try to establish connection to the axis with the lowest 
number. E.g. if USB is selected to connect to an AccurET position controller configured with axes 
#3 and #4, then by default the communication will be established with axis #3. Similarly, if the 
connection is established with an UltimET Light/ADVANCED motion controller having several 
AccurET position controllers connected via TransnET, being #0 the lowest axis number, then by 
default the connection is established with the axis #0. 

The user can always change the connection to another axis using the corresponding drop-down list 

on the Toolbar Connection group. 

 

 
 

3.1.2. Remote hardware 

Select the hardware from the list of available hosts and press the Open button. 

 

 

 

 
 

3.1.3. Connection failure 

Different errors are raised for different types of connection failures. Take the example of a failed 
attempt to establish a local connection to a Controller via the USB bus. 

 

NOTE 
A remote host can be an UltimET TCPIP motion controller or a TCP/IP connection with 
an AccurET position controller. 
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Here is another example of a failed local connection to an UltimET Light motion controller. 

 

 
 

Finally, this is the type of error raised if a remote connection to a Controller fails. 

 

 
 

3.1.4. Reconnection to another hardware 

If the user wants to establish a new connection (e.g. with another hardware), the communication bus 

must be closed by clicking on this icon  on the Toolbar Connection group. Only then a new 

connection with another hardware can be established. 

 

3.2. Setting up a controller 

The Setting tool allows the user to perform a first basic setting of the Controller. The most 

straightforward way to launch this tool is to click on the button  on the Toolbar Tools group (refer 

to Section §2.2.3). 

 

 
 

Then click on the New setting button on the Edit main panel to initiate the configuration of the 

selected axis. 

 

NOTE 
Before executing the Setting tool, please ensure that ComET4 has a connection 
established with the target hardware. 
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From this point on, the user is guided through a setup wizard containing several panels for 
configuring: 

• Controller general information; 

• Application configuration; 

• Motor environment; 

• Type of motor; 

• Type of position feedback; 

• Phasing mode; 

• Homing mode; 

• Perform a quick auto setting without requiring any manual adjustment from the user; 

• Configure system protections; and 

• Select the error propagation groups. 

Refer to Section §4.1 for further information about the New setting wizard. 

Once the setting is completed, the user is directed back to the Edit main panel, where it is possible 

to verify and/or modify any of configuration parameters as needed. 

With the axis configured, the user can power on the motor by clicking on Toolbar Macro power on 

button . 
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3.3. Sending commands 

A command can be sent to a Controller using the Terminal tool. There are several ways to launch 
this tool, namely the following: 

 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → Terminal. 

 

 

To send a command, type it in the Terminal window respecting the following syntax: 

 

<cmd_name>.<axis>[=<P1>][,<P2>] 

<cmd_name> Command name 

<axis> Axis number 

<P1> Parameter #1 

<P2> Parameter #2 

 

Press Enter to send the command to the Controller. 

 

 
 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 

NOTE 

The fields in between ’square brackets’ are optional and certain commands might require 
more than 2 parameters. 

Refer to the AccurET Modular Position Controller Operation & Software Manual and 
UltimET Light/ADVANCED Motion Controllers User’s Manuals for more information 
about the commands and their syntaxes. 
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Refer to Section §11.2 for more detailed information about the Terminal tool. 

 

3.4. Executing simple movements 

Before being able to execute movements with an axis, the user must have first realized the following 
actions: 

• Connect to a Controller; 

• Perform a setting of the Controller (refer to Sections §3.2 and §4.1 for further details); 

• Power on the axis, e.g. by clicking on the Toolbar Macro button  or by sending the 

equivalent command to the Controller from the Terminal tool; 

• Home the axis, e.g. by clicking on the Toolbar Macro button  or by sending the equivalent 

command to the Controller from the Terminal tool. 

Only then the user can execute movements, using one of the many options available: 

 

1. Go to the Startup Wizard tool, ‘Panel #5 – Use Controller’, and use the motion controls. 
Refer to Section §2.4.5 for further details. 

 

2. Use the Toolbar Motion controls. 

Refer to Section §2.2.10 for further details. 

 

3. Select Menu option Tools → Motion → Console (Point-to-Point) to launch the Console tool. 

Refer to Section §6.2 for further details about the Console tool. 
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3.5. Emergency stop 

Whatever the running process, it is always possible to execute an emergency stop using one of the 
following options: 

 

1. Press the Esc key. 

2. Click the Toolbar Emergency Stop button . 

3. Select the Menu option Execute → Emergency Stop. 

 

4. Send to the Controller one of the following urgent commands from the Terminal tool: 

• HLT, HLB, HLO, ERR. 

Refer to the AccurET Modular Position Controller Operation & Software Manual for further 
information about these commands. 

 

 

 
 

3.6. Monitoring 

ComET4’s most useful tools for monitoring the operation of a Controller are: 

• Scope tool; 

• Monitor tool. 

NOTE 
The behavior of the Emergency Stop can be configured under File → Preferences → 
Emergency Stop. Refer to Section §2.5.13 for further details. 
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3.6.1. Scope tool 

There are several ways to launch the Scope tool, namely the following: 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → Acquisition → Scope. 

 

 

The Scope tool can display up to 4 traces simultaneously belonging to any axis. Only basic register 
types can be monitored: 

• K (parameters); 

• M (monitorings); 

• X (user variables); 

• C (common). 

 

 
 

Under the TRACES group control, the user can select which registers to monitor on each trace, 

following one of two possible options: 

 

1. Select the register from the left drop-down list. Only the most frequently used registers are listed 
and these are related to the current axis (i.e. axis with which the connection is established). 
The units used to display the trace can also be selected on the right drop-down list. 

NOTE 

A Trace is an advanced register type (T register) which allows the acquisition of the 

Controller’s basic register types K, M, X and C versus time. 

Once the data is acquired by the Controller, the trace is uploaded to ComET4 and 

displayed on the Scope tool. 

A trace contains the values of the selected register, sampled at the frequency set by the 
user and with the acquisition starting from the moment the trigger conditions, also set by 
the user, are valid. 

Refer to the AccurET Modular Position Controller Operation & Software Manual and the 
UltimET Light/ADVANCED Motion Controllers User’s Manuals for more information 
about register types. 
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2. Click on the More button and configure the trace selection: 

• Axis (can be any “visible” axis); 

• Register type, index and depth; 

• Units used to display the trace. 

 

 

 

It is possible to monitor the selected register(s) using different acquisition modes: 

• Roll; 

• Single; 

• Continuous. 

and configure the acquisition settings clicking on the Setup button: 

• Trigger mode, delay and source; 

• Acquisition resolution. 

 

Refer to Section §7.1 for more detailed information about the Scope tool. 
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3.6.2. Monitor tool 

The Monitor tool can be launched from the Menu Tools: 

1. Select the Menu option Tools → Acquisition → Monitor. 

 

 

Compared to the Scope, the Monitor tool can be used to monitor a wider selection of register types 
(basic and advanced) belonging to any axis: 

• K, for parameters; 

• M, for monitorings; 

• X, for user variables; 

• C, for common; 

• L, for look-up table; 

• T, for trace; 

• P, for mapping; 

• E, for triggers. 

However, only the most recent sample is displayed. 

 

 
 

To add/remove a monitor from the tool or modify its refresh rate (i.e. update interval), right-click on 
the tool’s window to display the contextual menu. 
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Refer to Section §7.4 for more detailed information about the Monitor tool. 

NOTE 

The Monitor tool can display as many registers as wanted. But, there is a practical limit 
since the tool window size is constrained to ComET4’s desktop area and there is no 
vertical scrollbar. 

To remove a monitor, check before the corresponding checkbox control on the left side. 
If several monitors are selected, they all will be removed in one single action. The remove 
action cannot be reverted (i.e. undo). 
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4. Motion control settings 

4.1. Basic setting 

ComET4’s Setting tool allows the user to easily configure a Controller for a specific application. 
There are several ways to launch this tool, such as: 

 

1. In the Startup Wizard tool, ‘Panel #3 – Setup Controller’, click on the button . 

 

2. On the Toolbar Tools group, click on the button . 

 

3. Select the Menu option Tools → Settings → Setting. 

 

 

 
 

Once the Setting tool has been launched, click on the New setting button on the Edit main panel to 

initiate the configuration of the selected axis. 

 

NOTE 
Before executing the Setting tool, please ensure that ComET4 has a connection 
established with the target hardware. 
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If the Controller has already been configured, the following warning message pops-up: 

 

 
 

The user can abort the setting or proceed by clicking on the Yes button. The New setting wizard is 

launched and the first panel displayed. 

 

4.1.1. Setting wizard panel #1: general information 

In this panel the user can view information related to the Controller: 

• Controller type, following ETEL’s product coding; 

• Firmware version; 

• Boot version; 

• Serial number; 

• Maximum rated current. 

In addition, the user is requested to input the following information: 
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• Unique name to identify the Controller (max. 16 characters without spaces); 

• Controller power input voltage (only if the power input connector is unplugged; otherwise this 
value is measured and provided by the Controller); 

• Select the communication protocol used by the Controller. 

 

 

 

 
 

To proceed to the next panel, click on the Next button. 

 
  

NOTE 

The Controller’s common parameter C1 is set according to the selected communication 

protocol. 

The EtherCAT option is only available if the Controller supports this communication 
protocol (reserved for specific products). 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about the common parameter C1 and the supported communication 

protocols. 
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4.1.2. Setting wizard panel #2: application configuration 

In this panel the user can select the application configuration: 

Generic linear 

 

This configuration corresponds to a typical direct drive topology with a linear motor driving 
directly the linear movement of the payload without any mechanical transformations in 
between. A single position feedback is used for controlling the payload’s position. 

Generic rotary 

 

This configuration corresponds to a typical direct drive topology with a rotary motor driving 
directly the rotary movement of the payload without any mechanical transformations in 
between. A single position feedback is used for controlling the payload’s position. 

Generic indirect linear 

 

This configuration corresponds to a typical indirect drive topology, where there is a 
mechanical transformation between the rotary driving motor and the linear movement of the 
payload (e.g. lead screw drive system). 
In this configuration, there can be two position feedback sensors, one measuring the motor’s 
angular position and another measuring the payload’s linear position. 

Generic indirect rotary 

 

This configuration corresponds to a typical indirect drive topology, where there is a 
mechanical transformation between the rotary driving motor and the rotary movement of the 
payload (e.g. worm gear system). 
In this configuration, there can be two position feedback sensors, one measuring the motor’s 
angular position and another measuring the payload’s angular position. 

DynX linear axis 

 

This configuration corresponds to ETEL’s standard single linear axis product portfolio. 

DynX rotary axis 

 

This configuration corresponds to ETEL’s standard single rotary axis product portfolio. 
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To proceed to the next panel, click on the Next button. 

 

4.1.3. Setting wizard panel #3: motor environment 

This panel actually depends on the application configuration selected by the user in the previous 
panel. Nevertheless, there is collection of basic settings common to all configurations that the user 
must configure. 

 

 

 

 
 

 

NOTE 
The product family corresponding to the DynX rotary axis configuration has been 

renamed to DXR. 

NOTE 

For the sake of clarity, all panels presented next and corresponding screenshots are 

related to the Generic linear application configuration. 

Please contact an ETEL representative in case of questions related to other application 
configurations. 
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These settings are grouped on the four configuration sub-panels: 

Miscellaneous 

 

- Are there mechanical end-stops? 
- Is there a restoring force acting on the motor? 
- Is there a digital Hall Effect sensor connected? 

Brake 

 

- Is there a mechanical brake? 
- How is this brake controlled? 

Home & Limit switches 

 

- Is there a Home switch? 
- To which input is this switch connected? 
- Are there Limit switches? 
- To which inputs are these switches connected? 

Temperature sensor 

 

- Is there a temperature sensor? 
- To which input is this sensor connected? 

 

To proceed to the next panel, click on the Next button. 

 

4.1.4. Setting wizard panel #4: motor selection 

This is the panel where the user selects the type of motor. On the Motor brand drop-down list there 

is the option of selecting a standard motor from ETEL’s product portfolio or from another non-
specified vendor. 
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For an ETEL’s standard motor, the user must in addition select the motor family and series from the 

corresponding drop-down lists. The Motor data is automatically filled with the specifications of the 

selected motor. 

Alternately, the user can manually input the specifications of a motor from another vendor by 

selecting Other in the Motor brand drop-down list. The user can even create its own database of 

motor types using the Create and Remove buttons. 

 

  

 

To proceed to the next panel, click on the Next button. 

 

4.1.5. Setting wizard panel #5: position feedback 

In this panel, the user must configure the position feedback being used by the application. 

There are two sub-panels for configuring the Main and Secondary encoder (if any). 

 

 
 

NOTE 

The Secondary encoder sub-panel is only accessible if the user selected previously in 

panel #2 – application configuration the Generic indirect linear or Generic indirect 
rotary configurations. In addition, if the option permanent dual encoder feedback was 

checked, these sub-panels Main encoder and Secondary encoder are renamed 

respectively as Payload encoder and Motor encoder. 
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These are the configuration options available in each of these sub-panels: 

Selection mode 

 

The user can select a standard encoder from a pre-defined list available at the 
drop-down list just to the right or can manually input the encoder characteristics 
encoder type, resolution and reference marks(s). 

Encoder Type 

 

This control is automatically filled if the user has selected previously an encoder 
from the pre-defined list. Alternately, the user can select the encoder type 
amongst the options: 
- 1 Vptp; 
- TTL; 
- EnDat 2.1 or 2.2. 
- EnDat 3 (only supported by ACCURET+ position controllers). 
In addition, the encoder resolution must be defined. 

Reference mark(s) 

 

This control is automatically filled if the user has selected previously an encoder 
from the pre-defined list. Alternately, the user can select the reference mark type 
amongst the options: 
- No reference mark; 
- Single reference mark; 
- Multiple reference marks (the user also has to provide the distance between 

indexes). 

Interpolation 
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The user can define which interpolation factor to use by clicking on the Modify 

button. The default value is 8192. 
For the given interpolation factor, the following information is presented to the 
user: 
- Maximum position range (accounting for the encoder interpolated resolution 

and number of bits available in the Controller to represent a position); 
- Maximum speed and acceleration the Controller can cope without losing 

position information. 
- Position resolution. 

 

Click on the Display & Adjust button in order to check and adjust manually or automatically the 1Vptp 

encoder’s signals (amplitude, offset, reference marks…). There is now an option to release the motor 

brake during Encoder signal adjustment if one exists (Open brake). 

 

 
 

 
 

NOTE 

The encoder signal amplitude and Lissajous graph must be within the green zones of 
the graphs for a reliable operation of the Controller. 

If this is not the case, try to clean the encoder scale and verify if the signal quality is 
good. If still insufficient, mechanically adjust the encoder head position relative to the 
encoder scale until a good signal quality is obtained. Move the axis by hand along the 
full axis travel range to ensure the encoder signal quality remains good all the time. 

Refer to the corresponding System User’s Manual for instructions on how to execute the 
procedure of adjusting the encoder signal. 
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To proceed to the next panel, click on the Next button. 

 

4.1.6. Setting wizard panel #6: phasing selection 

In this panel the user selects the mode used to find the motor phasing. The phasing procedure 
determines the position of the motor's coils towards the magnets poles in order to inject the good 
current shape into the coils (giving the maximum force/torque to the motor). 

 

 
 

The supported phasing modes are: 

Constant current 

 
Consists of injecting a current ramp in the motor coils and moving the mobile part of the 
motor until the current and induced voltage are aligned. 
This mode is suited for all types of motors. 

Unselecting the Automatic phasing checkbox and clicking on the Additional Phasing 
options button opens the following dialog box to adjust these parameters: 

- Constant current level corresponding to parameter KF92; 

- Maximum time corresponding to parameter K94; 

- Initial pointer position corresponding to parameter K97; 

- Final pointer position corresponding parameter K93. 
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Current pulses 

 
Consists of injecting current pulses in the motor coils and measuring the offset between 
the current and the induced voltage signals. 
This mode is only suited for iron core motors with medium and high inductances. 

Unselecting the Automatic phasing checkbox and clicking on the Additional Phasing 
options button opens the following dialog box to adjust these parameters: 

- Pulse current level corresponding to parameter KF91; 

- Voltage rate corresponding to parameter K98. 

 

 

Small moves 

 
Consists of injecting current pulses in the motor coils and measuring the resulting 
displacements. The current pulses induce small movements whose amplitude is 
proportional to the encoder resolution and the current pulse amplitude. 
This mode is suited for all types of motors. 

Unselecting the Automatic phasing checkbox and clicking on the Additional Phasing 
options button opens the following dialog box to adjust these parameters: 

- Pulse current level corresponding to parameter KF91; 

- Total time corresponding to parameter K101. 

 

 

 

  



 ComET4 – Commissioning Software 
62 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 

 
 

The most suite phasing mode is selected by checking the Automatic phasing checkbox. 

To proceed to the next panel, click on the Next button. 

 

4.1.7. Setting wizard panel #7: homing selection 

In this panel the user selects the homing mode: 

 

 
  

NOTE 
The AccurET position controller supports other phasing modes. Refer to the AccurET 
Modular Position Controller Operation & Software Manual for further information about 
the different phasing modes supported by the AccurET position controller. 
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The supported homing modes are: 

Multiple reference mark 

 

Homing with a multi-reference mark with the selected movement direction. The 
motor needs to find only two successive reference marks to determine its 
absolute position (the ’0 machine’ is always positioned at the same place 
regardless the two reference marks found). 

Mechanical end stop 

 

Homing against a mechanical end stop with the selected movement direction. 
After having found the mechanical end stop, the motor moves back the distance 
given by the parameter KL47. 

Immediate homing 

 

The current position is the reference position. 

 

 
 

Except for the Immediate homing mode, the user can select to use the fine phase adjustment option 

by clicking on the Homing options button. Refer to the AccurET Modular Position Controller 

Operation & Software Manual for further details about this homing option. 

 

 
 

Finally, click on the Movement profile button to configure: 

• Speed and acceleration profile of the homing search movement; 

• Movement to realize after homing; 

NOTE 

The AccurET position controller supports many more homing modes. The ones 
available for selection on this panel depend upon certain choices made on previous 
panels, like e.g. the type of reference mark of the selected encoder, are limit switches 
used… 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about the different homing modes supported by the AccurET position 
controller. 
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• For the particular case of the mechanical end stop homing mode, current and maximum 
position error for an end stop detection. 

Refer to the AccurET Modular Position Controller Operation & Software Manual for further 
information about these settings. 

 

 
 

To proceed to the next panel, click on the Next button. 

 

4.1.8. Setting wizard panel #8: auto setting 

The auto-setting procedure is configured in this panel. The steps of the procedure are: 

• Auto-tuning of the current loop; 

• Checking the connection of the motor phases; 

• Auto-tuning of the position loop; 

• Searching for the maximum acceleration; 

• Executing the phasing procedure; 

• Executing the homing procedure; 

• Searching for the limit strokes. 
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Click on the Advanced options button to define which of these steps are executed during the auto-

setting procedure. 

 

 
 

To initiate the auto-setting procedure, click on the Next button. 

 

 

IMPORTANT 
Before starting the auto-setting procedure, ensure the motor is free to run. 
Place the motor at the center of its movement stroke. 
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The auto-setting procedure takes approximately 10 minutes to be completed. Once it has finished, 

click on the Next button to proceed to the next panel. 

 

4.1.9. Setting wizard panel #9: protections 

In the last panel of the Setting wizard, the user can configure the protections of the application. 
These settings are distributed over five configuration sub-panels: 

Movement protections 
- Stroke limits: movement stroke is constrained to these limits. The user can select one of the options available, which result on 

a different behavior of the position controller when the limits are reached (refer to the description of parameter K36 in the 

AccurET Modular Position Controller Operation & Software Manual). In addition, two methods can be used to define the stroke 
software limits: automatic and manual. 

- Tracking limit: error is raised if the tracking error exceeds this limit. 
- Speed limit: error is raised if the speed exceeds this limit. 

 

 

  

WARNING 
The Controller will power on the motor for executing the auto-setting procedure. Always 
ensure that the proper safety precautions are taken when powering on a Controller and 
executing movements with a motion system. 
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Thermal protection 
This panel is only enabled if the user has confirmed the existence of a temperature sensor back in panel #3, sub-panel Temperature 
sensor. 

 

Current limitation 
- Overcurrent limit: an error is raised if the current on the motor phases exceeds this limit. 
- I²t rms level: the integration of current starts when the motor current is higher than this level. 
- I²t rms limit: an error is raised if the integral of the motor current exceeds this limit. 
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Miscellaneous protections 
- Misc. protections: enable dynamic breaking in case of error. 
- Misc. protections: enable raising an error when the limit switches are reached during motion. 
- Protection signals on digital outputs: set/reset digital outputs when an error occurs. 
- Power ON enable on digital inputs: only allow axis power on if the digital input is set. 
- Error propagation groups: configuration of the error propagation mechanism. 

 

Bus voltage 
Enable error detection of the power input voltage by defining levels for overvoltage and under-voltage warning and error generation. 
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To proceed click on the Next button. 

If mechanical end stops or limit switches are used in the application, but the stroke limits were not 

enabled in the sub-panel Movement protections, the following warning message pops-up. 

 

 
 

Click Yes to proceed or No to go back to the sub-panel Movement protections to configure the 

stroke limits. 

 

4.1.10. Setting wizard: error propagation groups 

The last information to configure is related to the AccurET/UltimET error propagation mechanism 
running through TransnET. 

The user can define the group (1 to 4) to which the axis belongs by selecting the Monitored Groups 

checkboxes. An axis can belong to more than one group. 

In addition, the user can define the group in which the error must be published when an error occurs 
on the axis. An axis can publish the error to more than one group. 

 

 

 

 
 

IMPORTANT 
Carefully read the AccurET Modular Position Controller Operation & Software Manual in 
order to set properly the protections of the application. 

NOTE 
Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about the error propagation mechanism on TransnET. 
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To complete the Controller setting, click on the Finish button. Alternatively, clicking on the Previous 

button brings back the previous configuration panel related to protections. Once the setting is 

completed, the user is back to the main window of the Setting tool (Edit main panel), with the 

indication in the lower part that Controller is now set. 

 

 
 

If necessary, the user can now revisit directly some of the configuration panels to verify the settings 
and modify. Below is the correspondence between the button to click and the configuration panel 
that opens. 

 

Controller information → Setting wizard panel #1: general information 
Information can be modified. 

 

Application configuration → Setting wizard panel #3: motor environment 
Configuration can be modified. 

 

Motor configuration 
Only informative, setting cannot be modified. A new setting is required to modify the motor settings. 

 

Position feedback → Setting wizard panel #5: position feedback 
Configuration can be modified. 

 

Phasing → Setting wizard panel #6: phasing selection 
Configuration can be modified. 
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Homing → Setting wizard panel #7: homing selection 
Configuration can be modified. 

 

Auto Setting → Setting wizard panel #8: auto setting 
Configure and re-execute the auto-setting. 

 

Protections → Setting wizard panel #9: protections 
Configuration can be modified. 

 

The other buttons also available on this Edit main panel are explained in corresponding Sections of 

this Manual. 

 

I/O configuration → Refer to Chapter §9. 

 

Regulation → Refer to Section §4.2. 

 

4.2. Fine tuning 

Once a basic setting has been completed, it is possible to fine tune the regulation parameters 
previously set by the auto tuning procedure. 

There are several different techniques for tuning a PID controller, but these can be basically 
classified under two categories: time domain and frequency domain techniques. ComET4’s 

Regulation tool makes use of time domain techniques. 

By analyzing the time domain response of the system to certain stimuli, the user can adjust the 
parameters of both the current and position loops and modify the parameters of each filter present 
in the regulation loops until obtaining the desired controller behavior. 

There are several ways to launch the Regulation tool, such as: 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → Settings → Regulation. 
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The main window of the Regulation tool (Controller principle) contains the AccurET high-level 

control scheme, where three main blocks (control buttons) are clearly identified. 

 

Current loop: PI controller 

 

Position loop: PID controller 

 

Filters: 5 advanced filters (+3 reserved for the force control mode) 

 

 

 

The basic rules for tuning the Controller are: 

• First, fine tune the current loop to obtain the highest bandwidth possible; 

• Then, fine tune the position loop; 

• Adjust the filters; and 

• Finally, re-tune the position loop. 

 

4.2.1. Current loop 

For fine tuning the current loop regulation parameters, click on the Current Loop button on the 

Regulation tool main window to display the Current Loop regulation window. This window is divided 

into three areas: 

1. Current loop parameters (these can be edited by the user); 

NOTE 
Before executing the Regulation tool, please ensure that ComET4 has a connection 
established with the target hardware. 
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2. Settings of the stimuli function that can be applied to the system (Position Step); 

3. Plot (visualization o the time domain system response to the stimuli applied). 

 

 
 

Click on the Step button to execute a step movement of the axis with a given stroke and duration, 

which are configurable via the respective edit control boxes. 

Based on the analysis of the time domain response of the theoretical current (MF30) and real current 

(MF31), adjust the current loop parameters Kpc (KF80) and Kic (KF81). Press again the Step 

button to view the effect of these changes on the system response. 

This is an iterative process to be repeated until obtaining the desired current controller behavior. 

 

 
 

The function of all button controls present on this Current Loop regulation window are detailed below. 

 
Return to the Regulation tool main window (Controller principle) or change directly to the Position Loop 

window by selecting this option from the drop-down list. 

 
Hide/Unhide the plot area. 

 Execute a step movement 

1 

3 

2 

NOTE 

If the Scope tool is opened, the data acquisitions of the theoretical and real currents will 

not be displayed in the plot area of the Current Loop regulation window, but rather in the 

Scope tool directly (if it is properly configured to display these monitorings). 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details on how to perform a basic tuning of the Controller’s current loop. 
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Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed demagnification ratio. 

 
Undo previous Zoom action. 

 

4.2.2. Position loop 

For fine tuning the position loop regulation parameters, click on the Position Loop button on the 

Regulation tool main window to display the Position Loop regulation window. This window is divided 

into three areas: 

1. Position loop parameters (these can be edited by the user); 

2. Settings of the stimuli functions that can be applied to the system (Step, Feedforward and 

Settling time); 

3. Plot (visualization o the time domain system response to the stimuli applied). 

 

 
 
  

1 

3 

2 
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There are three functions available on the three sub-panels: 

Step 

 

Click on the Step button to execute a step movement of the axis with a given stroke and 

duration, which are configurable via the respective edit control boxes. 

Based on the analysis of the time domain response of the theoretical position (ML6) and real 

position (ML7), adjust the PID parameters Kpp (KF1), Kip (KF4) and Kdp (KF2). Press 

again the Step button to view the effect of these changes on the system response. 

This is an iterative process to be repeated until obtaining the desired current controller 
behavior. 

 
 

Feedforward 

 

Click on the Move button to execute a movement of the axis with the given profile, which is 

configurable via the position, speed, acceleration, jerk time and dwell time edit control boxes. 

Based on the analysis of the time domain response of the theoretical speed (M10) and 

tracking error (M2), adjust the feedforward parameter Kaffp (KF21). Press again the Move 

button to view the effect of this change on the system response. 

This is an iterative process to be repeated until obtaining the desired current controller 
behavior. 

 
 

Settling time 

 

Click on the Move button to execute a movement of the axis with the given profile, which is 

configurable via the position, speed, acceleration, jerk time and dwell time edit control boxes. 

Based on the analysis of the time domain response of the theoretical position (ML6) and 

tracking error (M2), adjust the PID parameters Kpp (KF1), Kip (KF4) and Kdp (KF2) and 

feedforward parameter Kaffp (KF21). Press again the Move button to view the effect of 

these changes on the system response. 

This is an iterative process to be repeated until obtaining the desired current controller 
behavior. 
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The function of all button controls present on this Position Loop regulation window are detailed 

below: 

 
Return to the Regulation tool main window (Controller principle) or change directly to the Current Loop 

window by selecting this option from the drop-down list. 

 
Hide/Unhide the plot area. 

 
Launch the Filter Design tool. 

 Execute a step movement. 

 Execute a movement with the defined profile. 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed demagnification ratio. 

 
Undo previous Zoom action. 

 
  

NOTE 

If the Scope tool is opened, the data acquisitions of the theoretical and real positions, 

theoretical speed and tracking error will not be displayed in the plot area of the Position 
Loop regulation window, but rather in the Scope tool directly (if it is properly configured 

to display the corresponding monitorings). 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details on how to perform a basic tuning of the Controller’s position loop. 



 ComET4 – Commissioning Software 
 User’s Manual 77 

ETEL Doc. / Version N / 31/03/23 

4.2.3. Filter design 

From the Regulation tool it is also possible to configure the different filters of the Controller. Click on 

the Filters button on the main window to launch the Filter Design tool. Alternatively, this tool can be 

launched by selecting the Menu option Tools → Settings → Filter Design. 

 

 
 

The Filter Design tool window is divided into three areas: 

1. Filter selection; 
2. Filter definition; 
3. Plot of the filter’s frequency response (gain and phase). 

 

 
 
  

1 

2 3 
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Filter selection 

 

Up to 5 advanced filters can be set on the Controller: 
- Advanced filter I → Speed filter 
- Advanced filter II → First filter on force reference 
- Advanced filter III → Second filter on force reference 
- Advanced filter IV → Third filter on force reference 
- Advanced filter V → Fourth filter on force reference 

Parameters KF104, KF105, KF106, KF107 and KF108 are used to define 

these advanced filters. There are 5 depths, one for each filter. 

The advanced filters VI, VII and VIII are reserved for the force control mode. 

Filter definition 

 

The supported filter types are: 
- Low-pass (first and second order); 
- Notch; 
- Lead-Lag (or Lag-Lead); 
- Biquad; 
- Polynomial. 

 

 
 
To set a filter, enter the values in the Definition area required by the selected filter and press the 

Enter key. The corresponding ’gain vs frequency’ and ’phase vs frequency’ curves are then 

displayed on the plot area. 
 

 

NOTE 
Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details about the Controller’s regulator filters. 
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The black curve is the Actual filter (filter whose parameters’ values are currently set in the 

Controller) and the red one is the Project filter (filter corresponding to the entered values). 

 

The function of the button controls present on the Plot area are detailed below: 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Undo previous Zoom action. 

 

If the user clicks on the Apply button, the values of the selected filter’s K parameters in the Controller 

will be updated with those just entered in the Definition area. This means that the Actual filter plots 

matches the Project filter plots. 

On the other hand, if the user clicks on the Reload button, the values in the Definition area will be 

overwritten by the Controller’s actual values of the corresponding K parameters. This means that 

the Project filter plots matches the Actual filter plots. 

 

4.2.4. Advanced feedforward tuning 

The Advanced Feedforward Tuning tool allows the user to fine tune the advanced feedforward 
parameters: 

• Cogging compensation; 

• Friction feedforward; and 

• Acceleration feedforward. 

To launch this tool select the Menu option Tools → Settings → Advanced Feedforward Tuning. 

 

 
 

At tool startup, the following warning message pops up to remind the user that the tuning of the 
feedforward parameters should only be realized after having tuned properly the current loop, position 

loop and filters. Click on Yes to proceed or No to exit the tool. 

 



 ComET4 – Commissioning Software 
80 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 
 

The Advanced Feedforward Tuning tool window is divided into 5 areas: 

1. Test conditions and other settings: composed of two tabs, one for the cogging and another 
for the friction and acceleration feedforward; 

2. Computed friction and acceleration feedforward parameters; 
3. Cogging look-up table configuration; 
4. Plot of the measurements; 
5. Status bar. 

 

 
 

 
 

Cogging 

The cogging compensation table can compensate any position dependent force acting on the system (cogging, spring force, gravity, 
restoring force…). In order to acquire this table the following inputs should be provided (to tool already fills the different fields with 
proposed settings that the user can modify). 

 In case of a rotary axis, indicate if it has an infinite rotary motion. 

 
Minimum position of measurement. This position should be greater or equal to 
the minimum software position limit (KL34). 

1 

2 

4 

3 

5 

NOTE 

In order to obtain a good tuning, start by tuning first the cogging parameters and only 
then the friction and acceleration feedforward parameters. 

Furthermore, the cogging compensation should be active when tuning the friction and 
acceleration feedforward parameters. 



 ComET4 – Commissioning Software 
 User’s Manual 81 

ETEL Doc. / Version N / 31/03/23 

 
Maximum position of measurement. This position should be smaller or equal to 
the maximum software position limit (KL35). 

 
Speed at which the cogging compensation will be measured. 
It is recommended to measure the cogging compensation at low speed. 

 
Maximum acceleration of the motion executed for measuring the cogging 
compensation. 

 
A cycle is composed of a back-and-forth motion. If more than one cycle is used, 
the cogging compensation table will be an average between all cycles. 

 

The cogging compensation table can have up to 8192 points. The points used to 
store the cogging will be equally spaced between the minimum and maximum 
positions. 

 
Cut-off frequency of the low-pass filter used to filter the raw data. 
It can be modified after acquisition of the raw data. 

 

The cogging compensation table is defined between the minimum and maximum 
positions (compensation zone). For a position smaller than the minimum or 
greater than maximum, the first or last point of the table is used. 

To measure correctly the cogging effect, the system must move at constant 
speed, which is not the case during motion acceleration and deceleration phases. 
If these motion phases occur within the compensation zone, the user can choose 
one of the following options: 

- Filtered curve: use anyway the filtered raw data; 

- Constant value: replace the raw data by a constant value (equal to the last 

point obtained at constant speed); 

- Linear interpolation: replace the raw data by a linear interpolation of the 

cogging compensation table. 

It should be noted that if the motion is at constant speed within the compensation 
zone, this option is disabled. The option selected by the user can also be modified 
after acquisition of the raw data. 

 

The measurement is an average between positive and negative directions. 
However, in certain cases, the user might want to use only one direction. 

 

 

 

After having configured the settings above, click on the Start button to initiate the measurement 

procedure for determining the cogging compensation table. A message pops up to warn the user 
that the motor is about to move. 

 

 

 

NOTE The Cogging Compensation tool does not support the Gantry mode. 
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If the safety conditions are assured, click on the Ok button to proceed with the measurement 

procedure. A progress dialog box appears to display the progress 

 

 
 

Once the procedure is completed, the progress dialog box closes and a message is displayed in the 
status bar informing that the procedure is completed. Furthermore, the cogging compensation is 
automatically activated at the end of a successful procedure. 

 

 
 

The raw and filtered measurements of the theoretical current after the advanced filters (MF230) as 

a function of the motor’s position are displayed in the plot area. The user can modify the 

cut-off frequency of the low-pass filter and visualize the effect. Also, the Cogging LKT information in 

area 3 is updated accordingly. 

 

 
 

 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 
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The function of the button controls present on the Plot area are detailed below: 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed magnification ratio. 

 
Undo previous Zoom action. 

 
Pan. 

 

Lock axis (this option is particularly useful to analyze the effect of the different options for the LKT extension; 
if the axis is locked, the user can switch between the options without the inconvenience of the plot being 
refreshed to the default view). 

 
Restore original view. 

 

The next step consists of tuning the friction and acceleration feedforward parameters: 

Friction and Acceleration feedfoward 

To tune these feedforward parameters, the following inputs should be provided (to tool already fills the different fields with proposed 
settings that the user can modify). 

 
Minimum position of measurement. This position should be greater or equal to 
the minimum software position limit (KL34). 

 
Maximum position of measurement. This position should be smaller or equal to 
the maximum software position limit (KL35). 

 Minimum speed at which the friction is measured. 

 Maximum speed at which the friction is measured. 

 Maximum speed used for the acceleration feedforward parameter tuning. 

 Number of different speeds used between the minimum and maximum values. 

 Maximum acceleration used. 

 Jerk time used on every motion. 

 
Possibility to use a friction model with or without hysteresis. 

 
If the friction model with hysteresis is selected, the threshold speed can be 
adjusted. 

 
A moving average filter is used to filter the feedforward response to smooth the 
step at speed 0 or at threshold speed. 

 Select if the cogging compensation should be active (recommended) or not. 

 

After having configured the settings above, click on the Start button to initiate the measurement 

procedure for determining the friction and acceleration feedforward parameters. A message pops 
up to warn the user that the motor is going to move. 
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If the safety conditions are assured, click on the Ok button to proceed with the measurement 

procedure. A progress dialog box appears to display the progress. 

 

 
 

Once the procedure is completed, the progress dialog box closes and a message is displayed in the 
status bar to inform the user that the procedure is completed. Furthermore, the friction feedforward 
is automatically activated at the end of a successful procedure. 

 

 
 

The average of theoretical current after the advanced filters (MF230) as a function of the speed and 

a linear regression fit to this data are displayed in the plot area. Also, the Friction coefficients 

information in area 2 is updated accordingly. 

 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 
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Finally, the user must save the configuration to the Controller. For this, select the Menu Controller 
→ Save Configuration to Controller or click on the Save configuration to controller toolbar button 

. On the Save on Controller dialog box that pops-up, select which axis to save, select the radio 

button control corresponding to the SAV = 0 command for saving the complete configuration on 

the Controller and then click on the Save button. 

Alternatively, this command can also be typed in the Terminal tool. Refer to Section §10.3 for more 
information about saving a Controller’s configuration. 

 

4.2.5. Scale mapping 

Measurements of all linear and rotary encoders include errors with respect to the real position. The 
AccurET’s scale error mapping feature can be used to compensate for the deterministic portion of 
such errors based on an error map provided by the user. 

ComET4’s Scale Mapping tool allows the user to configure the AccurET’s scale error mapping 
feature, to download to the Controller the correction data and to activate/deactivate this feature. 

 

This tool can be launched by selecting the Menu option Tools → Settings → Scale Mapping. 
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Before describing how the Scale Mapping tool works, it is important to refresh some basic notions of 
the AccurET’s scale error mapping feature. 

The table below lists the important Controller registers associated to this feature: 

K165 Enable/Disable the scale error mapping feature: 
= 0 → scale correction disabled; 
= 1 → linear scale mapping mode activated; 
= 4 → cyclic (rotary) scale mapping mode activated. 

K294 Number of points of the scale mapping correction. 

KL166 Position where the scale correction starts. 
Must be zero when using the cyclic scale mapping mode (K165 = 4). 

KL167 Length where the scale mapping correction is active. 

ML9 Gives the scale correction value being applied. 

ML19 Real position before scale correction. 

ML17 Real position after scale correction (ML17 = ML19 + ML9). 

If the scale mapping feature is deactivated (K165 = 0), ML17 = ML19. 

LD0 Look-up table containing the corrections to apply. 

 

When using the linear scale mapping mode, the correction is only applied to the position zone 
defined by KL166 and KL167. The correction for the first and last points of this zone must be zero. 
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The cyclic scale mapping mode is suited for a rotary axis. When using this mode, parameter KL166 

must be set to zero and parameter KL167 must be set equal to the distance in dpi corresponding 

to the value of KL27 (maximum position range limit for a rotary movement; for an infinite rotary 

movement, it corresponds to the value of one turn). Whatever the distance to be covered, the same 
look-up table is applied again and again if the motor is moving. 

 

 

 

 
 

When using the Scale Mapping tool, follow this recommended sequence of actions to properly 
configure the AccurET’s scale error mapping feature: 

1. Activate/Deactivate the pre-processing mode; 
2. Select the activation mode; 
3. Download the scale mapping file; 
4. Activate the scale mapping feature; 
5. Verify if the scale mapping feature is working as expected; 
6. Save the configuration to the Controller. 

 

Pre-processing mode 

 

The user can select the zero-edge pre-processing mode. 

This basically ensures that the first and last scale corrections on the look-up table LD0 will be zero as 

required by the linear scale mapping mode (alternatively, the user can ensure that the first and last 
corrections listed in the scale mapping file are zero and deactivate this feature). 

This option must be activated prior to the download of the scale mapping data to the Controller to have 
the desired effect. Indeed, it is only when downloading the scale mapping data to the Controller that 
ComET4 checks if this option is activated or not. 

NOTE 
When the position is out of the correction zone (defined by KL166 and KL167), the 

applied correction is the last value of the table. 

NOTE 
Whatever the scaling mapping mode, the applied correction is rounded to the integer. 
Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details about the Controller’s scale error mapping feature. 
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If activated, ComET4 reads the scale corrections from the file and appends on-the-fly a zero before the 
first and after the last point when transferring the data to the Controller. Furthermore, ComET4 adjusts 
parameter K294 accordingly and consequently parameter KL167. E.g., if the scale mapping file 

indicates that there are 20 correction points, K294 will be set to 22 to account for these two extra zeros 

added on-the-fly and, consequently, parameter KL167 is increased by 2 times the step size. 

Be aware that enabling this option will indirectly affect where the first correction is applied. Indeed, the 
first correction will be applied at the origin defined in the scale mapping file (corresponding to KL166). 

If this option is activated, the correction that will be applied at this location corresponds to the zero added 
on-the-fly by ComET4 and not to the first correction listed in the scale mapping file. 

 

Activation mode 

 
The user can select between using the linear or cyclic scale mapping modes. 

ComET4 only checks which activation mode is selected at the instant the user clicks on the Activate 
scaling button. Parameter K165 of the Controller is set accordingly: 

K165 = 1 for the linear scale mapping mode; or 

K165 = 4 for the cyclic scale mapping mode. 

 

 
 

After having realized steps 1 and 2, the user must now download the scale mapping file to the 

Controller. Click on the Download to controllers button to select the scale mapping file and press 

on the Open button to initiate the download. 

 

 
 

NOTE 

ComET4 does not notify the user if the linear scale mapping mode has been selected, 
but the first and last scale mapping corrections are not zero as required. It is up to the 
user to ensure that such constraint is respected. 

ComET4 does not notify the user if the cyclic scale mapping mode has been selected, 
but the origin of the mapping (KL166) is not set to zero as required. It is up to the user 

to ensure that such constraint is respected. 
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If the download is completed successfully, the following dialog box pops-up: 

 

 
 

 

On the other hand, if there is a problem with the file format, the following error message pops-up: 

 

 
 

 
 

An example of a scale mapping file is presented below. 

 

[Header] 

 

[[General info]] 

Data type, Scale error mapping 

Data format version, 1.00A 

Software name, ComET4 Scale Mapping tool 

Software version, 4.23A 

Date, 01/01/2020 

Time, 00:00:00 

Operator, John Doe 

Customer, My dearest customer 

Project, Customer application 

Description, X scale error mapping 

 

[[Controller info]] 

NOTE 

Depending on the root cause, other types of error messages might be displayed. 
If required contact an ETEL representative for support on addressing the problem. 

Although downloading a new scale mapping file to the Controller while this feature is 
activated does not raise any error, please follow the recommended steps and ensure 
that the scale mapping feature is deactivated before downloading a new file. 

Downloading a new scale mapping file to the Controller while the axis is powered on will 
raise an error on the Controller. 
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Controller name list, EA-P2M-048-05/10A-0000-01, EA-P2M-048-05/10A-0000-01 

Controller firmware list, 3.19A, 3.19A 

Controller address list, 0, 1 

Controller SN, 12345678, 12345678 

Controller status, 0x20290000, 0x20290000 

 

[[Scale error mapping configuration]] 

Mapping version, 1.01A 

Machine type, METIS 

Machine SN, 12345 

Correction mode, positive 

Axis, X, 0 

 

[[[Configuration 1]]] 

Corrected axis, X 

Source axes, X 

Source registers, ML19 

Correction table, table 1 

Origin, X, 0.1 

 

[Data] 

 

[[Info table 1]] 

Step size, 1.0e-3 

Table size, 20 

Data unit factor, -9 

 

[[Data table 1]] 

-10.0,20.0,-10.0,20.0,20.0,-10.0,20.0,-10.0,20.0,20.0,-10.0,20.0,-10.0,20.0,20.0,-

10.0,20.0,-10.0,20.0,20.0 

 

[End Of File] 

 

 
 

It is a plain text file hierarchically organized by sections: 

• [Header] 

o [[General info]] 

o [[Controller info]] 

o [[Scale error mapping configuration]] 

▪ [[[Configuration 1]]] 

• [Data] 

o [[Info table 1]] 

o [[Data table 1]] 

 

All sections are mandatory and the file format must be respected (e.g. 1st level sections are 
embraced by single squared brackets, 2nd level sections are embraced by double squared brackets 
…). However, part of the information contained in some sections is not mandatory. In the example 
below, the information displayed with a grey font is facultative. 

 

NOTE 
In the above example of a scale mapping file, the greyed text is not mandatory. 
The file format must be respected, including the closing line [End Of File]. 
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Header 

General info Identify the data type and format. Remaining information is not mandatory. 

Controller info Non mandatory information related to the Controller (product type, firmware version…). 

Scale error mapping 

configuration 

Define the correction mode (positive or negative) and assign a virtual axis identifier to a real 
physical axis. This identifier is used in the remainder of the file to identify the concerned axis. 
Remaining information is not mandatory. 

Configuration 1 Identify which axis is going to be corrected, which are the source axis and source register, the 
correction table and the origin of the correction (corresponds to KL166). 

Data 

Info table 1 Define the step size (KL167 = (K294 – 1)*step_size), the table size (corresponds to 

K294) and a conversion factor to apply to the data table. 

Data table 1 Comma separated list of corrections, as many values as indicated by the table size defined in 
Info table 1. 

When downloading this table to the Controller, for each correction it is applied the Data unit 

factor defined in Info table 1.  

 

Once the scale mapping file has been successfully downloaded to the Controller, click on the 

Activate scaling button to activate the feature (Controller’s parameter K165 is set accordingly to the 

activation mode selected). If the activation is successful, the following message pops-up. 

 

 
 

 
 

Clicking on the Deactivate scaling button will reset parameter K165 to zero (K165 = 0). 

 

 
 

In order to verify if the scale mapping feature is working as expected, use the Scope tool to trace 
monitorings ML19 and ML17. Position the axis at a location within the position zone where the scale 

corrections are applied (defined by KL166 and KL167) and activate/deactivate the feature to check 

the effect on the real position after scale correction (ML17). Don’t forget that a homing must have 

been done previously and ensure that the correction for the position where the axis is located is 
different from zero to be able to visually verify its effect. 

NOTE 
Even if the scale mapping feature has been successfully activated (K165 ≠ 0), the 

corrections are only applied to the real position after a homing is done. 
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In the above Scope tool screenshots it is possible to observe the effect of activating and deactivating 
the scale mapping feature. When the feature is activated, ML17 becomes different from ML19 by 

the scale correction for that location. Inversely, when the feature is deactivated, ML17 and ML19 

have the same value. 

 

 
 

Finally, the user must save the configuration to the Controller. For this, select the Menu Controller 
→ Save Configuration to Controller or click on the Save configuration to controller toolbar button 

. On the Save on Controller dialog box that pops-up, select which axis to save, select the radio 

button control corresponding to the SAV = 0 command for saving the complete configuration on 

the Controller (including the mapping registers) and then click on the Save button. 

Alternatively, this command can also be typed in the Terminal tool. Refer to Section §10.3 for more 
information about saving a Controller’s configuration. 

 

Scale 
mapping 
activation 

Scale 
mapping 

deactivation 

NOTE 

There are others ways of verifying if the scale mapping feature is working as expected. 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details about the Controller’s scale error mapping feature. 
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4.2.6. Stage mapping 

The AccurET’s stage mapping feature allows the user to apply an error compensation to the 
concerned axes within a given operational area (2D) or volume (3D). 

Each axis that has to apply the stage error compensation along its corresponding direction will 
contain a stage mapping table and the information to determine and apply the correction (e.g. origin 
of the coordinates of the mapped area, step size, number of steps…). The information about the 
position of the other axes is provided through TransnET. 

 

 
 

ComET4’s Stage Mapping tool allows the user to download/upload to/from the Controllers the stage 
mapping data, to display the contents of a stage mapping file, to save the stage mapping data into 
a file, to modify the stage mapping data and to activate/deactivate this feature. 

This tool can be launched by selecting the Menu option Tools → Settings → Stage Mapping: 

 

 
 

NOTE 

The stage mapping feature requires the presence of an UltimET motion controller. This 
feature cannot be used with an individual AccurET position controller. 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details about the Controller’s stage mapping feature. 
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Before describing how the Stage Mapping tool works, it is important to refresh some basic notions 
of the AccurET’s stage mapping feature. 

The table below lists the main Controller registers associated to this feature: 

K365 Enable/Disable the stage mapping feature: 
= 0 → stage mapping disabled; 
= 1 → stage mapping enabled. 

M21 Gives the stage mapping compensation value. 

ML17 Real position after scale mapping and before stage mapping. 

ML1 Real position after stage mapping. 

P Registers where the stage error mapping information is stored. 
There are 16352 P registers and each P register has 8 depths (0 to 7). Thus, a total of 130816 correction 

values can be stored for each axis. 

 

The stage mapping feature can be used in many different mapping configurations, but here are a 
few examples: 

Mapping configuration Map dimension Source axes Corrected axes 

3D stage error mapping 3D X, Y, Z X, Y, Z 

X-Y-Theta 3D stage error mapping 3D X, Y, Theta X, Y 

2.5D stage error mapping 2D X, Y X, Y, Z 

2D stage error mapping 2D X, Y X, Y 
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The stage error mapping configuration is measured and defined by the user. The border between 
mapped and non-mapped areas/volumes should be smoothed by the user to have no correction in 
the non-mapped part. By default, the Controller automatically add a zero-correction range all around 
the mapping area/volume to apply a transition between areas. This transition is done on a one step 
size in each dimension. 

 

 
 

 
 

The Stage Mapping tool is composed of two main panels: 

• Configuration panel, where the mapped and source axes are defined; and 

• Corrections panel, where the map of corrections is defined. 

 

 

NOTE 
Other mapping configurations besides the standard examples presented above can be 
realized based on the same principle. Contact your ETEL representative for support on 
designing the stage mapping for your application. 

Measured 
corrections 

area 

Zero correction edge 
not in the mapping area, but 

used as it is in AccurET 

NOTE 
The stage mapping is done on a set of coordinates. Between these coordinates, a linear 
interpolation is applied. 
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When using the Stage Mapping tool, follow this recommended sequence of actions to properly 
configure the AccurET’s stage mapping feature: 

1. Under the Configuration panel, identify the system to which the mapping data refers and 

define the mapped and source axes according to the mapping configuration (e.g. 2D, 2.5D or 
3D); 

2. Under the Corrections panel and according to the selected mapping configuration, define the 

mapping tables using this tool or reading the correction data from a file; 
3. Configure the transition smoothing from mapped to non-mapped areas/volumes; 
4. Download the stage mapping data to the Controllers; 
5. Activate the stage mapping feature; 
6. Verify if the stage mapping feature is working as expected; 
7. Save the configuration to the Controller; 
8. If necessary, save the stage mapping configuration and correction data to a file (e.g. for 

backup purposes). This file can be reloaded to the Stage Mapping tool if required. 

 

Configuration panel 

 Input the type of machine (e.g. METIS, VULCANO2, CHARON2…). 

 Input the machine’s serial number. 

 Define the version of the mapping. 

 
Define if the correction should be added or subtracted to ML17. 
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Define the mapped and source axes. 
 

Double click on the axis Name edit control to rename an axis: 

 
 

Double click on the Axis Number edit control to modify an axis number: 

 
 

To add a new axis right-click on the table and select Insert row: 

 
 

To delete an axis right-click on the table and select Delete row: 

 
 

Check the Source only checkbox control for the axes that are not to be mapped, 

but on which depends the mapping of another axes. 

 

Under the Corrections panel, there are as many sub-panels as mapped axes defined in the 

Configuration panel (source axes only excluded). E.g., if the user has created the mapped axes X 

and Y in the Configuration panel, two sub-panels X and Y are available in the Corrections panel. 

 

  
 

Therefore, for each one of the sub-panels under the Corrections panel (e.g. X, Y), the user must 

input the following information: 

Corrections panel 

 

Unique identifier for this mapping table (starting from 0). If not, the following 
error is raised: 
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Conversion factor to apply to the mapping data when downloading it to the 
Controllers. 

 

- Source axis for this mapping; 
- Origin of the mapping along this axis; 
- Step of the mapping along this axis; 
- Number of mapping points; 
- Source register (usually ML17, but can be another); 

- If it is a cyclic axis (i.e. rotary axis) that repeats over one turn. 
 
To add another dimension (i.e. source axis) to the mapping table right-click on 

the table and select Add x dimension: 

 
 
Similarly, to remove a dimension (i.e. source axis) from the mapping table right-

click on the table and select Remove x dimension: 

 
 
Finally, two dimensions (i.e. source axis) of the mapping table can be swapped 

by right-clicking on the table and selecting the Swap dimensions option: 

 

 

So, here are examples of how the Configuration and Corrections panels should look like for the 

typical mapping configurations presented before (3D, 2.5D, 2D). 

Mapping configuration Configuration panel Corrections panel 

3D stage error mapping  

 

For each of the 3 sub-panels: X, Y and Z 

 

X-Y-Theta 
3D stage error mapping 

 

 

For each of the 2 sub-panels: X and Y 

 

2.5D stage error mapping 

 

 

For each of the 3 sub-panels: X, Y and Z 

 

2D stage error mapping 

 

 

For each of the 2 sub-panels: X and Y 
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For sake of simplicity, the following explanations refer to a 2D stage error mapping configuration 

with two source axis (X and Y) and two mapped axis (X and Y). 

Once the Configuration and the Corrections’ X and Y sub-panels have been set as described 

previously, including the origin, step and source register for every dimension, the user has two 

options for creating the correction data for each of the mapped axis X and Y: 

1. Define the number of points for each dimension of the stage mapping (this will define the size of 

the 2D correction matrix) and input the correction values directly via the Stage Mapping tool; 

 

 
 

The user can always backup the stage mapping data to a file by clicking on the Export Correction 
Data button, entering the file name in the dialog box that pops-up and pressing the Save button. 

 

 

 

 

2. Import the correction data from a file. After reading the file, and provided there is no issue with 

its format, the Stage Mapping tool will display the correction values and automatically set the 
number of points accordingly. 

user input 

user input 
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The correction data file is a plain text file with a given format. This format is explained in the tooltip 

that is displayed when hovering with the mouse over the Import Correction Data button. 

 

automatically filled 

automatically filled 

NOTE 

Be aware that when downloading the stage error mapping data to the Controllers, the 

Correction Unit factor selected on the corresponding drop-down list box will be applied. 

Bear this in mind when defining the correction values. 
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It is basically based on a comma-separated values (CSV) format, but with a small twist: empty lines 
make the separation between blocks of mapping data. 

One block of mapping data is a 2D map, i.e. a two dimensional matrix of size NxM, where N 

represents the number of lines of the block and M the number of comma-separated values per line. 

The several blocks represent the third dimension for being able to define 3D maps. 

For the example above, the file contains a single block (2D map) representing a 3x3 matrix (3 lines 
and 3 comma-separated values). 
 

 
 

 

The following example below would represent a 3D map file, a matrix of 3x3x3 (3 lines and 3 comma-
separated values per block and 3 blocks) 

 

 

 

 
Be aware that the file with the correction data has no information whatsoever concerning the origin 
and step at which the corrections are applied. This information must be properly set in the 

Corrections’ sub-panels. 

0.001,0.002,0.003 

0.004,0.005,0.006 

0.007,0.008,0.009 

0.001,0.002,0.003 

0.004,0.005,0.006 

0.007,0.008,0.009 

 
0.011,0.012,0.013 

0.014,0.015,0.016 

0.017,0.018,0.019 

 
0.021,0.022,0.023 

0.024,0.025,0.026 

0.027,0.028,0.029 
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If the file contents do not match the configuration set in the Stage Mapping tool, an error is generated 
when importing the data. E.g. in this case the user is trying to import a 3D map correction while the 

Stage Mapping tool has only two mapped axis defined: 

 

 
 

Also, be very careful about any formatting mistakes included in the corrections data file. These are 

not flagged with an error by the Stage Mapping tool while importing the data, but still the outcome 
might give unexpected results. 

In the example below, the user forgot to add in the first line the second comma and the third value 
(,0.003). The result after importing the file is still a 2D map file as expected, but the data related 

to one step for the X dimension is completely missing (the resulting matrix is 3x2, instead of the 

expected 3x3 matrix). 

 

 
 

 

Here is another mistake similar to the previous one, but on the second line (,0.006 is missing). In 

this case, the result is still a 3x3 matrix as expected, but the corrections are not assigned to the right 

locations and a zero correction is added to the last [X, Y] mapped location. 

 

 
 

 

Once error mapping data has been created for the concerned mapped axes, the user can next 
configure the transition smoothing from mapped to non-mapped areas/volumes by clicking on the 

Smooth Correction Data button. Configure how many steps to be used for the smoothing and select 

one of the two possible algorithms available: linear or sinusoidal smoothed transition. 

0.001,0.002,0.003 

0.004,0.005,0.006 

0.007,0.008,0.009 

0.001,0.002,0.003 

0.004,0.005,0.006 

0.007,0.008,0.009 
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After having created the error mapping data for all the mapped axes (i.e. for all Corrections’ sub-

panels X and Y) and configured the transition smoothing, the stage mapping data is finally ready for 

being downloaded to the Controllers. Press the Download to Controllers button and if the download 

is successful, the following information message pops-up: 

 

 
 

 

 

Next step consists on activating the stage mapping feature by clicking on the Activate Mapping 

button (Controllers’ parameter K365 will be set accordingly and all real-time value channels set 

accordingly to exchange the information over TransnET). A dialog box appears for the user to select 
which mapping axis group to download: 

 

 
 

The concept of mapping axis group was not yet introduced. Basically, the Stage Mapping tool allows 

to create/manage multiple mapping axis groups. E.g. consider a dual-gantry system with X1/Y1 axes 

for one gantry and X2/Y2 axes for the other gantry. With the Stage Mapping tool, the user can create 

an error map for (X1,Y1) and another error map for (X2,Y2), which are managed as two separate 

mapping groups. 

NOTE 
When downloading the stage mapping data, the Controllers will power off the motors 
which are powered on. 
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Select the mapping group and press the OK button to activate the stage mapping feature on the 

concerned Controllers. If the activation is successful, the following message pops-up: 

 

 
 

On the other hand, in case of an issue with the activation of the stage mapping feature, an error 
message pops-up to inform the user of the nature of the problem. E.g. the following message informs 
the user that one of the axis concerned by the mapping was in error or not homed (this was indeed 
the root cause) and for that reason the activation of the stage mapping feature failed. 

 

 
 

 
 

To deactivate the stage mapping feature, click on the Deactivate Mapping button, select the 

mapping axis group to deactivate from the dialog box and press the OK button. 

 

 
 

Upon a successful deactivation, the following information message pops up and parameter K365 of 

the concerned axes will be reset to zero (K365 = 0). 

 

 
 

NOTE 
Depending on the root cause, other types of error messages might be displayed. 
If required contact an ETEL representative for support on addressing the problem. 
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The user can inquire about the status of the stage mapping feature (activated or deactivated) by 

clicking on the Check Mapping State button on the Configuration panel. A message dialog box pops 

up with the status of the stage mapping feature. Click either OK or Cancel to close it. 

 

 

 

 

 

 

 

 
 

In order to verify if the stage mapping feature is working as expected, use the Scope tool to trace 
monitorings ML17 and ML1. Position the axes at a location within the position area/volume where 

the stage corrections are applied and activate/deactivate the feature to check the effect on the real 
position after stage correction (ML1). Don’t forget to ensure that the correction for the position where 

the axes are located is different from zero to be able to visually verify its effect. 

 

NOTE 

INCONSISTENT MAPPING means that all axes belonging to a same mapping group do 

not have the same mapping state (either all active or all inactive). 

To recover from this state, deactivate the stage mapping feature on the concerned group 
and reactivate it again if this is the state it should be. 
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In the above Scope tool screenshots it is possible to observe the effect of activating and deactivating 
the stage mapping feature. When the feature is activated, ML1 becomes different from ML17 by the 

stage correction for that location. Inversely, when the feature is deactivated, ML1 and ML17 have 

the same value. 

 

 
 

The next step consists on saving the configuration to the Controller. For this, select the Menu 

Controller → Save Configuration to Controller or click on the Save configuration to controller 
toolbar button . On the Save on Controller dialog box that pops-up, select which axis to save, 

select the radio button control corresponding to the SAV = 0 command for saving the complete 

configuration on the Controller (including the mapping registers) and then click on the Save button. 

Alternatively, this command can also be typed in the Terminal tool. Refer to Section §10.3 for more 
information about saving a Controller’s configuration. 

 

Stage 
mapping 
activation 

Stage 
mapping 

deactivation 

NOTE 
There are alternative ways of verifying that the stage mapping feature is working as 
expected. Refer to the AccurET Modular Position Controller Operation & Software 
Manual for details about the Controller’s stage error mapping feature. 
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The user can also save (backup) the stage mapping configuration and correction data to a file. 

Simply go to File → Save As…, type in the file name and click on the Save button. 

 

 
 

NOTE 

Be aware that saving the configuration to the Controller only guarantees that the stage 
mapping correction data is stored and, thus, available after rebooting the Controller(s). 

However, all the configuration related to the exchange of information about the position 
of the axes over TransnET through Real-Time Values (RTVs) that is required for the 

Stage Mapping functionality is lost after rebooting the Controller(s). 

This configuration needs to be reprogrammed by the user at each startup of his system 
either through his application based on EDI or a Sequence running on one of the 
Controllers. 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
details about the Controller’s stage error mapping feature or contact an ETEL 
representative for support. 
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If the file already exists, a warning message pops-up allowing the user to confirm or not the 

overwriting. Click on the Yes button to overwrite or on the No button to cancel the operation of saving 

the stage mapping data. 

 

 
 

The format of the stage mapping file is very similar to the scale mapping file format (refer to Section 
§4.2.5). An example of a 2D stage mapping file is presented below. 

 

[Header] 

[[General info]] 

Data type, Stage error mapping 

Data format version, 1.00A 

Software name, ComET Stage mapping tool 

Software version,4.23A 

Date, 01/01/2020 

Time, 00:00:00 

NOTE 

Ensure that the Stage Mapping tool detains the interface focus before attempting to save 

the stage mapping file. Or else, it can happen that the option Save As… under the Menu 

File is disabled or, even more deceiving, it might be enabled in relation to another tool 

detaining the interface focus (e.g. the Editor tool). 

TIP 
Use the custom file extension *.emap for stage mapping files and associate it to the 
ComET4 software, making it the default application for this type of file. 
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Operator, John Doe 

Customer, My dearest customer 

Project, Customer application 

Description, XY stage mapping 

 

[[Controller info]] 

Controller name list, EA-P2M-048-05/10A-0100-01 

Controller firmware list, 3.18A 

Controller address list, 1, 0 

Controller SN, 40930067, 0 

Controller type list, 0, 0 

Controller status, 0x0, 0x0 

 

[[Stage error mapping configuration]] 

Mapping version, 1.00A 

Machine type, METIS 

Machine SN, 12345678 

Correction mode, positive 

Axis, X, 0 

Axis, Y, 1 

 

[[[Configuration 0]]] 

Corrected axis, X 

Correction dimensions, 2 

Source axes, X, Y 

Source registers, ML17, ML17 

Correction table, table 0 

Origin, X, 0.000000 

Origin, Y, 0.000000 

 

[[[Configuration 1]]] 

Corrected axis, Y 

Correction dimensions, 2 

Source axes, X, Y 

Source registers, ML17, ML17 

Correction table, table 1 

Origin, X, 0.000000 

Origin, Y, 0.000000 

 

[Data] 

[[Info table 0]] 

Step size, 1.000000e-01, 1.000000e-01 

Table size, 3, 3 

Data unit factor, -3 

 

[[Data table 0]] 

0.001000, 0.002000, 0.003000 

0.004000, 0.005000, 0.006000 

0.007000, 0.008000, 0.009000 

 

[[Info table 1]] 

Step size, 1.000000e-01, 1.000000e-01 

Table size, 3, 3 

Data unit factor, -3 

 

[[Data table 1]] 

0.001000, 0.002000, 0.003000 

0.004000, 0.005000, 0.006000 

0.007000, 0.008000, 0.009000 

 

[End Of File] 
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It is also a plain text file hierarchically organized by sections: 

• [Header] 

o [[General info]] 

o [[Controller info]] 

o [[Stage error mapping configuration]] 

▪ [[[Configuration 0]]] 

▪ [[[Configuration 1]]] 

• [Data] 

o [[Info table 0]] 

o [[Data table 0]] 

o [[Info table 1]] 

o [[Data table 1]] 

 

Header 

General info Contains information about the data type and data format version of the stage mapping file, which 
ComET4 tool and version was used to generate the file and the time and date of file generation. 
The remaining information about the operator, customer, project and description are left empty and 
can be edited by the user as will using a text editor of his choice. 

Controller info Contains information related to the Controller(s) (product type, firmware version…). 

Stage error mapping 

configuration 

Contains information about the mapping version, the machine type and serial number. It also 
includes information about the correction mode to apply (positive or negative) and the 
correspondence between virtual axes to a real physical axes identifiers. These identifiers are used 
in the remainder of the file to identify the concerned axes and improve the file’s readability. 

Configuration 0 / 1 Identifies the corrected axes, the correction dimensions (2 for 2D, 3 for 3D), the source axes and 
source registers, the correction table and the origin of the correction. 

Data 

Info table 0 / 1 Contains information about the step size, the table size and the conversion factor to be applied to 
the data table. There are two tables for 2D maps and three tables for 3D maps. 

Data table 0 / 1 Table of corrections, with as many lines and comma separated values as indicated by the table 
size in Info table 0 / 1. There are two tables for 2D maps and three tables for 3D maps. 

In addition, for 3D tables, there is an empty line separating the blocks of data relative to the third 
dimension (just as the format of the correction data file presented before). 

When downloading this table to the Controller, for each correction it is applied the Data unit 

factor defined in Info table 0 / 1. 

 

An existing stage mapping file can also be opened with the Stage Mapping tool. Simply go to File → 
Open…, select the file to open and click on the Open button. 

 

NOTE 
The stage mapping file can be edited with any text editor, but the format must not be 
modified, including the closing line [End Of File]. 
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If the current stage mapping data being edited by the Stage Mapping tool has been modified and not 
yet saved, a warning message pops-up allowing the user to decide the right action to take. Click on 

the Yes button to save the existing configuration before loading the new one, or on the No button to 

proceed with the loading without saving the existing configuration or on the Cancel button to simply 

abort the whole operation. 
 
  

NOTE 

Ensure that the Stage Mapping tool detains the interface focus before attempting to open 

the stage mapping file. Or else, it can happen that the option Open… under the Menu 

File is disabled or, even more deceiving, it might be enabled in relation to another tool 

detaining the interface focus (e.g. the Editor tool). 
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Once loaded to the Stage Mapping tool, the mapping configuration and correction data can be 
modified if required or simply downloaded to the Controllers and the stage mapping feature activated 
as explained previously. 
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5. Setting of other control modes 

The AccurET position controller can be configured to operate in other control modes besides the 
standard position control of an axis. The other control modes available are: 

• Force control; 

• QuiET; and 

• ZxT. 

The following Sections introduce the tools available in ComET4 for commissioning these less 
conventional control modes available in the AccurET position controller. 

 

 
 

5.1. Force Control 

The force control mode addresses those applications requiring the execution of motion in a position 
controlled way with a seamless transition to force control mode in the final stage of the movement 
to accurately control an applied contact force. 

 

 
 

The AccurET’s force control feature offers various modes of operation targeting different types of 
applications. 

 

5.1.1. Force control action 

A force control action is made of three distinct phases: 

1. Fast Motion 
The axis is moved at high dynamics using a standard position controller. This brings the tooltip 
at a predefined position and with a predefined residual constant speed. This residual speed is 
used as approach speed in the next phase. 

2. Low Speed Approach 
The axis moves at a low constant speed. The touchdown detection is activated during this phase. 

3. Force Control 
As soon as touchdown (contact) is detected, the Controller is switched to force control mode. 
The force reference is tracked until force control is ended. 

NOTE 
The QuiET and ZxT control modes are not supported by the ACCURET+ position 
controllers. 

NOTE 

The single axis force control mode available in the AccurET position controller is not 
suited to control actuators where several axes affect the contact force (e.g. dual-axis 
actuator with a short and long stroke axis). Refer the AccurET Modular Position 
Controller Operation & Software Manual for details about the Controller’s force control 
mode. 
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5.1.2. Force control modes 

The AccurET’s force control modes of operation use different control schemes during the low speed 
approach phase and during the force control phase. There are three main modes of operation 

designated as Mode 0, 1 and 2. 

 

Mode Low speed approach Force control (after touchdown) 

0 PID position controller tracking a position ramp Control loop build around the position control loop 

1 PID position controller tracking a position ramp Control loop build around the current control loop 

2 P speed controller with constant speed reference Open loop control of the current control loop reference 

 

5.1.2.1. Choosing the right mode of operation 

The three available force control modes offer different performance tradeoffs. The choice of the 
mode of operation therefore depends on the type of axis and application. 

• Mode 0 can be seen as a multi-purpose mode of operation. It is robust with most types of axes 

and works with all choices of estimator settings (i.e. sensorless, sensor-based, with/without 
spring compensation). The downside is that it reaches a lower bandwidth compared to the other 
modes, leading to a slower force settling time. 

• Mode 1 has the same scope of application as Mode 0. However, it can achieve higher 

bandwidths at the cost of a somewhat reduced robustness. 

• Mode 2 has the fastest force settling time, but it is limited to low friction (or frictionless) axes 

without pre-constraint spring. It works without estimator in the loop and is limited to sensorless 
applications. Wire bonding heads are typical applications for this mode of operation. 

 

 

NOTE 
In sensorless applications (Mode 0/1 with sensorless estimator and Mode 2), the 

accuracy of the applied force after settling depends on the accuracy of the motor 
constant Kt. It is also influenced by axis friction. 
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5.1.2.2. Low speed approach phase 

The control strategy for the low speed approach varies according to the selected force control mode. 

In Modes 0 and 1, the approach is performed with the axis position controller, the reference of which 

is computed from the output of an integrator (position ramp). Refer to the AccurET Modular Position 
Controller Operation & Software Manual for details on setting up the appropriate gains manually. 

The Force Control Tool allows setting these by simply specifying the desired approach speed. 

In Mode 2, the control strategy during approach is different. The speed is stabilized by a simple 

proportional speed controller with gain D (the same gain value as used during force control, see 
Section §5.1.2.3. 

While stability during the low speed approach is guaranteed by a proper position control loop design 

in Modes 0 and 1; in Mode 2, stability must be ensured when tuning the force controller. This is part 

of the Force Control Tool’s commissioning tasks. 

 

5.1.2.3. Force control phase 

In Mode 0, the force controller acts on the axis position reference and is fed back via a force 

estimator. 
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In Mode 1, the force controller acts on the axis current references and is fed back via a force 

estimator. 

 

Plant Estimator
Iq,real

pos

(Fsensor)

Iq,theo
Force 

controller 
mode 1

Fref
Fest

 
 

In Mode 2, the force controller applies a current reference directly derived from the (filtered) force 

reference. The feedback loop only features stabilization via damping (D gain and filtering). The force 
estimator is not in the feedback loop. 
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5.1.2.4. Touchdown detection 

The switching between the low speed approach phase and the force control phase is triggered by 
the touchdown detection. Two types are available: 

1. Detection on estimated force level. This is the recommended detection type for most applications 

using Modes 0 and 1; 

2. Detection on measured speed level. In Modes 0 and 1, the threshold speed is specified as an 

absolute speed value. In Mode 2 the threshold is specified relative to the chosen approach speed 

in percent [%]. This is the recommended detection type in Mode 2. 

 

5.1.2.5. Force estimator 

The AccurET features a force estimation algorithm. The output of the force estimator has multiple 
purposes: 

1. Feedback value for the force control loops in Modes 0 and 1; 

2. Force value reading for touchdown detection (mainly in Modes 0 and 1); 

3. Force values reading for assessing settling with respect to specification windows (Modes 0, 1 

and 2). 

 

The force estimator has three main modes of operation: 

1. Using a force sensor. If the sensor is moving with the axis, acceleration effects can be 
compensated for; 

2. Sensorless operation. In this mode, the force is estimated based on motor current (using the Kt 
motor constant), speed, acceleration, etc. are used to compensate for dynamic effects; 

3. Sensorless operation with spring-compensation. This mode 
is identical to the above one with additional position-based 
compensation for use cases featuring a pre-constrained 
spring. Use this mode if the axis is preloaded with a spring 
and the spring force is not a component of the force to be 
applied to the contact surface. 

 

5.1.3. Force Control Tool 

The Force Control tool allows the user to configure the force control mode on one of the axis of an 
AccurET position controller. This tool is one of ComET4’s so-called external tools consisting of a 
MATLAB-based standalone application. 
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The Force Control tool can be started by selecting the Menu option Tools → Settings → Force 
Control: 

 

 

 

Or by executing the file ForceControlTool.exe that can be found under: 

“C:\Program Files (x86)\ETEL SA\ComET-4.xxY\external-tools\ForceControlTool\”. 
 

 
 

At startup of the Force Control tool, a warning message informs the user of the conditions to be 

fulfilled to ensure optimal operation. Click on the OK button to proceed. 

 

 

 

NOTE 

The Force Control tool requires the prior installation of the MATLAB Compiler Runtime 
(MCR) version 2019b, which can be downloaded from: 
http://www.mathworks.com/products/compiler/mcr/. 

This tool will take several seconds to initialize while the MCR is being loaded into 
memory. 

MATLAB® is a numerical computing environment and proprietary programming language 
developed by The MathWorks Inc. 

NOTE 

The Force Control tool can only be executed on a 64-bit Windows Operating System. 
Furthermore, the tool can only be used together with an AccurET position controller 

running firmware 3.10A or above. For the force control Mode 2 the firmware version 

must be 3.19B or above. 

http://www.mathworks.com/products/compiler/mcr/
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5.1.4. General Workflow 

The Force Control tool is divided in six main tabs, each corresponding to a specific step in the 
workflow for tuning a force control axis: 

1. General: set axis type, units to be used in the tool, sensor type if available and force contact 
direction. 

2. Identification: contact identification and free identification (when axis not in contact). When 
using a sensor, a measurement of the Kt motor constant is also performed during contact 
identification. 

3. Estimator: tune the force estimator (with sensor or sensorless). 

4. Force Controller: tune force controller for operation Mode 0, 1 or 2. 

5. Protections: set axis protection parameters to prevent damages. 

6. Touchdown: run touchdown experiments in operation Modes 0, 1 or 2 to assess tuning 

performances. 

 

Connection
Identification Tab
• Contact
• Free

Estimator Tab
• With/without 

sensor
• With/without 

spring

General Tab
• Axis type
• Units
• Sensor def
• Direction

Mode 0

Mode 1

Mode 2

Protections Tab
• Saturations
• Limits

Touchdown Tab
• Set motion
• Set dynamics
• Touchdown 

experiment

Force Control TabExport CSV Export CSVAt any time:
Save tool state 

to XML

Estimator 
parameters

System 
paramters

Protection 
parameters

Touchdown 
parameters

FC Mode 0/1/2 
parameters

 

 

At any time, the current tool state can be saved to (File → Save to XML) or loaded from an XML file 

(File → Load from XML). The XML file will retain the following information: 

1. Identification measurements; 
2. Tuning gains and drive registers relevant for force control features (called parameter sets in the 

tool); 
3. Time traces of last touchdown experiment. 

 

 
 

In addition to the XML format, identification and time-domain experiment results can be saved 
individually to CSV format. The time-domain data is compatible with the ComET4 scope. 

 

 

NOTE Loading an XML file will overwrite all information in the tool with the content of the file. 
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5.1.5. Connection 

Before interacting with a force control axis, the user needs to establish the communication. This is 
done via the dedicated panel always visible on the top of the tool’s interface. 

 

 

 

Connection bar 

 

Selects the type of connection. Local connections are available by default (UltimET and 
USB). Additional remote connections are listed. If ComET4 is connected to an axis upon 

starting the tool, the connection will be shared and labelled Auto connection. 

 
Connect / Disconnect to a remote IP address. 

 Choose force control axis once a connection type is chosen and established. 

 

Basic axis commands: 

• RST reset axis; 

• ON power on; 

• OFF power off; 

• IND perform a homing. 

 Current axis status. 

 

 
 

5.1.6. Parameter sets instances 

The force control features in the AccurET position controller are configured via numerous registers. 
To clarify and ease the tuning process, registers related to force control operations have been split 
in non-overlapping parameter sets, each corresponding to separate sub-functionalities. Each tuning 
tab in the tool (except for the Identification tab) is dedicated to the tuning of one of the parameter 
sets. Detailed parameter sets content is given in Section §5.1.15. 

Furthermore, for each parameter set, multiple instances can be created. This allows experimenting 
with different tuning settings and easily switch between these. It is important to note the following 
behavior: 

• The different instances of a given parameter set are identified with a user-editable name. 

• The first instance of each set has the name FromDrive and cannot be edited. This parameter set 

is systematically loaded with the Controller’s register content upon each connection and each 
axis selection. 

• To create a new instance, an existing parameter set is selected and then copied (duplicated). 
The copied set can then be edited or used as basis for further tuning. 

• The active parameter set instance is the instance whose name is currently selected. This is the 
set used by the tool for tuning and for executing touchdown tests. 

NOTE 
The Force Control tool is a MATLAB-based standalone application. Therefore, the 
connection to the drive axis is independent from the ComET4 application instance. 
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• The tuning results are stored in the corresponding active parameter sets, but they are not saved 
nor written to the Controller. Active parameter sets can be written to the Controller individually 

from the corresponding tab or all at once from the menu Controller → Active parameters → 
Write all to axis. 

• When an experiment is carried out (touchdown), the axis parameters are backed-up, all active 
parameter sets are written to the Controller, the experiment is performed and then the backed-
up parameters are restored to the Controller. 

• All active parameter sets can be read at once from the Controller with Controller → Active 
parameters → Read all from axis. 

• All active parameter sets can be written at once to the Controller with Controller → Active 
parameters → Write all to axis. Note that the values are written to the Controller registers, but 

not saved (no SAV command is issued). 

 

The following depicts the access panel for the Active Estimator Parameter Set in the Estimator 

tab, showing either the FromDrive instance as active or a user editable instance named 

MyParamName_1. 

 

 

 

 

Active parameter selection 

 

Select active parameter set from the list of available parameters. The list contains the 

FromDrive instance followed by all user-created instances. The values from the active set 

are used throughout the tool (either tuned or used for experiments). 

 
Edit the name of the currently selected parameter set. The name of the FromDrive 

parameter set cannot be edited. 

 

Duplicate the active parameter set. The name is initialized with a unique variant of the 
duplicated set name and can be edited afterwards. 

 Overwrite the active parameter set with the Controller (axis) register values. 

 Write active parameter set content to corresponding Controller (axis) register values. 

 Delete active parameter set. The first set FromDrive cannot be deleted. 

 
Edit parameters manually. Opens a popup window with an editable parameters. Note that 
this button is not available for all parameter sets. 
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5.1.7. General tab 

The General tab groups the settings of some basic tool-wide parameters. 

 

5.1.7.1. Active System Parameter Set panel 

This parameter set contain only two properties related to force control applications: 

 

Active System Parameter Set panel 

 
Sets the lever arm length for rotary actuators. Set this field to 1 [m] if using a linear actuator. If a 
value different from 1 [m] is used with a linear axis, a warning message is displayed. 

 
Motor force constant in [N/A] for linear axes and [Nm/A] for rotary axes. When using a force sensor, 
the value is measured during identification and can be copied here. 

 

The System Parameter Set also contains other Controller register values that are not editable from 

the tool (refer to Section §5.1.15). These are not related to force control, but directly influence the 
force control behavior and performance. 

 

 

 

5.1.7.2. Displayed Units panel 

Units used for displaying position and current values throughout the tool user interface can be 
selected here: 

 

Displayed Units 

 
 

Units for positions displayed in the tool. When choosing a linear position unit with a rotary axis, 

the Lever arm value is used as a conversion factor. 

 
Current units used throughout the tool. Motor Kt and Lever arm are used for converting between 

current values in Ampere and force or torque values. 

 

Whenever a value is displayed in units requiring a conversion factor dependent on some parameter 
value, the unit name is shown with an “*” appended to it. This should attract the user’s attention to 
the fact that the displayed value will change if for example the Lever arm or Motor Kt values are 
modified. 

The unit name will be displayed in red if the conversion is problematic (e.g. Lever arm set to zero). 

NOTE 

If system parameters (position loop PID gains, advanced filters 1-4, current loop PI 
gains) are modified outside the tool after the tool was connected to a controller, the 
system parameter sets (also the FromDrive set) in the tool will not correspond to the 

drive values anymore. Use the  button to read the controller values and load 
them into the active set. 
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5.1.7.3. Force Sensor panel 

In a sensorless application, select No sensor: 

 

 

To define a sensor, select Sensor present and enter the register corresponding to the sensor signal. 

 

 

Some sensors need to be reset before every measurement. Two options are available: 

1. Sending a short pulse to a chosen register. In the example below, a pulse is sent to register C6 

by setting it to 0 for some milliseconds, and resetting it to 1 afterwards. This example assumes 
that the register C6 is normally set to 1. 

 

 

2. Launch a Sequence. The user is then responsible for writing an appropriate Sequence and 
downloading it to the Controller. In the example below, the sensor is reset by calling the 
Sequence function func0 on axis 0. 

 

 

Finally, the sensor gain needs to be specified in the corresponding edit field. 

 

5.1.7.4. Force Axis Direction panel 

The user needs to specify if the contact is reached by a positive or negative motion. 

 

5.1.8.  Identification tab 

Identification results are required for any force controller tuning. Two types of identifications are 
available: 

1. Contact Identification: run a frequency domain identification of the contact behavior. Multiple 
identifications can be run with different average contact force exerted. This allows tuning of a 
more robust controller. It is recommended to run identifications with force levels covering the 
range of force levels used by the application. At least one contact identification is required to tune 

any of the Modes 0, 1 and 2. 

2. Free Identification: run a frequency domain identification of the axis away of the contact. Only 
one identification result can be stored. Free identification is only required for tuning force control 

in Mode 2 to ensure stability during approach. 
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Note that the Identification tab is the only tab in the tool not related to a parameter set. Indeed, it 

only allows performing measurements. 

 

5.1.8.1. Contact Identification Settings panel 

Contact Identification 

 

The Rest Position defines the position to which the axis returns once identification 

is completed and where the sensor is reset (if configured to do so). The << Axis pos 

button can be used to set the edit field value to current axis position. Note that it is 
advisable to enter a position value not too distant from the contact position to avoid 
unnecessarily large impacts (contact is established by increasing the current slowly, 
not with the force control algorithm). 

 

 

Specify the number of contact identifications to run. For each run, an average force 
offset to be applied must be specified. These values must all be strictly positive 

(irrespective of the contact direction specified in the General tab). 

 

The identification noise is split into 8 different frequency bands. The amplitude of the 
noise in each band can be specified as a percentage of the force offset defined 
above. The default values are usually good enough, but inspection of the coherence 
function may reveal that the level needs to be adjusted for better measurement 
quality (especially at low frequencies). Refer to Section §5.1.8.4 for more details. 

 
The Run button starts the contact identification(s). Note that it is advisable to start 

from a position near to the contact. 

 

 

Once the identification has been completed, a measured motor Kt constant is 
displayed. 
If more than one identification was run, a standard deviation is also given. If the 
standard deviation is not much smaller than the value itself, the measured Kt should 
not be used and one should rely on the datasheet Kt value. 

 

If the estimated standard deviation of the Kt measurement is much smaller than the measurement 

value itself, the Kt value can be copied to the corresponding edit field in the General tab. Note 

however that doing so will change any value dependent on Kt (i.e. units involving Kt in the 
conversion). 

The estimated transfer functions are plotted in the Results panel (see Section §5.1.8.3). 

 

5.1.8.2. Free Identification Settings panel 

Running a free identification (with the axis not in contact) is only required for tuning the force 

controller in Mode 2. In addition, it also allows inspection of the position loop and current loop 

transfer functions (this can be useful in assessing the quality of the axis tuning prior to the tuning of 
the force control functionality). 

 

 

NOTE 

The identification method used for the ‘Free Identification’ is a 3-points closed-loop 
identification. This is different from the standard method in ComET4. In this method, 
the axis is excited with an identification noise signal while the controller is in active 
closed loop with constant reference position. For best performances, the PID gains 
are typically reduced so as to lower the control bandwidth during identification. 
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Free Identification 

 

The identification position defines the position around which the identification is 

performed The << Axis pos button can be used to set the edit field value to current 

axis position. 

 The identification noise level setting algorithm will not go above this value. 

 
Reduce PID gains so as to reduce the controller bandwidth during identification. On 
a frictionless axis, a value as low as 30% may be used. 

 The Run button starts the free identification. 

 

The estimated transfer functions are plotted in the Results panel (see Section §5.1.8.3). 

 

5.1.8.3. Results panel 

The Results panel shows both contact and free identification measurements. A drop-down menu 

allows to apply some smoothing on the transfer function estimates. It is recommended to apply some 

smoothing (usually FortyEigth or TwentyFourth of octave) as this helps with the subsequent tuning 

algorithm convergence. 

The available transfer functions to display (if measured) are Contact, Contact coherence and Free. 

For each chosen transfer function, the input-output pair of the displayed data can be chosen as well. 

At this stage, it is important to check the Contact coherence plot to ensure that the measurement is 

of sufficient quality, see Section §5.1.8.4. 

 

 

 

5.1.8.4. Reading the Coherence function estimate 

A good force control tuning can be obtained only if the measured transfer functions are of sufficient 
quality. It turns out that measuring the transfer function of a system in contact can be tricky. The 
main challenge is to find a good ratio between the applied force offset and the amplitude of the 

added excitation signal. In most cases, the default ratios set in Contact Identification settings panel 

are good enough (see Section §5.1.8.1). However in some cases, the relative amplitude may have 
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to be adjusted in one or some of the frequency bands. The reason for a bad identification quality 
may be because of either of two reasons: 

• Too high excitation level leading to contact loss at the toolpoint (this usually produces an 
audible vibration sound); or 

• Too low excitation level leading to a poor signal-to-noise ratio. 

 

The Contact coherence plot is useful for assessing the quality of the identification in a given 

frequency band. Whenever the plotted value is high (close to 1), the identification is of good quality. 
Whenever the value is lower than about 0.8 over a certain frequency band, the excitation level 
around these frequencies should be readjusted, either by increasing or decreasing the level. 

The following plot shows an example of poor coherence in the range 300Hz-600Hz. 

 

 
 

On the other hand, this next plot gives an example of good coherence on a large frequency range 
(coherence is always poor at very low and very high frequencies). Note that it may not always be 
possible to obtain a coherence as consistently high as depicted in this plot. 
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5.1.9. Estimator tab 

The Estimator tab is used to tune the force estimator according to the use case. As such, it tunes 

values in the Active Estimator Parameter Set (refer to Sections §5.1.6 and §5.1.15 for details about 

parameter sets). 

The purpose of the estimator algorithm is described in Section §5.1.2.5. Tuning the estimator is 

mandatory for force control Modes 0 and 1. In Mode 2, the estimator is also of use for validation and 

for settling window assessment. It is recommended to always tune the estimator, even if only Mode 
2 operation is foreseen. 

 

 
 

5.1.9.1. Active Estimator Parameter Set panel 

The active set selector for the estimator parameters features an Edit button. Clicking it opens a 

popup window with a table of all parameters (except for the filter settings). This may be useful for 
advanced users. However, the tuning algorithm should be able to cope with most situations. 

 

5.1.9.2. Estimator Filters panel 

The estimator features two filters, one on the estimator output and one acting only on the measured 

acceleration component. Clicking the Set Default button gives two filters featuring a good 

compromise between bandwidth and noise rejection for most applications. These filters must be set 
manually before tuning. 

 

 

 

5.1.9.3. Tuning panel 

The tuning of the estimator is done based on time-domain experimental data. A series of high 
dynamics motions without contact is executed (near or around the contact region if possible). The 
estimator coefficients are then tuned according to one of the three proposed use-cases and in a way 
such that the output of the estimator is as close to zero as possible during all motion phases. Indeed, 
since there is no contact, there should be no estimated contact force. The next two plots show 
examples of tuning results in a sensorless application. The tuning is good if the estimator output 
(expressed in Ampere) is small compared to the actuator current. In Section §5.1.9.9 there is an 
example of an estimator tuned with a poor cogging table, leading to very poor performances. 

NOTE 

The estimator tuning algorithm assumes that the Cogging table and the Advanced 
Feedforward where properly tuned before. A good cogging compensation table is of 
paramount importance for the estimator tuning and performance. See Section §4.2.4 
for more information on tuning Cogging tables and Advanced Feedforwards. 

The tuning of the estimator has a large influence on the behavior of the force controller 

in Modes 0 and 1. It must always be tuned first. If the estimator parameters are 

modified, the force controllers for Modes 0 and 1 must be re-tuned. On the other hand, 

Mode 2 stability is independent of the estimator tuning. 
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The tuning of either of the three use-cases is split in three sub-tabs. The sub-tabs contain various 
setting controls. Among other things, they all feature settings for the tuning- and test-motions 
definition: 

 

 
 

Motion definition 

[1] Stroke Limit Search 
Issues an SLS command. The axis slowly moves back and forth and detects end-stops or 

contact in either direction. The extreme positions are the used as motion stroke limits. 

[2] ∆x margin (≥ 0) The motion stroke as defined by the SLS command is reduced on either ends by the amount ∆x. 

[3] Stroke start position Position at which the motion will start. The << Axis pos button gets the current axis position. 

[4] Stroke end position Position at which the motion will end. The << Axis pos button gets the current axis position. 

[5] Motion dynamics Maximum speed, maximum acceleration and jerk time to use. 

[6] Number of test strokes Tune and test with that many 1-way motion strokes. 

 

1 2 

3 

5 5 

6 

5 

4 
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5.1.9.4. Tuning with Sensor tab 

This tunes an estimator using a force sensor. In this use case, acceleration compensation and force 
offset are tuned. Checkboxes allow to choose whether a given coefficient should be tuned or forced 
to zero. Acceleration compensation is useful if the sensor is mounted on the axis mobile part. If the 

sensor does not move, the acceleration coefficient should not be tuned (uncheck the Acceleration 

checkbox). 

 

 
 

Press the Tune button to start the tuning process. Then, press the Test button to repeat the 

experiment with the tuned coefficients and evaluate the tuning result in the Results panel as 

explained in Section §5.1.9.3. 

 

5.1.9.5. Tuning Sensorless tab 

This tunes a sensorless estimator. Force is estimated based on acceleration, speed, and 
feedforward signals. 

 

 
 

In most cases, it is recommended to tune an estimator using all coefficients except the Dry friction 

one. 

Press the Tune button to start the tuning process. Then, press the Test button to repeat the 

experiment with the tuned coefficients and evaluate the tuning result in the Results panel as 

explained in Section §5.1.9.3. 

 

5.1.9.6. Tuning Sensorless with Spring tab 

This use case is intended for applications featuring an axis pushing 
against a pre-constrained spring. The shaft associated with the 
spring in turn enters in contact with the surface on which the 
controlled force must be applied. The tuning of this use case is split 
in two parts: 1) determine the spring entry point and range; and 2) 
tune the estimator within the spring range. 

 

 

 

NOTE 

Compensating for a spring force with the estimator is only supported with force control 

Modes 0 and 1. To use Mode 2 with a spring, the spring force must be compensated 

for using the cogging table (not recommended). 
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5.1.9.7. Spring search sub-tab 

 
 

Spring search setting 

[1] Search stroke motion settings This determines the motion stroke to use for spring detection. The settings are similar to the 
ones described in Section §5.1.9.3. Note, however, that the motion dynamics should be low 
(stroke should complete within 1-3 seconds). 

[2] Search Spring This starts the spring entry point search. When complete, data is displayed in the Results 

panel 

[3] Entry position Detected start of the spring range. The value can also be entered manually. 

The << Axis pos button gets the current axis position. 

[4] Max compression Position of maximum compression of the spring. The value is determined from the result of 

the SLS motion result. The value can also be entered manually. The << Axis pos button 

gets the current axis position. 

 

The next plot shows a spring search result example. In this case the spring entry point was detected 
at 7.1 mm. 

 

 

 

5.1.9.8. Tune inside spring range sub-tab 

Once the spring range is detected or manually specified (see Section §5.1.9.7), the estimator can 
be tuned within the spring range. The motion stroke and rest position are defined automatically from 
the results of the spring range search experiment, but may also be entered/overwritten manually. 

 

1 

2 

3 4 
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Spring range tuning 

[1] Coefficients to tune Choose what estimator coefficients should be used/tuned. A spring assembly often has 
significant dry friction so that tuning the corresponding coefficient may be advisable. 

[2] Rest position The axis will go to this position after experiment. It is recommend to set a position outside the 
spring range to avoid continuous forces. The value is set automatically and may be overwritten 
manually. 

[3] Motion definition This determines the motion stroke to use for tuning. The settings are similar to the ones 

described in Section §5.1.9.3. The Stroke from and stroke to values are filled automatically, 

but may be set manually as well. 

[4] Tune / Test Start tuning and test tuned coefficients. The next plot shows an example of a properly tuned 
estimator with spring (inside the spring range). 

 

 

 

5.1.9.9. Troubleshooting 

Cogging. Before tuning the estimator, it is essential to make sure that the axis cogging is properly 

compensated for (select in ComET4 the option Tools→Settings→Advanced Feedforwards Tuning). 

To stress the importance of this point, the next plot gives an example of the best tuning obtainable 
without proper cogging table (the axis used in the example features a simple voice-coil; expect even 
worse figures on other types of axes). 

 

1 

2 

3 

4 
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5.1.10. Force Controller / Mode 0 tab 

The Force Controller / Mode 0 tab is used to tune the force controller for operation in Mode 0. As 

such, it tunes values in the Active Mode 0 Parameter Set (refer to Sections §5.1.6 and §5.1.15 for 

details about parameter sets). 

 

5.1.10.1. Active Force Control Mode 0 Parameter Set panel 

This panel selects which instance of the Mode 0 parameter sets is the active one (displayed and 

tuned). 

 

5.1.10.2. Tuning panel 

The Tuning panel is used to tune the controller based on a modulus margin criterion. The auto-tuner 

tries to tune a PI controller maximizing the bandwidth while satisfying a user-settable modulus 

margin. A full PID tuner may also be tuned manually, checking the Results panel and the Nyquist 

plot for assessing performance. 

 

 
 

Force controller tuning – Mode 0 

[1] Target Modulus Margin Modulus margin that the auto-tuner should ensure while maximizing bandwidth. 

[2] Tune & Update Start auto-tuning and updates the Results and Responses panels’ data. 

[3] Controller gains 
Force controller gains computed by the auto-tuner. Gains may be manually edited as well. 
Note that the auto-tuner produces a PI controller. 

[4] Update, Auto Update 
Updates the Results and Responses panels’ data. If the Auto Update checkbox is selected, 

data will be updated every time a gain parameter is edited. 

 

1 3 

2 

4 
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5.1.10.3. Results panel 

The Results panel displays numerical tuning performance results: 

 

Tuning Results 

Stability Stability indicator: 

• Green: indicates stability; 

• Red: indicates an unstable control loop; 

• Grey: undefined / no data available. 

Bandwidth Achieved controller bandwidth. 

Modulus Margin Achieved Modulus Margin and frequency at which the modulus margin is the smallest. 

 

5.1.10.4. Response panel 

The Response panel shows the open or closed loop response of the tuned system. By default, the 

Nyquist plot of the open-loop system is displayed. The transfer function may be exported to a CSV 
file. The next plot shows a successfully tuned system. 

 

 

 

5.1.11. Force Controller / Mode 1 tab 

The Force Controller / Mode 1 tab is used to tune the force controller for operation in Mode 1. As 

such, it tunes values in the Active Mode 1 Parameter Set (refer to Sections §5.1.6 and §5.1.15 for 

details about parameter sets). 

 

5.1.11.1. Active Force Control Mode 1 Parameter Set panel 

This panel selects which instance of the Mode 1 parameter sets is the active one (displayed and 

tuned). 

 

5.1.11.2. Tuning panel 

The Tuning panel is used to tune the controller based on a modulus margin criterion. The auto-tuner 

tries to tune a PI controller maximizing the bandwidth while satisfying a user-settable modulus 
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margin. A full PID tuner may also be tuned manually, checking the Results panel and the Nyquist 

plot for assessing performance. 

 

 
 

Force controller tuning – Mode 1 

[1] Target Modulus Margin Modulus margin that the auto-tuner should ensure while maximizing bandwidth. 

[2] Tune & Update Starts auto-tuning and updates the Results and Responses panels’ data. 

[3] Controller gains 
Force controller gains computed by the auto-tuner. Gains may be manually edited as well. 
Note that the auto-tuner produces a PI controller. 

[4] Update, Auto Update 
Updates the Results and Responses panels’ data. If the Auto Update checkbox is selected, 

data will be updated every time a gain parameter is edited. 

 

 
 

The following plots depict an example where reducing the cutoff frequency of the estimator 

acceleration filter increases the obtained controller bandwidth (on the left, a Mode 1 controller with 

low bandwidth of 60Hz and, on the right, a higher bandwidth of 110Hz). Estimator filters influence 
controller performances substantially. Sometimes, adding some derivative gain KDFC:1 also 

improves bandwidth slightly. Note that the auto-tuner only produces PI controllers. Full PID 
controllers must be tuned manually. 

 

  

 

5.1.11.3. Results panel 

The Results panel displays numerical tuning performance results: 

 

1 3 

2 

4 

NOTE 
The performances achieved by the auto-tuner strongly depends on the settings of the 
estimator. Reducing/increasing the low-pass estimator filters cutoff frequencies may 
change tuning results substantially. 
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Tuning Results 

Stability Stability indicator: 

• Green: indicates stability; 

• Red: indicates an unstable control loop; 

• Grey: undefined / no data available. 

Bandwidth Achieved controller bandwidth. 

Modulus Margin Achieved Modulus Margin and frequency at which the modulus margin is the smallest. 

 

5.1.11.4. Response panel 

The Response panel shows the open or closed loop response of the tuned system. By default, the 

Nyquist plot of the open-loop system is displayed. The transfer function may be exported to a CSV 
file. The next plot shows a successfully tuned system. 

 

 

 

5.1.12. Force Controller / Mode 2 tab 

The Force Controller / Mode 2 tab is used to tune the force controller for operation in Mode 2. As 

such, it tunes values in the Active Mode 2 Parameter Set (refer to Sections §5.1.6 and §5.1.15 for 

details about parameter sets). 

There are three different components to tune for the force control Mode 2: 

1. Feedback filters: there are three feedback filters in the controller feedback loop. They can be 

used to fine tune the controller’s behavior. In most cases, using just one low-pass filter (default 
option) will give good results. Any tuning should be attempted first with the default setting 
proposed by the tool. 

2. Feedback Speed Gain: the auto-tuner only tunes this gain, based on the preset feedback filters. 

3. Feedforward Filters: these filters have no influence on the stability of the feedback loop, 

therefore, they should be set to their default values for the initial tuning. The feedforward filters 
are then set based on experiments made in the Touchdown tab: if an oscillation is observed in 
the measured or estimated force plot, a filter is placed at the approximate observed frequency. 

 



 ComET4 – Commissioning Software 
 User’s Manual 135 

ETEL Doc. / Version N / 31/03/23 

5.1.12.1. Active Force Control Mode 2 Parameter Set panel 

This panel selects which instance of the Mode 2 parameter sets is the active one (displayed and 

tuned). 

 

5.1.12.2. Feedback Filters panel 

 

 

Feedback Filters 

[1-3] Filter 1-3 
Settings for each of the three series-connected feedback filters. Initial setting should first be done 
with one low-pass filter. 

[4] Set Default Set default filters 1 through 3. (LowPass and two Disabled filters. Disabled means unity gain). 

 

5.1.12.3. Tuning panel 

The Tuning panel is used to tune the controller based on a modulus margin criterion. The auto-tuner 

tries to tune a single gain Speed Gain. The Results panel displays the resulting stability information 

and the Responses panel displays the Nyquist plot for assessing performance. The gain can be 

tuned manually as well. 

 

 
 

Force controller tuning – Mode 2 

[1] Target Modulus Margin Modulus margin that the auto-tuner should ensure while maximizing bandwidth. 

[2] Tune & Update Starts auto-tuning and updates the Results and Responses panels’ data. 

[3] Controller gain Force controller gain computed by the auto-tuner. Gain may be manually edited as well. 

[4] Update, Auto Update 
Updates the Results and Responses panels’ data. If the Auto Update checkbox is selected, data 

will be updated every time the gain parameter or any filter is edited. 

 

5.1.12.4. Results panel 

The Results panel displays numerical tuning performance results: 

 

 

2 

1 

4 3 

1 
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Tuning Results 

Stability Stability indicator. The stability is assessed both for the low-speed approach phase and for the 
force control phase simultaneously: 

• Green: indicates stability; 

• Red: indicates an unstable control loop; 

• Grey: undefined / no data available. 

Bandwidth 
Achieved controller bandwidth. The bandwidth is indicated for the approach phase. In force 

control Mode 2, bandwidth during contact is not defined. 

Modulus Margin 
Achieved Modulus Margin and frequency at which the modulus margin is the smallest. The 

value is the worst case value between approach phase and contact phase. 

 

5.1.12.5. Responses panel 

The Responses panel shows the open or closed loop response of the tuned system. By default, the 

Nyquist plot of the open-loop system is displayed. The transfer function may be exported to a CSV 
file. The next plot shows a successfully tuned system. 

 

 

 

In Mode 2, two sets of frequency responses are displayed on the same plot: 

1. Contact responses, this is similar to the other two control modes; and 

2. Free response, in Mode 2 control stability needs to be ensured during the approach phase as 

well. 

 

5.1.12.6. Feedforward panel 

As explained in Section §5.1.12, the Feedforward Filters should first be set to default until a stable 

controller with good bandwidth is found. 

 

 

1 

2 

4 3 
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Feedforward Filters 

[1-2] 2nd order feedforward filters Feedforward filters on force reference. 

[3] Feedforward comb filter Feedforward filter on force reference. Effective for suppressing oscillations. Enter 
frequency of observed oscillation. 

To choose the Damp value: If the oscillation has little damping (lasting for many periods) 

use the maximum value of 50%. If the oscillation presents a higher damping enter a lower 
value. The value can be determined more precisely by estimating the relative amplitude 
of two consecutive periods. The value to enter should be half of this ratio (in percentage). 
Note that only discrete frequency values can be entered. The user-entered value will be 
rounded to the closest available value. 

[4] Set Default Set all feedforward filters to default (disabled, i.e. unit gain). 

 

With the feedback (filters and speed gain) tuned so as to get the highest possible bandwidth with 
specified modulus margin, a touchdown experiment is carried out (do not forget to set appropriate 
protection settings first, refer to Section §5.1.13 for more information). It is recommended to use at 
least two force levels, so as to acquire a touchdown and at least one force transition. 

A result example is given below. From either the force sensor acquisition (if available) or from the 
estimated force acquisition (MF400), one may check if any problematic oscillation is present. If so, 

a Feedforward Filter can be selected. 

 

 
 

 
 

The next plot shows the effectiveness of a Comb filter to reject oscillations during a force transitions. 

One should expect feedforward filters to be very effective on force reference transitions, less so on 
touchdown (as made clear by the example). Filter 1 and 2 may additionally be used: 

• Notch filters: reject any other frequency; 

• Low-pass filter: may reduce noise (noise excited by reference changes, not noise from the 
feedback loop). 

 

Touchdown 
Force 

reference 
step 
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5.1.13. Protections tab 

The Protections tab groups all axis-protection settings for all force control Modes 0, 1 and 2. 

 

 

 

5.1.13.1. Active Protections Parameter Set panel 

This panel selects which instance of the protections parameter sets is the active one (displayed and 
tuned). 

 

5.1.13.2. Protections Mode 0, 1 & 2 

These settings are common to all Modes 0, 1 and 2. 

 

Protections Mode 0/1/2 

 
Saturation value of the output of the force controller (this does not saturate the current 
reference during position control). 

 
Max rebound distance after touchdown detection. If a rebound larger than this value is 
detected, the axis falls in error. 

Touchdown 
Force 

reference 
step 

NOTE 
When trying to reject more than one oscillation, always use the Comb filter on the 

lowest frequency component. It is usually more effective than notch filters, but its 
frequency resolution is better at lower frequencies. 

NOTE It is essential to properly set the protection features before attempting any touchdown. 



 ComET4 – Commissioning Software 
 User’s Manual 139 

ETEL Doc. / Version N / 31/03/23 

 

5.1.13.1. Protections Mode 0 & 1 

These settings affect only force control Modes 0 and 1: 

 

Protections Mode 0/1 only 

 

If this position is exceeded during low-speed approach in Modes 0 or 1, the axis falls in 

error. The position is relative to the low-speed approach starting position. The entered value 
should be positive irrespective of the defined axis direction. 

 

5.1.13.2. Protections Mode 2 only 

These settings affect only force control Mode 2: 

 

Protections Mode 2 only 

 
If at any time during low-speed approach or during force-control phase, the measured speed 
exceeds this value, the axis falls in error. 

 

5.1.14. Touchdown tab 

5.1.14.1. Active Touchdown Parameter Set panel 

This panel selects which instance of the touchdown parameter sets is the active one (displayed, 
tuned and used). 

 

5.1.14.2. Force Control Mode 0/1/2 panel 

This tab groups settings that depend on the chosen force control mode. The parameters in the left 

column are common to all modes. Those in the right column are different if Mode 0 or 1 is selected 

or if Mode 2 is selected 

 

Force control Mode 0/1/2 (common to all modes, left column) 

 Speed of the low-speed approach. 

 
After starting the low-speed approach, ignore any touchdown detection for that amount of 
time. 

 
For a force level to be detected as reached-and-stabilized, the estimated force must 
remain within the window range (next setting) for that amount of time. 

 Window range definition [𝐹𝑟𝑒𝑓 − value, 𝐹𝑟𝑒𝑓 + value] 
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Force control Mode 0/1 (common to modes 0 and 1, right column) 

 
If Yes is selected, the force feedback is disabled during slow-speed approach, 

resulting in a constant approach speed (recommended setting is Yes). 

 
Touchdown detection on estimated Force (recommended) or Speed. The 

numerical value is the threshold value to use (always positive). 

 

If a non-zero 𝑇𝑠𝑚𝑜𝑜𝑡ℎ value is given, the estimated force is multiplied by a ramp 

𝑟(𝑡) = max⁡(0,min(1,
𝑡

⁡𝑇𝑠𝑚𝑜𝑜𝑡ℎ
) in the feedback loop. This can be used in case of 

estimation overshoot at the beginning of force control. 

 

Force control Mode 2 (particular to mode 2, right column) 

 

In force control Mode 2, touchdown detection is based on the measured speed. 

The value is specified relative to low-speed-approach speed. A value of 50% 
works in most cases. After initial tuning, the value may be increased (earlier 
detection). Note that higher values increase the risk of false detection during 
approach. 

 

The force control Mode 2 includes a Dead Zone nonlinearity in the feedback 

loop. This allows to effectively prevent damping at very low speeds (i.e. when 
in contact). Non-zero value are useful only in situations where the contact 

surface has a low rigidity and where the Speed Gain could slow down force 

transitions (due to motions while in contact). In most situation, zero is the 
recommended value. 

 
Upper bound of the Dead Zone (see above). In most situation, zero is the 

recommended value. 

 

5.1.14.3. Motion & Force Reference panel 

This tab groups settings for the approach motion and for the force levels to go through while in 
contact. 

 

Motion & Force Reference 

 
Speed, acceleration and jerk time of the initial motion (performed in position control 
and before the beginning of the low-speed approach phase). 

 
Initial motion start position. The <<Axis pos button takes the actual axis position as 

value. 

 

End of the initial motion and start position of the low-speed approach phase. This 

position should be close, but not equal to the contact surface position. The <<Axis 
pos button takes the actual axis position as value. 

 Number and values of the force reference levels to go through. 

NOTE 

The force window settings are used in all Modes and are based on the estimator 

output. This is why it is important to tune the force estimator also in Mode 2. If the 

force window range is set to a too small value, estimated force noise may prevent the 
in-window criterion ever to be satisfied, leading to waiting time-up. In that case, the 
axis remains in contact for some time and the error “… WTF timed out” pops up. In 
such case, increase the Force est. window range value. 
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 Pause between each force levels (approximate value). 

 
The force reference can be stepped or ramped between specified levels. Set 0s 
for steps. 

 

5.1.14.4. Acquisition panel 

This tab allows to specify which registers should be acquired during touchdown experiments. Up to 
four different simultaneous traces can be acquired. 

 

 
 

Motion & Force Reference 

[1] Trigger Source Event type for starting acquisition: 

• BeginMove trigger is at the start of the initial position-controlled motion; 

• BeginFC trigger is at the beginning of the low-speed approach phase; 

• Touchdown trigger is at the touchdown detection instant. 

[2] Pre-trigger Time shift between trigger and start of acquisition. If positive, the first acquired point is before 
the trigger event. 

[3] Acquired registers Define registers to be acquired: 

• None, for no register; 

• Custom, to specify a custom register name, e.g. ML6; 

• <Name>, select one of the predefined register names. 
 

If all registers are set to None, no acquisition is started. An acquisition can be configured and 

started from ComET instead. 

 Starts the experiment and acquisition (if at least one register was configured). 

 

5.1.14.5. Results panel 

 

 

1 2 

3 

1 

2 

4 
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Results 

[1] Plots Plots of all acquired registers’ traces. 

[2] Axes selection 
For each acquisition, the axis number in which the plot should be displayed can be 
selected. The trace can be inverted as well (sign change). 

[3] Refresh plots and units Refresh the plots. Takes units selected in the General tab into account. 

[4] Export to CVS (ComET4) 
Export traces to a CSV text data file. The exported file is compatible with the ComET4 

Viewer Tool (Tool→Acquisition→Viewer). 

 

5.1.14.6. Troubleshooting 

It is recommended to adopt the following approach during tuning: 

1. Make sure to produce identification data of sufficient quality, refer to Section §5.1.8.4. 

2. Make sure to properly tune the estimator, even for Mode 2, refer to Section §5.1.9 (this implies 

a good cogging compensation). 
3. Start with “lower than specified” values first, i.e.: 

a. Start with low Approach speed; 

b. Start with low motion Dynamics (low speed, low acceleration, large jerk time, e.g. 10-

20ms); 

c. Start with long low-speed approach phase: set the FC start pos sufficiently off the contact 

surface position; 

d. Detection inhibit duration: start with a non-zero value, but make sure that the duration 

multiplied with the approach speed corresponds to a distance shorter than about half the 
approach distance; 

e. Start with a large Force est. window duration (values as high as twice the force levels). 

f. Detection threshold: 

i. Mode 0/1: start with half the first force level; 

ii. Mode 2: start with 50%. 

 

Once a working setting (good bandwidth, etc.) is achieved, the values listed above can be tightened 
one by one. 

When a satisfactory setting is obtained, all active parameters can be downloaded to the Controller 

via the menu entry Controller→ActiveParameters→Write all to axis. 

 

 
 
  

NOTE 
The active parameters are downloaded to the Controller, but not saved (i.e. the SAV 

command not issued). 
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Results 

Problem Possible issues and solutions 

Axis in error and RST button ineffective Your axis may be on an error propagation group or the error cannot be reset with the 

RST command. Connect via ComET4 and type RST=123 in the Terminal tool. 

Axis goes unstable • Check force controller stability (tab Force Control); 
• Check current and position loop; 

• Try with a more conservative controller by increasing the modulus margin or 
decreasing gains manually; 

• Check if identification data used for tuning is of sufficient quality (refer to Section 
§5.1.8.4); 

• Check if the chosen mode is the best suited for the type of axis (refer to Section 
§5.1.2.1); 

• Try reducing the Approach Speed (panel Force control Mode 0/1/2); 

• Try to move the FC Start pos value further away from the contact surface; 

• Check if the used force levels are within or close to the range of forces used during 
identification. 

Large force overshoot at touchdown or 
tracking error 

• Make sure the FC Start pos is above the contact surface with sufficient margin for 

the low speed approach phase. Try increasing the margin by adjusting FC Start pos; 

• Try reducing the Approach speed; 

• Try reducing the motion Dynamics (lower speed/acceleration, larger jerk time); 

• Try reducing the Detection inhibit duration. 

Modes 0/1/2 

Contact established, axis stays in contact 
for some time, followed by error “… 
Executing WTF command timed out” 

The Wait Till Force command timed-out before the in-window criterion was satisfied. 

• Was the estimator tuned correctly? 

• Try increasing the Force est. window range (refer to Section §5.1.14.2). This value 

may be set larger than the targeted force, effectively deactivating the window wait 

(thus relying only on the Pause value); 

• Try reducing the Force est. window if larger than 1s (refer to Section §5.1.14.2). 

 

Another reason (Mode 0/1) can be due to a too small Integration limit setting: 

• Go to tab Protection and increase the Integration limit value. 

Early touchdown detection • Mode 0/1 with detection on force: check that the estimator is properly tuned. Try 

reducing the motion acceleration and/or increasing the motion jerk time; 

• Mode 2: try reducing the Detection speed ratio; 

• Mode 0/1/2: try increasing the Detect inhibit duration. 

Modes 0/1/2 

Touchdown fails with error “… M64.x = 
89, Bad setting for the Force Control 
loop” 

This error is triggered by the Rebound protection setting. Go to the protection tab and: 

• Increase the Rebound protection value; 

• If the error persist, deactivate the protection by setting the value to 0. 

Mode 2 

Touchdown fails with error “… The 
velocity is greater than K31” 

The Approach speed (refer to Section §5.1.14.2) is too close to the Speed limit 
(Protections tab). Got to the Protections tab and increase the speed limit value. 
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5.1.15. Parameter sets content 

For reference, the data content of each type of parameter set edited and tuned by the Force Control 
Tool is depicted below. 

 

System Parameters
• Speed Filter (KF104:0-108:0)
• Adv Filters (KF104.108, depth 1-4)
• Kdp (KF2)
• Kpp (KF1)
• Kip (KF4)
• Kpc (KF80)
• Kpc (KF81)
• LeverArm (KF308)
• Kt (KF300)

Estimator Parameters
• Acc Filter (KF104:5-108:5)
• Out filter (KF104:6-108:6)
• Current Offset (KF302)
• Acc gain (KF301)
• Spd gain (KF303)
• Dry friction (KF304)
• Sens. Offset (KF309)
• Sens. Gain (KF310)
• Sensor def (K311:0-3)
• Current gain (K316)
• Cogging gain (K317)
• Spring Offset (K373)
• Spring Stiff. (KF373)
• Spring max compression (K374)
• Spring damping (KF374)

FC Mode 0 Parameters
• KDF1 (KF318:1)
• KPF1 (KF305:1)
• KIF1 (KF306:1)

FC Mode 1 Parameters
• KDFC1 (KF314:1)
• KPFC1 (KF312:1)
• KIFC1 (KF313:1)

FC Mode 2 Parameters
• FB Filters (KF114-118, depth 0-2)
• FFWD Filters (KF114-118, depth 3-4)
• Comb filter settings (K291:4, K292:4)
• Speed gain D (KF315)

Protection Parameters
• Out. Saturation (KF6:1)
• Rebound prot. (KL314)
• Speed Limit (K31:1)
• Pos integration limit (K307)

Touchdown Parameters
• FC config bits (K302)
• Dead zone (K19:5, K19:6)
• TD detect inhibit duration (K193)
• Detect. Force threshold (KF299)
• Detect. Spd threshold mode 0/1 (K19:4)
• Detect. Spd threshold ration mode 2 

(KF321)
• Detect. Delay (K191)
• Force estimation smooth time (K192)
• Force window duration (K190)
• Force window range (KF191)
• KDF:0 Approach derivative gain (always 0) 

(KF318:0)
• KPF:0 Approach proportional  gain (always 

0) (KF305:0)
• KIF:0 Approach integral gain (KF306:0)

 

 

5.2. QuiET 

The QuiET tool allows the user to verify and, if needed, perform adjustments to the settings of the 
QuiET active isolation system. The QuiET system serves two main purposes: 

• Filter out the vibrations coming from the floor impacting the performance of the motion system 
mounted on top of it (i.e. vibration isolation capability); and 

• Cancel the driving forces generated by the motion system movements (i.e. drive force 
cancellation capability). 

 

 
 

NOTE The QuiET control mode is not supported by the ACCURET+ position controllers. 
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The QuiET tool is one of ComET4’s so-called external tools consisting of a MATLAB-based 
standalone application. 

 

 
 

This tool can be launched from within ComET4 by selecting the Menu option Tools → Settings → 
QuiET: 

 

 
 

or executing the file QuiETTool.exe that can be found under: 

“C:\Program Files (x86)\ETEL SA\ComET-4.xxY\external-tools\QuiETTool\”. 
 

 
 

At startup, a warning message informs the user of the conditions to be fulfilled to ensure optimal and 

safe operation of the system. Click on the OK button to proceed. 

 

NOTE 

The QuiET tool requires the prior installation of the MATLAB Compiler Runtime (MCR) 
version 2019b, which can be downloaded from: 
http://www.mathworks.com/products/compiler/mcr/. 

This tool will take several seconds to initialize while the MCR is being loaded into 
memory. 

MATLAB® is a numerical computing environment and proprietary programming language 
developed by The MathWorks Inc. 

As a standalone MATLAB-based application external to ComET4, the QuiET tool only 
communicates with QuiET controllers. It is not aware of the status of any other 
Controllers on the communication bus. 

NOTE The QuiET tool can only be executed on a 64-bit Windows Operating System. 

http://www.mathworks.com/products/compiler/mcr/
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The main window is divided in 4 areas: 

1. System Data; 

2. Result file; 

3. Connect to System; and 

4. Test Applications. 

 

In the System Data area, the user can select a system from the System drop-down list and choose 

the location where to store the test results file by clicking on the Browse button. The user must add 

the name of the operator conducting the tests and the system’s serial number (though not 
mandatory, a description of the test is recommended). 

 

 
 

Alternatively, the user can load test results for analysis by clicking on the Load button in the Result 
file area. 

 

NOTE 
The results are stored as a MATLAB native file. Therefore, it is recommended to use the 
default *.mat file extension. 
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Usually, the connection with the Controllers is established automatically when the QuiET tool is 

launched from within ComET4. The drop-down list in the Connect to System area lists the different 

connection types available and the button  allows the user to establish a connection to a TCP/IP 
host, just like in ComET4. Select the Controller’s axis from the second drop-down list. 

In the Test Applications area, the user can access several tools for adjusting and verifying the 

settings of a QuiET active isolation system. 

 

5.2.1. Leveling 

Clicking on the Leveling button in the Test Applications area opens the Leveling tool. This tool allows 

the user to adjust the leveling of the granite and set the system’s X and Y static masses. 

The Leveling tool window is divided in 4 areas: 

1. System; 

2. Leveling; 

3. Leveling Display; and 

4. Static Masses Tuning. 

 

In the System area, the tool provides an indication of the status of the system (e.g. is the system 

ready, in error, connection not established…). 

1 

2 

4 
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The controls in the Leveling and Leveling Display areas are required for leveling the granite. The 

controls in the Static Mases Tuning area are used for setting (and tuning) the system’s X and Y static 

masses. 

 

 
 

The first step consists in leveling the granite according to the following procedure: 

1. Make sure the brackets are in position below the feet and lock the blocking devices. This will 
ensure that the granite is parallel to the system’s frame. 

2. Click the Start button. 

3. Once the virtual representation of the granite is displayed in the Leveling Display area, click 

on the Live Display button to get a live feed visualization of the granite’s movements. The Lin 
Scale and Rot Scale edit controls allow the user to adjust the magnification factor between the 

movement of the “real” granite and its “virtual” representation on the tool. The goal is to make 

the very small movements of the granite visually perceptible to the user in the Leveling 
Display. 

4. Unscrew the screws of the blocking devices and remove the brackets. The granite is free to 
position itself at equilibrium and the sensors will measure the leveling angle errors. 

5. Check for the height corrections to apply in the Leveling Display area. Start with the isolator 

with the largest absolute error and apply the proposed number of turns at the pre-loading 
screw (refer to the QuiET integration manual for further information). Only adjust one isolator 

at a time. Once one isolator is adjusted, check on the Leveling Display area again for the new 

proposition and adjust the isolator with the largest absolute error. This operation should be 
executed iteratively until the required leveling (parallelism) is obtained. This value is reported 
in the system’s specifications. If not explicitly provided, use the reference value of 20 µm for 
the maximum height error. 

 

1 

2 

4 

3 



 ComET4 – Commissioning Software 
 User’s Manual 149 

ETEL Doc. / Version N / 31/03/23 

Once the leveling is completed, the user must set the parameters related to the system’s X and Y 

static masses. The Controller’s current configuration can be obtained by clicking on the Read button. 

If these need to be adjusted, the user can manually input the new parameters in the Manual edit 

controls placed to the right of the Controller edit controls and re-configure the Controller parameters 

by clicking on the <= button. 

If X and Y static masses of the system are not known, click on the Auto-Tuning button to initiate an 

automatic procedure for determining these parameters. At any moment the user can abort the 

procedure by clicking on the Stop test button. 

 

 

 

 
 

If completed successfully, the results of the auto-tuning algorithm are written to the Controller’s 

configuration and are displayed in the Manual and Controller edit controls. 

Once all settings are completed, close the tool by clicking on the  button located on the top right 
corner. 

 

 
 

WARNING 
The auto-tuning algorithm will execute a series of controlled movements with the 
system’s axes. Always ensure that the proper safety precautions are taken when 
powering on a Controller and executing movements with a motion system. 

NOTE 
The user must save the configuration to the Controller after using this tool. Refer to 
section §10.3 for more information about saving a Controller’s configuration. 
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5.2.2. Control setting 

Clicking on the Control Setting button in the Test Applications area opens the Control Setting tool. 

This tool allows the user to adjust the derivative gain of the PID regulators. 

The Control Setting tool window is divided in 2 areas: 

1. System; and 

2. Regulators. 

 

 
 

In the System area, the tool provides an indication of the status of the system (e.g. is the system 

ready, in error, connection not established…). 

In the Regulators area, the user can modify the derivative gain of the PID regulator controlling the 

direction selected in the first drop-down list. With the Copy => button the new derivative gain can 

also be applied to the PID regulator controlling another direction, corresponding to the selection in 
the second drop-down list. 

 

5.2.3. Transmissibility 

Clicking on the Transmissibility button in the Test Applications area opens the Transmissibility 

Measurement tool. This tool allows the user to realize an identification of the transmissibility of the 
QuiET system. The transmissibility is the ratio between the vibrations of the granite mounted on the 
QuiET system and the floor vibrations, being an indication of the performance its vibration isolation 
capability. 

The Transmissibility tool window is divided in 4 areas: 

1. System; 

2. Test; 
3. Display Setting; and 

4. Bode Diagram. 

 

1 

2 
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In the System area, the tool provides an indication of the status of the system (e.g. is the system 

ready, in error, connection not established…). 

Click on the Start Identification button in the Test area to initiate an identification of the 

transmissibility transfer function. At any moment the user can abort the procedure by clicking on the 

Stop Identification button. 

The transmissibility’s amplitude and phase are displayed in the Bode Diagram area. The user can 

interact with the plots using the tools located at the toolbar: 
 

 Zoom in. 

 Zoom out. 

 Pan. 

 Cursor. 

 

The user can choose which transmissibility curves to display using the checkboxes in the Display 
Setting area. 

 

1 

2 

3 

4 
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5.2.4. Feedforward calibration 

Clicking on the FFwd Calibration button in the Test Applications area opens the Feedforward Tuning 

tool. This tool allows the user to adjust the QuiET feedforward parameters. 

The tool window is divided in 2 areas: 

1. System; and 

2. Setting. 

 

In the System area, the tool provides an indication of the status of the system (e.g. is the system 

ready, in error, connection not established…). 

In the Setting area the user can find the feedforward parameters to adjust organized in three sets: 

• Backup: set of parameters the user should keep as reference, i.e. not to be modified; 

• Controller: set of parameters currently active in the Controller; 

• Manual: set of parameters the user can modify. 

 

Click on the Read button to upload the Controller active parameters and display them under the 

Controller column. Using the => button, the user downloads the Backup set of parameters to the 

Controller. Likewise, with the <= button, the user downloads the Manual set of parameters to the 

Controller. 
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The user can initiate an automatic tuning of the feedforward parameters clicking on the Auto-Tuning 

button. At any moment the user can abort the procedure by clicking on the Stop Test button. 

The automatic procedure will tune all the feedforward parameters the user has selected for tuning 

using the Tune checkboxes located to the right of the parameters’ set. Certain parameters are tuned 

jointly being indicated by the ] bracket sign located to their right: 

 

 

 

 
 

Finally, once the user is satisfied with the performance of the QuiET system, the Controller 

parameters can be saved by clicking on the button Save Controller. 

 

5.2.5. Performance 

The last tool available in the Test Applications area is the Performance Measurement tool. Click on 

the Performance button to launch it. 

This tool allows the user to verify the level of efficiency of the QuiET system in cancelling the motion 
system born movements. In other words, it gives an indication of the performance of its drive force 
cancellation capability. 

The tool window is divided in 2 areas: 

1. System; and 

2. Performance. 

 

1 2 

WARNING 
The auto-tuning algorithm will execute a series of controlled movements with the 
system’s axes. Always ensure that the proper safety precautions are taken when 
powering on a Controller and executing movements with a motion system. 
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In the System area, the tool provides an indication of the status of the system (e.g. is the system 

ready, in error, connection not established…). 

Click on the Test button to initiate the test procedure. Once completed, the performance levels are 

displayed in the Performance area. 

 

 

 

 

 

5.3. ZxT 

The ZxT tool allows the user to automatically set the encoder offsets, determine the tip/tilt limit 
strokes and perform a position loop identification of a module controlled by the ZxT firmware, such 
as the Z3TH or Z3TM. 

 

 
 

1 2 

WARNING 
The test procedure will execute a series of controlled movements with the system’s axes. 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 

NOTE The ZxT control mode is not supported by the ACCURET+ position controllers. 
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The ZxT tool is one of ComET4’s so-called external tools consisting of a MATLAB-based standalone 
application. 

 

 
 

This tool can be launched from within ComET4 by selecting the Menu option Tools → Settings → 
ZxT: 

 

 
 

or executing the file ZxTTool.exe that can be found under: 

“C:\Program Files (x86)\ETEL SA\ComET-4.xxY\external-tools\ZxTTool\”. 
 

 
 

At startup, a warning message informs the user of the conditions to be fulfilled to ensure optimal and 

safe operation of the system. Click on the OK button to proceed. 

 

NOTE 

The ZxT tool requires the prior installation of the MATLAB Compiler Runtime (MCR) 
version 2019b, which can be downloaded from: 
http://www.mathworks.com/products/compiler/mcr/. 

This tool will take several seconds to initialize while the MCR is being loaded into 
memory. 

MATLAB® is a numerical computing environment and proprietary programming language 
developed by The MathWorks Inc. 

As a standalone MATLAB-based application external to ComET4, the ZxT tool only 
communicates with ZxT controllers. It is not aware of the status of any other Controllers 
on the communication bus, except when tuning the feedforward parameters in the 

Feedforward Tuning panel. 

NOTE The ZxT tool can only be executed on a 64-bit Windows Operating System. 

http://www.mathworks.com/products/compiler/mcr/
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The ZxT tool is divided in three main panels: 

1. Homing and Limit Stroke; 

2. ZxT Identification; 

3. Feedforward Tuning. 

 

 
 

1 2 3 
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Usually, the connection with a ZxT controller is established automatically when the ZxT tool is 
executed from within ComET4. The drop-down list in the lower part of the tool’s window lists the 
different connection types available and the button  allows the user to establish a connection to a 
TCP/IP host, just like in ComET4. The Controller(s) running a ZxT firmware are automatically 

detected and their axis numbers are displayed in the ZxT Axis drop-down list. 

 

5.3.1. Homing and Limit Stroke 

In this panel the user can automatically set the encoder offsets and to determine the tip/tilt limit 
strokes. 

 

5.3.1.1. Setting factory encoder offsets 

When commissioning a ZxT module, the factory encoder offsets must be adjusted to set the zero 
position of the Z and tip/tilt axes at the center of their respective mechanical strokes. The factory 

encoder offsets can be determined automatically by clicking on the Search Zero button. The tool will 

then determine the zero position of the ZxT module and set the offsets accordingly. 
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After clicking on the Search Zero button, the following information message pops-up. Click on the 

OK button to proceed. To prevent this message from appearing again, select the Do not show again 

checkbox. 

 

 
 

Once the process is completed the following dialog box is displayed and the Indexing Status traffic 

lights switch to green. The new factory encoder offsets corresponding to parameters K480 depths 

0, 1, 2 and 3 are also presented. 

 

 

 

 

The user must save the Controller parameters and reboot it, so that the new Controller parameters 
are taken into account. Refer to Section §10.3 for information on how to save a Controller’s 
configuration. Alternatively, the user can set the factory encoder offsets such that the current Z-tip/tilt 

position becomes the zero position of the ZxT module by clicking on the Set Zero button. 

 

NOTE 

It is highly recommended to use the Search Zero button to automatically find the factory 

encoder offsets. If the application requires the zero position of the Z axis to be located 
elsewhere than the center of the Z stroke, the user can use the homing offset KL45 to 

adjust it (refer to the AccurET Modular Position Controller Operation & Software Manual 
for further information). Only set KL45 after adjusting the factory encoder offsets, as 

modifying these also affects the zero position set by KL45. 

The Set Zero button should only be used when it is required to align the ZxT module’s 

zero position with a specific hardware location. It should not be used to set the zero 
position close to the limits of the Z stroke instead of using KL45. The reason for this is 

that the tip/tilt strokes at the limits of the Z stroke are often not symmetrical and, 
consequently the center of the Z stroke might be inaccurately computed. 
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5.3.1.2. Limit stroke examination 

The ZxT tool allows the user to examine the tip/tilt (Rx and Ry) strokes for different Z positions and 
tip/tilt directions. 

Before initiating the test, define the Z positions as a list of values separated by commas in the Z 
Values edit control and define how many tip/tilt directions in the Number Tip/Tilt Directions edit 

control (e.g. 8 directions means that the tip/tilt axis will change direction by steps of 45 degrees). 

To start the verification, click on the Start button. 
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The following information message pops-up. Click on the OK button to proceed. To prevent this 

dialog box from appearing again, select the Do not show again checkbox. 

 

 
 

Once the test verification is completed the results are displayed as 3D or 2D plots. 
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The user can interact with the plots using the tools that appear when hovering with the mouse over 
the plot: 

 
Zoom in. 

 
Zoom out. 

 
Pan. 

 
3D rotation. 

 
Return to original view. 

 

The results can be saved to a file by clicking on the Save Result button. Alternatively, the user can 

load results from a previously saved test for analysis using the Load Result button. 

The Software Tip/Tilt Limit (corresponding to MAXSL) set in the Controller is displayed and can be 

modified. The Minimum Tip/Tilt Boundary represented by the dotted circles displayed in the 3D plot 

helps the user to find the Controller’s Software Tip/Tilt Limit. Adjust the Software Tip/Tilt Limit 
value in such a way that all maximum stroke measurements are displayed on the exterior of the 
dotted circles. 
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In the above example, the Worst Measured Stroke is 0.097 degrees obtained at the tip/tilt direction 

of 270 degrees and Z position of 1.07 mm. This value is below the Minimum Tip/Tilt Boundary of 

0.1 degrees; in other words, this stroke is on the interior of the dotted circles. Therefore, the 

Controller’s Software Tip/Tilt Limit cannot be set to 0.1 degrees, but to a value lower than the Worst 
Measured Stroke. 

 

 
 

5.3.2. ZxT identification 

In this panel the user can perform an identification of the position loop of a ZxT module or simulate 
its behavior based on identification data previously collected. 

 

5.3.2.1. Identification 

To perform an identification of the position loop at the current position click on the Identify button. 

 

 
 

Once the identification is completed, the results are added to the data list in the Display Control area 

and displayed in the Display area. It is possible to display multiple identification results for 

comparison purposes. Just select from the data list which identification results are to be presented. 

For a better understanding of the different results, a description can be added in the Description edit 

control prior to initiating the identification. Alternately, an identification result can be renamed at any 
time from the data list. To remove an identification result, select it from the data list and click on the 

 button. 

 

NOTE The ZxT control loops needs to be well tuned for the algorithm to work correctly. 



 ComET4 – Commissioning Software 
 User’s Manual 163 

ETEL Doc. / Version N / 31/03/23 

 
 

Like ComET4’s Identification tool, different types of transfer functions and diagrams can be selected 
for display using the drop-down list controls located below the data list. 
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To determine the stability of the ZxT module’s position loop select the ZxT Stability option. The loop 

is stable if all 3 curves pass to the right of the critical point (-1; 0). 
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The user can interact with the plots using the tools that appear when hovering with the mouse over 
the plot: 

 
Zoom in. 

 
Zoom out. 

 
Pan. 

 
3D rotation. 

 
Return to original view. 

 

The identification results can be saved to a file by clicking on the Save Result button. Alternatively, 

the user can load results from a previously saved identification for analysis using the Load Result 
button. 

It is also possible to start a series of identifications at different positions of the Z, Rx and Ry axes. 

For this, select the Advanced option in the left topmost drop-down list and click on Configure to input 

the specifications. 

 

 
 

The following dialog box will open: 
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A different description for each identification can be generated by using 
placeholders. For example, assume that two identifications have to be 
performed: one at Z = 0 mm and a second at Z=1 mm, and the results in 
the data table have to appear with the descriptions: 
- Identification 1: At Z=0 mm; 
- Identification 2: At Z=1 mm. 

For that enter Identification %d: At Z=%z mm in the description field. 
The placeholder %d stands for the consecutive number of the 
identification. With the placeholders %z, %rx and %ry, you can insert the 
Z, Rx and Ry position into the description. 

 

To avoid saving each result manually after the identification, file names 
can be generated similarly to the description. The data will then be saved 

during identification. Click on the Browse button to select the path. 

 

There are two ways of specifying the Z, Rx or Ry positions: 
- A comma to separate the list of numbers; 
- By specifying the start position, the step between positions and the 

final position, separated by colons. Thus, -0.1:0.05:0.1 is equivalent 
to -0.1, -0.05, 0.0, 0.05, 0.1. 

The > buttons to the right of the position edit controls open a separate 

window for editing. The tool will perform an identification for each possible 
combination of Z, Rx and Ry positions. 

 

5.3.2.2. Simulation 

The ZxT tool also allows the user to simulate the behavior of the position loop based on identification 
data previously collected. 

In the upper part of the Simulation area, select which axis to simulate from the drop-down list (Z, Rx 

or Ry) and configure the PID and filters parameters in the corresponding PID and Filters panels. The 

user can select if Rx and Ry should have common parameters by checking the Rx/Ry Coupled 

checkbox. 
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The Bode diagrams below then show the previous (black line) and modified (red line) transfer 

function for PID controller (equivalently for the filters). Upon clicking on the Simulate button, the 

diagram shown in the Display area is recalculated with the new parameters. 
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The simulated Controller settings can be copied to the Clipboard in a format that can be directly 

pasted into ComET4’s Terminal tool for configuring the Controller. Alternatively, if a connection is 

established, click on the Export button to download the configuration directly to the AccurET 

controller. 

The user must save the Controller parameters and reboot it, so that the new Controller parameters 
are taken into account. Refer to Section §10.3 for information on how to save a Controller’s 
configuration. 

 

 
 

5.3.3. Feedforward tuning 

In this panel the user can tune the feedforward parameters to compensate for the effects of the X 
and Y movements of the motion system on top of which is mounted the ZxT module. 

The user sets the tuning conditions in the Tuning area. 

NOTE 
A simulation result cannot be saved. Clicking on the Save Result button will only save 

the original identification data without the controller modifications. 
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Select which Controllers are driving the X and Y axes. 

 

Configure the X and Y axes motion profiles. 

The stroke for the tuning motion is common for X and Y axes and is measured with 
respect to the current axes’ position. 

Uncheck the Use Current Setting checkbox to set a common speed, acceleration 

and jerk time for both X and Y axes. Alternatively, check this checkbox if different 
speed, acceleration and jerks settings are required (use the axis’ current settings). 

 
As the feedforward compensation is Z position dependent, specify different Z 
positions. There are two ways of specifying the Z positions: 
- A comma to separate the list of numbers; 
- By specifying the start position, the step between positions and the final position, 

separated by colons. Thus, -0.1:0.05:0.1 is equivalent to -0.1, -0.05, 0.0, 0.05, 
0.1. 

The > button to the right of the Z Values edit control open a separate window for 

editing. 
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Click on the Start button to initiate the tuning of the feedforward parameters. During the tuning, the 

Display area shows the tracking error of the axis which is currently being tuned (Rx or Ry), adding 

new colored curves for every iteration. 

 

 
 

The user can abort at any time the tuning procedure by clicking on the Cancel button. 

When the tuning is finished, the resulting feedforward values are displayed for each Z position, with 
the corresponding best-fit line. Based on this fit, the calculated mass and offset for Rx and Ry axes 
(respectively registers CF490 and KL250 in depths 0 and 1) are downloaded to the Controller. 

The user must save the Controller parameters and reboot it, so that the new Controller parameters 
are taken into account. Refer to Section §10.3 for information on how to save a Controller’s 
configuration. 

 

 

 

NOTE The results of the feedforward tuning cannot be saved. 
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5.3.4. Stage Mapping 

To enable the stage mapping on the Rx and Ry axes, use the Stage Mapping tool (refer to Section 
§4.2.6) as follows: 

• Select the Rx axis by setting K495 = 0 using the Terminal; 

• Define the mapped and source axes under the Configuration panel. 

• Define and fill the mapping correction table for the Rx axis under the Corrections panel; 

• Click on the Download to Controllers button; 

• Save the configuration to the Controller; 

• Click on the Activate Mapping button; 

• Switch to the Ry axis by setting K495 = 1 using the Terminal; 

• Define and fill the mapping correction table for the Ry axis under the Corrections panel; 

• Click on the Download to Controllers button; 

• Save the configuration to the Controller; 

• Click on the Activate Mapping button. 
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6. Motion 

6.1. S-curve profile 

The S-Curve Profile tool allows the user to easily define motion profiles and generate the 
corresponding Sequence C-like code to be executed by a Controller. 

This tool can be launched by selecting the Menu option Tools → Motion → S-Curve Profile: 

 

 
 

 

 

1 

4 

2 

3 
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The S-Curve Profile tool window is divided into 4 areas: 

1. Definition of the motion profile(s); 
2. Visualization of the motion profile(s); 
3. Motion testing; 
4. Sequence code generation. 

 

In the first area, the user defines the specifications of the motion profile(s) to be executed. Up to four 

profiles can be defined and concatenated. By default only Movement 1 is enabled, but the remaining 

movements can be enabled by clicking on the check box control on the top right side. 

 

 
 

Here is what the user must set to configure the motion profile: 

Definition of the motion profile(s) 

 

Starting position. It can be relative to the current position of the axis, i.e. the current position 
is the starting point. Or, it can be relative to some position the user defines in the 
corresponding edit box control. 

 
Stroke corresponds to the relative distance to be travelled for this motion profile. 

 

Velocity. Depending on the profile definition, this value might not actually be reached during 
the movement. 

 

Acceleration. The same value is applied for the deceleration phase. Depending on the 
profile definition, this value might not actually be reached during the movement. 

 

Jerk, expressed in time (seconds). Depending on the profile definition, this value might not 
actually be reached during the movement. 

 

Dwell-time is the duration of the static motion at the end of the profile before the next one 
initiates. 

 

In the second area, the user can visualize the evolution over time of the motion profiles specifications 
that were defined. Here is what these specifications represent on these plots. 

 

NOTE 
The S-Curve Profile tool only allows to define motion profiles of a single axis (i.e. in a 
single dimension). 
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Once the motion has been defined, the user can verify its execution using the following buttons: 

 
Execute the motion profile of the axis in the backward direction. 

 
Stop the execution of the motion profile. 

 
Execute the motion profile of the axis in a forward direction. 

 Repeat continuously the motion profile. 

 

 

 
 

stroke 

origin 

constant 
velocity 

constant 
acceleration 

jerk-time 

dwell-time 

NOTE Ensure that the axis is powered on before making a movement. 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 
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Take the example of the following motion profile composed of two movements defined to travel in 
one direction and inverse direction to bring back the axis to the starting point. 

 

 
 

Configure the Scope tool to display the theoretical and real positions (ML6 and ML7, respectively) 

on Roll mode. Then, select the continuous mode check box on the S-Curve Profile tool, click on the 

button  to execute the motion profile on the forward direction and analyze the signals on the Scope. 
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Click on the  to execute the motion profile on the backward direction. 

 

 

 

 

After having verified that the defined motion profile performs as expected, the user can generate the 
corresponding Sequence C-like code to be executed by a Controller. For that, use one of the buttons: 

 

 
Opens a new Editor window with the Sequence code corresponding to the defined motion profile. 

 

Copies onto the Clipboard the Sequence code corresponding to the defined motion profile. The user can then 

paste this code to whatever editor of his choice. 

 

 

 

6.2. Console tool (Point-to-Point motion) 

The Console tool allows the user to perform simple point-to-point movements. It provides a similar 

functionality to what the user can already find in the Startup Wizard tool (panel #5) or on the Toolbar 
Motion group. However, the Console tool also allows the user to set the speed and acceleration for 

the motion, to store the positions for replay and to manage several axis from the same interface. 



 ComET4 – Commissioning Software 
 User’s Manual 177 

ETEL Doc. / Version N / 31/03/23 

 

 
 

The Console tool can be launched by selecting the Menu option Tools → Motion → Console (Point-
to-Point): 

 

 
 

The Console tool window is divided into 3 areas: 

1. Current position of the selected axis; 
2. Motion definition, namely, motion stroke or target position, speed and acceleration; 
3. Management of stored positions. 

 

 
 

Here is an explanation of the controls that can be found in the first area of the Console tool: 

Current position of the selected axis 

 

Select one of the axes from the drop-down list with the available axes. 

 Current position of the selected axis. 

 

Select the units used to display the current position of the selected axis. 

 

Additional axes can be added to the Console tool. Simply select the option Add a new console from 

the contextual menu that pops-up when right-clicking on the tool’s window. 

 

NOTE 
Refer to Section §2.4.5 for more information about panel #5 of the Startup Wizard tool. 

Refer to Section §2.2.10 for more information about the Toolbar Motion group. 

1 2 3 
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Similarly, an axis (or multiple axes) can be removed from the Console tool. First, select which axis 
(or axes) to remove using the checkbox controls on the left of the axis identifier and then select the 

option Remove selected console from the contextual menu that pops-up when right-clicking on the 

tool’s window. 

 

 
 

Here is an explanation of the controls that can be found in the second area of the Console tool: 

Motion definition 

 
Execute a jog movement of the axis in the backward direction. 

 
Execute a jog movement of the axis in the forward direction. 

 
Execute a relative movement of the axis in the backward direction. Distance to move is defined on the 
relative position control. 

 
Execute a relative movement of the axis in the forward direction. Distance to move is defined on the 
relative position control. 

 
Execute an absolute movement of the axis to the position defined on the target position control. 

 

Dual-purpose control: 
- Relative position control: distance to move for relative movements; or 
- Target position control: target position for an absolute movement. 
Select the units accordingly. 

 
Set the speed and acceleration of the motion using the slider or edit controls. 

 

 

 
 

NOTE Ensure that the axis or axes are powered on before making a movement. 

WARNING 
Always ensure that the proper safety precautions are taken when powering on a 
Controller and executing movements with a motion system. 
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Here is an explanation of the controls that can be found in the third area of the Console tool: 

Management of stored positions 

 
Save the current position to the list of stored positions. 

 
Execute a movement to previous position in the list of stored positions. 

 
Execute a movement to next position in the list of stored positions. 

 
Move sequentially and continuously to all positions in the list of stored positions. 

 
Stop the axis movement. 

 
View (and edit) the list of stored positions. 

 

The user can view and edit the list of stored positions by clicking on the button  to display the 

Stored positions dialog box. This dialog box is divided in three distinct areas: 

1. List of all stored positions; 
2. Motion execution controls; 
3. Editing controls. 

 

 
 

The list of all stored positions is displayed in the first area. The user can select any entry from this 
list and use the controls in the third area to edit its value, delete the entry from the list or add new 
entries to the list. 

The controls in the second area are related to motion execution according to the list of stored 

positions and have the same functionality as described previously. Only the Delay slider control has 

not yet been introduced. It allows the user to define a waiting time before execution of the movement 
to the next target position. 

 

1 

2 

3 
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The editing controls in the third area are described below: 

Edit controls 

 Input a position value and select the corresponding units. 

 
Modify the selected entry in the list of stored positions with the value entered in the previous control. 

 

Add a new position to the list of stored positions just before (above) the selected entry. This always 

creates a new entry with a zero position value. Use the modify control  to modify the value. 

 

Add a new position to the list of stored positions just after (below) the selected entry. This always 

creates a new entry with a zero position value. Use the modify control  to modify the value. 

 
Delete the selected entry from the list of stored positions. 

 

Take the example of the following list of stored positions that correspond to a movement in one 
direction and then backwards to the starting point. 

 

 
 

Configure the Scope tool to display the theoretical and real positions (ML6 and ML7, respectively) 

on Roll mode. Then, click on the button  to move sequentially (and continuously) to all positions in 

the list of stored positions and analyze the signals on the Scope. This is the result for a zero delay in 
between movements. 
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This is now the result with a 2s delay in between movements. 

 

 

 

 

Finally, as presented before, the user can add several axes to the Console tool and control their 
movement. Here is an example with two axes, one linear and another rotary. 

 

 
 

The user has started the first movement of the linear axis from its current position at -10mm up to 
the target position at -30mm. A second movement of rotary axis is also realized from 0 degrees up 

to 270 degrees. This is how it looks like on the Scope tool. 
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7. Monitoring & Diagnostics 

7.1. Scope 

The Scope tool is one of the most versatile and suitable tools available in ComET4 for monitoring 
and troubleshooting an application. 

There are several ways to launch the Scope tool, such as: 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → Acquisition → Scope. 

 

 

The Scope tool main window is divided in 5 areas: 

1. Trigger panel; 

2. Trace panel; 

3. Scale/Cursor panel; 

4. Zoom panel; 

5. View: Scope and FFT. 

 

 

 

NOTE 

A Trace is an advanced register type (T register) which allows the acquisition of the 

Controller’s basic register types K, M, X and C versus time. 

A trace contains the values of the selected register, sampled at the frequency set by the 
user and with the acquisition starting from the moment the trigger conditions, also set by 
the user, are valid. 

Refer to the AccurET Modular Position Controller Operation & Software Manual and the 
UltimET Light/ADVANCED Motion Controllers User’s Manuals for more information 
about register types. 
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The user can customize the layout of this main window. All areas except the View can be hidden to 

free screen real estate for the plots. Right-click on the Scope‘s tool window to bring up a contextual 
menu and select which panels to show/hide. 

 

 

 

7.1.1. Trigger panel 

The Scope tool supports the following acquisition modes: 

 

Perform a single acquisition. The trace is acquired when the trigger is fired. The trigger is not re-armed 

automatically (single shot). The trace is uploaded from the Controller and displayed in the View area 

replacing the previous view. To configure the trigger conditions click on the Setup button. 

 

Perform an acquisition every time the trigger is fired. Once fired, the trace is uploaded from the Controller 

and displayed in the View area replacing the previous view. The trigger is automatically re-armed after each 

acquisition. To configure the trigger conditions click on the Setup button. To stop this acquisition mode 

simply click on the same button to toggle off the mode or press the Stop button. 

 

Perform acquisitions continuously independently of the trigger conditions. The trace is uploaded from the 

Controller and displayed in the View area appended to the already existing data. To stop this acquisition 

mode simply click on the same button to toggle off the mode or press the Stop button. 

 

 

1 2 

3 

4 

5 
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Click on the Setup button to configure the acquisition settings: 

• Trigger mode, delay and source; and 

• Acquisition resolution. 

 

 
 

These are the options available for the Trigger Mode and Trigger Source: 

Trigger Mode Trigger Source 

 Trigger is fired immediately.  

 Trigger is fired once the movement begins on the selected 
axis or interpolation group (if any). 

The detection of the movement is based on the toggling of 
the isMoving bit (Bit #4 in M60 and bit #20 in M63) in 

the Controller. 

 

 Trigger is fired once the movement ends on the selected 
axis or interpolation group (if any). 

The detection of the movement is based on the toggling of 
the isMoving bit (Bit #4 in M60 and bit #20 in M63) in 

the Controller. 
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Trigger Mode Trigger Source 

 Trigger is fired once the selected axis reaches the pre-
defined position. 

The user can also define if the trigger should be fired on: 
- Rising edge: position is reached with a movement 

direction corresponding to increasing values of 
position; 

- Falling edge: position is reached with a movement 
direction corresponding to decreasing values of 
position; or 

- Both: position is reached from whatever direction. 

 

 Trigger is fired once the selected trace reaches the pre-
defined value. 

The user can also define if the trigger should be fired on: 
- Rising edge: value is reached coming from smaller 

values, i.e. trace values are increasing when the pre-
defined value is reached; 

- Falling edge: value is reached coming from bigger 
values, i.e. trace values are decreasing when the pre-
defined value is reached; or 

- Both: value is reached from whatever direction. 

 

 Trigger is fired once the selected register reaches the pre-
defined value. 

The user can also define if the trigger should be fired on: 
- Rising edge: value is reached coming from smaller 

values, i.e. register values are increasing when the 
pre-defined value is reached; 

- Falling edge: value is reached coming from bigger 
values, i.e. register values are decreasing when the 
pre-defined value is reached; or 

- Both: value is reached from whatever direction. 
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Trigger Mode Trigger Source 

 Trigger is fired when the bits of the selected register 
corresponding to the LOW and HIGH state bit masks are 
set accordingly. 

Take the following example with register M63, where one 

would like to trigger when: 
- Bit #26 (controller in error) is “0”, i.e. axis is not in error; 

and 
- Bit #20 (isMoving bit) is “1”, i.e. axis is moving. 

To achieve this behavior: 

- Bit field LOW state must be set to 0x04000000, 

corresponding to the mask for Bit #26. 

- Bit field HIGH state must be set to 0x00100000, 

corresponding to the mask for Bit #20. 

 

 Trigger is fired when the bits of the selected register 
corresponding to either Rising Edge or Falling Edge state 
bit masks are toggled accordingly. 
Take the following example with register M63, where one 

would like to trigger when: 
- Bit #20 (isMoving bit) is set to “1”, i.e. start of motion 

detected; and 
- Bit #20 is set to “0”, i.e. end of motion detected. 
 
To achieve this behavior: 

- Rising Edge Bit field must be set to 0x00100000, 

corresponding to the mask for Bit #20. 

- Falling Edge Bit field must be set to 0x00100000, 

corresponding to the mask for Bit #20. 

 

 

These are the options available for the Trigger Delay: 

Trigger Delay 

 Controller starts recording at the exact moment the trigger is fired. 

 Controller records the x milliseconds prior to the trigger being fired. 

 Controller starts recording x milliseconds after the trigger is fired. 

 

Regarding the Acquisition Resolution, the user has multiple options to input the information: 

Acquisition Resolution 

 

Input the acquisition time and number of acquisition points. The Scope tool will determine the 
sampling frequency that best fits these settings. 



 ComET4 – Commissioning Software 
188 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 

Input the acquisition time and sampling time (or sampling frequency if the Use sampling 
frequency checkbox is selected). The Scope tool will determine the number of acquisition 

points that best fits these settings. 

 

Input the sampling time (or sampling frequency if the Use sampling frequency checkbox is 

selected) and number of acquisition points. The Scope tool will calculate the corresponding 
acquisition time for such settings. 

 

The Computed Values group control displays the values actually set for the acquisition resolution 

accounting for the limits of the Controller. In other words, the user input for defining the acquisition 
resolution is not always feasible because the Controller has a limited sampling frequency (which 
depends on the Controller model) and a limited number of acquisition points (16384): 

 

 

 

Furthermore, not all registers are sampled at the same frequency in the Controllers. E.g., in the 
AccurET position controller, some registers are updated at the PLTI rate, while others are updated 
at the slower MLTI rate. Also, UltimET motion controllers have a different sampling rate from the 

AccurETs. So, when monitoring simultaneously with the Scope tool registers with different sampling 
rates, it might be more convenient to use a common sampling rate. If this is the case, select the 

Common frequency checkbox to acquire all traces using the same common sampling rate. 

 

 

 

7.1.2. Trace panel 

The Scope tool can display up to 4 traces simultaneously belonging to any axis. Only basic register 
types can be monitored: 

• K (parameters); 

• M (monitorings); 

• X (user variables); 

• C (common). 

 

NOTE 

When selecting the Common frequency checkbox, the Scope tool actually decimates the 

traces acquired with a higher sampling rate to ensure a common time base for all the 
traces acquired. 
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Under the TRACES group control, the user can select which registers to monitor on each trace, 

following one of two possible options: 

 

1. Select the register from the left drop-down list. Only the most frequently used registers are listed 
and these are related to the current axis (i.e. axis with which the connection is established). 
The units used to display the trace can also be selected on the right drop-down list. 

  

2. Click on the More button and configure the trace selection: 

• Axis (can be any “visible” axis); 

• Register type, index and depth; 

• Units used to display the trace. 

 

 

 

In the Scope view area, the plot abscissa (horizontal X axis) is usually reserved for the time scale, 
while the ordinate (vertical Y axis) is used for the traces. However, when all traces acquired by the 

Scope tool belong to the same axis or have been acquired with the acquisition resolution option 

Common sampling time selected (refer to previous Section §7.1.1), it is possible to assign one of 

these traces to the abscissa, while the other(s) remain assigned to the ordinate. This feature can be 
used e.g. for displaying the 2D trajectory executed by a XY system. 

Finally, the user can hide a trace or change its style. Right-click on the TRACES group control to bring 

up the context menu allowing to show/hide traces and change their style. 
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7.1.3. Scale/Cursor panel 

The Scope tool includes a Cursor measurement function with two cursors that can be used to readout 

the trace(s) values and compute the difference. This function can be configured on the CURSORS 

panel. 

 

 
Show/Hide cursor (red/blue). 

 

 
Lock/Unlock cursor to assigned trace. When locked, the cursor will 
follow the trace signal. 

 Assign cursor (red/blue) to a trace (both cursors can be assigned 
to the same trace). Here, the red and blue cursors are assigned 
respectively to Trace 1 and Trace 2.  

 Cursor readouts: abscissa (horizontal) and ordinate (vertical) 
readings. 

 

 
Difference between red and blue cursor readouts. 

 

 

Cursors 
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Under the SCALES panel, the user can configure the behavior of the plot scales. Use the Auto 

checkbox to choose between automatic adjustment of the scale limits or manual setting and use the 

Show checkbox to include separate vertical scale axis for each trace. 

The user can also configure the numerical representation (format and precision) to apply to the scale 

labels, as well as the type of scale (linear or logarithmic). Right-click on the SCALES panel to bring 

up the context menu allowing to modify these settings. 

 

  

 

7.1.4. View 

The View area is composed of two panels: 

• SCOPE; and 

• FFT. 

 

 

 

In the SCOPE panel are displayed the time domain plots of the acquired traces (up to 4 traces 

simultaneously belonging to any axis can be displayed). Besides the already described cursors and 
scales, the user can also find in this display the trigger marker. 

 

TIP 
The color of the grid, frame, background, traces, cursors and trigger for the View area of 

the Scope tool can be customized under File → Preferences → Colors. 
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The user can adjust the view of the plots with the available view controls from the Zoom panel: 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed demagnification ratio. 

 
Undo previous Zoom action. 

 
Pan. 

 
Return to original view. 

 

The FFT panel includes two plots: 

• Selected trace (time domain); and 

• Single-sided FFT of the selected trace (frequency domain). 

 

Trigger marker 
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The user can use the red and blue cursors on the time domain plot to delimit the signal for which the 

FFT is actually computed (these are the cursors the user can configure under the Scale/Cursor panel 

on the right side of the main window). 

Furthermore, the FFT panel view has a third cursor (red) available to be used exclusively on the FFT 

plot. The abscissa and ordinate for this cursor, as well as the show/hide control, can be found in the 
bottom part of the window. 

 

 
 

Finally, the user can choose to remove the offset (DC component) and select between linear or dB 
for the vertical scale and logarithmic or linear for the horizontal scale. 

 

 
 

NOTE 
On the FFT panel, only one trace can be displayed at a time. Also, changes introduced 

to the scales configuration in the Scale/Cursor panel do not affect this view. 
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7.1.5. Save acquisition data 

The Scope acquisitions can be saved to a text file and imported back to the Viewer tool (refer to 

Section §7.2) for offline analysis. With the interface focus on the Scope tool window, select the menu 

entry File → Save Acquisition…. 

 

 
 

Type in the file name in the Save As dialog box and click on the Save button. Then, fill in the 

information in the Save File Format dialog box and finally press on the OK button to save the Scope 

acquisition data. 

 

 

 

 

Alternatively, the Scope acquisition data can be exported to Excel (*.csv file format) by selecting 

the menu option File → Export Acquisition to Excel…. 

 

7.2. Viewer 

The Viewer tool allows the user to display acquisitions realized with the Scope tool. It can be used in 
either on-line (i.e. connection to a Controller required) or off-line modes. 

TIP 
The View area can be expanded by selecting the Menu option View → Full/Normal 
Scope View or pressing the F7 shortcut. Use the same option to restore the default view. 
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To launch the Viewer tool, go to the Menu option Tools → Acquisition → Viewer: 

 

 
 

The main window of this tool is divided in 4 areas: 

1. Traces selection panel; 

2. Zoom panel; 

3. Cursors panel; and 

4. View. 

 

 
 

7.2.1. Traces selection panel 

This panel allows the user to load traces acquired with the Scope tool. Up to 16 traces are supported 

by the Viewer tool. 

There are basically three sources from where to “procure” the traces to be displayed: 

1 2 3 

4 
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File name: load a Scope acquisition previously saved to a file. 

Scope: load traces acquired with a running Scope tool. 

Math function: perform mathematical operations with traces already 

loaded to the Viewer tool. 

 

7.2.1.1. File 

To load a file of a Scope acquisition, select the File name option, click on the Browse button to select 

the file and then click on Open to close the dialog box. 

 

 
 

Next, click on the Upload File button to load the acquisition data into the Viewer tool. 

 

 
 

All the traces stored in the acquisition file are listed on the Trace drop-down list. The user can select 

which trace to display in the View area and which units to use. 
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Saved Scope acquisition files containing traces acquired with the Roll acquisition mode (refer to 

Section §7.1.1 for information about the available acquisition modes in the Scope tool) are not 

supported by the Viewer tool and any attempt to load such files will generate the following error 
message: 

 

 
 

Click on the OK button to clear the message and return to the Viewer tool. 

NOTE 
There is no need to have a connection established with a Controller to use the Viewer 
tool if all the all the traces to be displayed are loaded from a file. In other words, the 

Viewer can be used on off-line mode. 



 ComET4 – Commissioning Software 
198 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 

7.2.1.2. Scope 

An alternative way to load a trace to the Viewer tool is to transfer it directly from the Scope tool. For 

this case, select the Scope option and click on the Upload Scope button to transfer to the Viewer the 

traces acquired by the Scope. 

 

 
 

As before, all the traces transferred are listed on the Trace drop-down list. The user can select which 

trace to display in the View area and which units to use. 
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At the moment of clicking on the Upload Scope button, if the Scope tool is not running an error 

message is displayed. 

 

 
 

If the Scope tool is performing a Continuous or Roll acquisition (refer to Section §7.1.1 for information 

about the available acquisition modes in the Scope tool) at the moment a request of transfer is issued 

by the Viewer tool, the following error message pops-up: 

 

 
 

A similar error message is also displayed if the last acquisition performed by the Scope tool was 
done in Roll mode. 

 

 
 

In any case, just click on the OK button to clear the message and return to the Viewer tool. 

 

7.2.1.3. Math function 

The last option Math function differs from the previous ones in the sense that a virtual trace is 

recreated by applying mathematical operations on already loaded traces. 

Consider the example of taking the absolute value of a signal. Type in abs(T1), where T1 stands 

for Trace 1, in the Math function edit control and click on the Calculate Function button. 

 

NOTE 
Only the traces that are visible in the Scope tool will be transferred to the Viewer tool. 

This mode requires a connection with a Controller and the Scope tool opened with 
recently acquired traces. 
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The result is depicted below. Note that the scale of Trace 2 (rose pale scale on the right side furthest 
away from the plot) contains only positive numbers ranging from 0.01 to 0.02, whereas the scale of 
the original Trace 1 (green scale also on the right side closest to the plot) contains negative numbers 
ranging from -0.02 to -0.01, which is what is expected from an absolute value operation. 

 

 

 

 
 

If a nonexistent mathematical function is used, an error message similar to this one is displayed. 

 

NOTE When using the mathematical functions, T0 refers to Trace 0, T1 to Trace 1 and so forth. 
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Similarly, if the mathematical function does reference to a trace not yet available in the Viewer tool, 
the following error message pops up: 

 

 
 

Here is a list of the supported mathematical functions: 

a & b bitwise AND with a and b 

a l b bitwise OR with a and b 

a << b SHIFT LEFT a with number of bits b 

a >> b SHIFT RIGHT a with number of bits b 

a &~ b bitwise NOT AND 

a || b bitwise XOR with a and b 

a + b ADD a and b 

a - b SUBSTRACT b from a 

a * b MULTIPLY a by b 

a / b DIVIDE a by b 

a % b a MODULO b 

a ^ b elevate a by power of b 

abs(a) ABSOLUTE VALUE of a 

sqrt(a) SQUARE ROOT of a 

 

Here are a few examples on how to use these mathematical functions: 

• 2 * (T1 + T2) / T3 – T4; 

• 3 * abs(T1). 
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Here is a list of the special series mathematical functions that are supported: 

derivative(T<n>) DERIVATE Trace n 

integral(T<n>) INTEGRATE Trace n 

undersampling(T<n>, <step>, <offset>) UNDERSAMPLE Trace n with step from offset 

filter(T<n>) MOVING AVERAGE of Trace n 

 

 
 

Once a trace has been loaded to the Viewer tool, the user can control if the plot is actually displayed 

or not in the View area. There is checkbox control on the left of the trace name for this purpose. 

 

 
 

However, an attempt to display a trace that has not yet been loaded generates one of the following 

error messages, depending whether the user has already selected a Source option (i.e. File name, 

Scope or Math function) or not. 

 

 
 

 
 

Each trace is displayed in the View area according to its color (border around the Traces selection 
panel). The trace color and style can be modified by right-clicking on the Traces selection panel. 

 

NOTE 

The series mathematical functions cannot be applied over a regular mathematical 
function. E.g. derivative(T1 + T2) must be handled in two steps: 

 T3 = T1 + T2 

 T4 = derivative(T3) 
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Finally, the Share scale with option allows the user to apply the same scale between traces, with the 

corresponding update in the View area. In other words, one trace will be referenced to another and 

the same unit factor will be applied. 

Take for example traces 1 and 2, where trace 2 applies the absolute value mathematical function of 

trace 1. If these traces do not share a common scale, each trace is displayed in the View area with 

its own scale. Selecting trace 2 to share the scale of trace 1 (or vice-versa), only one scale exists 
and it applies to both traces. 
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7.2.2. Zoom panel 

The user can adjust the view of the plots with the available view controls from the Zoom panel: 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed demagnification ratio. 

 
Undo previous Zoom action. 

 
Pan. 

 
Return to original view. 

 

7.2.3. Cursors panel 

The Viewer tool includes a Cursor measurement function with two cursors that can be used to 
readout the trace(s) values and compute the difference. This function can be configured on the 

Cursors panel. 

 

 
Show/Hide cursor (green/blue). 

 

 
Lock/Unlock cursor to assigned trace. When 
locked, the cursor will follow the trace signal. 

 
Assign cursor (green/blue) to a trace (both 
cursors can be assigned to the same trace). Here, 
the green and blue cursors are assigned 
respectively to Trace 0 and Trace 1.  

 

Cursor readouts: abscissa (horizontal) and 
ordinate (vertical) readings. 
The bottom control displays the difference 
between green and blue cursor readouts. 
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7.2.4. View 

The traces loaded to the Viewer tool are displayed in this area. Each trace will have its own scale, 

except if the scale sharing option is activated in the Traces selection panel. 

The View area includes four panels: 

• Time domain; 

• Fast Fourier Transform (FFT) of the first selected trace in the Traces selection panel; 
• Power Spectrum (PS) of the first selected trace in the Traces selection panel; and 

• Cumulative Power Spectrum (CPS) of the first selected trace in the Traces selection panel. 

 

Two plots are displayed in the FFT, PS and CPS panels: 

• Top plot: first selected trace in the Traces selection panel (time domain); and 

• Bottom plot: single-sided FFT/PS/CPS of the selected trace (frequency domain). 

 

In these FFT, PS and CPS panels, the user can use the green and blue cursors on the time domain 

plot to delimit the signal for which the FFT/PS/CPS is actually computed (these are the cursors the 

user can configure under the Cursors panel). 

 

Cursors 



 ComET4 – Commissioning Software 
206 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 
 

Furthermore, these panels have a third cursor (white) available to be used exclusively on the 
frequency domain plots. The abscissa and ordinate for this cursor, as well as the show/hide control, 
can be found in the bottom part of the window. Finally, the user can choose to remove the offset (DC 
component). 

 

 

 

7.3. Identification 

After a basic setting of the Controller is completed (refer to Section §4.1 for more information on how 
to realize a basic setting), the user can use the various types of identification available in the 

Identification tool to validate and fine tune the Controller’s regulation. 

This tool can be launched by selecting the Menu option Tools → Acquisition → Identification: 
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The main window of the Identification tool is divided into 2 areas: 

1. Selection of the identification type and frequency limit/level of quality; 
2. Panel with two tabs 

a. Diagram showing a representation of the Controller’s regulators with the noise injection 

point and measurement points (inputs and outputs) corresponding to the selected type 
of identification; and 

b. Bode and Nyquist plots of the selected transfer function amongst those computed from 

the identification performed. 

 

 
 

1 
2 
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In the Bode & Nyquist panel, the user can adjust the view of the plots with the available tools: 

 
Zoom to rectangle. 

 
Zoom along the horizontal axis while keeping the vertical axis scale fixed. 

 
Zoom along the vertical axis while keeping the horizontal axis scale fixed. 

 
Zoom in with a fixed magnification ratio. 

 
Zoom out with a fixed demagnification ratio. 

 
Undo previous Zoom action. 

 
Return to original view. 

 Select which of the plotted data has the focus for the cursors’ information: raw or filtered. 

 Enable/disable the red vertical cursor. 

2 
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 Enable/disable the blue vertical cursor. 

 Move to the left the vertical cursor with the focus. 

 Move to the right the vertical cursor with the focus. 

 
Extend the Nyquist plot by hiding the Bode plot and vice-versa. 

 

The Identification tool is capable of realizing different types of identification. They all rely on 
experiments that are performed under the following basic conditions: 

• Open or Closed position control loop; and 

• Noise injected at the level of the theoretical position or theoretical current. 

As for the measurement points (inputs and outputs), these vary according to the type of identification 
selected (refer to the following Sections for details). 

Here are the types of identification supported: 

Identification type Noise injection point Position control loop 

 

Position loop 
Theoretical position 

Closed 
Theoretical current 

Current loop Theoretical current Open 

Mechanical Transfer Func. Theoretical current Open 

Mechanical TF. (pos loop) 
Theoretical position 

Closed 
Theoretical current 

Motor’s coils Theoretical current Open 

Full Transfer Func. 
Theoretical position 

Closed 
Theoretical current 

Advanced Identification 

Theoretical position Closed 

Theoretical current 
Open 

Closed 

 

The user must also select the frequency limit and level of quality of the identification: 

Frequency limit and level of quality 
Frequency 

limit 

Frequency bands 

Number Bands (Hz) 

 

Standard (10.00 kHz) 10 kHz 8 

 [0 – 78.1] [78.1 – 156] 
 [156 – 313] [313 – 625] 
 [625 – 1250] [1250 – 2500] 
 [2500 – 5000] [5000 – 10000] 

Standard (2.50 kHz) 2.5 kHz 6 
 [0 – 78.1] [78.1 – 156] 
 [156 – 313] [313 – 625] 
 [625 – 1250] [1250 – 2500] 

Fast (10.00 kHz) 10 kHz 6 
 [0 – 313] [313 – 625] 
 [625 – 1250] [1250 – 2500] 
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 [2500 – 5000] [5000 – 10000] 

Fast (2.50 kHz) 2.5 kHz 4 
 [0 – 313] [313 – 625] 
 [625 – 1250] [1250 – 2500] 

High Quality (1.25 kHz) 1.25 kHz 8 

 [0 – 9.77] [9.77 – 19.5] 
 [19.5 – 39.1] [39.1 – 78.1] 
 [78.1 – 156] [156 – 313] 
 [313 – 625] [625 – 1250] 

 

 
 

Once the type of identification and frequency limit/quality level have been selected, click on the Start 
button to initiate an identification. 

 

7.3.1. Position loop 

The Position loop identification type is suited for analyzing the stability margins and bandwidth of 

the system and the immunity to disturbances. 

This identification is realized in position closed loop mode, with the possibility of selecting between 

injecting the noise at the level of the theoretical position or theoretical current through the Noise 
added on Current Reference checkbox control. 

The measurement points for this type of identification are: 

Noise injection 
point 

Measurement points 

Inputs Outputs 

Theoretical position 
Theoretical position 

(M0) 
Real position 

(M1) 

Theoretical current 
Injected noise 

(MF236) 

Theoretical current before KF60 limit 

(MF233) 

 

Once the identification has finished, the Bode & Nyquist plots are displayed, with the option of 

selecting amongst the three transfer functions available: 

• Open loop, defining the system’s stability margin (gain, phase and modulus margins) and 
bandwidth (0 dB frequency crossing); 

• Closed loop, defining the system’s rigidity; 

• Sensitivity, defining the system’s immunity to disturbances. 

 

NOTE The frequency limit depends on the Controller connected to ComET4. 
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7.3.2. Current loop 

The Current loop identification type is suited for observing the stability margins and bandwidth of 

the current loop and its immunity to disturbances. 

This identification is realized in position open loop mode, but current closed loop mode, with the 
noise injection point at the level of the theoretical current. 

The measurement points for this identification type are: 

Noise injection 
point 

Measurement points 

Inputs Outputs 

Theoretical current Theoretical current (MF30) Real current (MF31) 

 

Once the identification has finished, the Bode & Nyquist plots are displayed, with the option of 

selecting amongst the three transfer functions available. 

NOTE 
The Nyquist diagram is only displayed for the open loop transfer function, as it has no 
meaning for the other two transfer functions (closed loop and sensitivity). 
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• Open loop; 

• Closed loop; 

• Sensitivity. 

 

 
 

7.3.3. Mechanical Transfer Func. 

The Mechanical Transfer Func. identification type is suited for analyzing the mechanical behavior of 

the system independent from the setting: resonances and anti-resonances, integrator effect, etc. 

The mass (inertia) can also be determined using the mass-line (-40 dB/dec slop line in the 
mechanical position transfer function and -20 dB/dec slop line in the mechanical speed transfer 
function). 

This identification is realized in position open loop mode, with the noise injection point at the level of 
the theoretical current. 

The measurement points for this identification type are: 

Noise injection 
point 

Measurement points 

Inputs Outputs 

Theoretical current Real current (MF31) 
Real position (M1) 

Real speed before advanced filter depth 0 (M111) 
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Once the identification has finished, only the Bode plots are displayed, with the option of selecting 

between the two transfer functions available: 

• Mechanical position defining the force vs. position; and 

• Mechanical speed defining the force vs. speed. 

 

 
 

7.3.4. Mechanical TF. (pos loop) 

The Mechanical TF. (pos loop) identification type is similar to the previous one (§7.2.3), but realized 

in position closed loop mode. Also, the user can select between injecting the noise at the level of 

the theoretical position or theoretical current using the Noise added on Current Reference checkbox 

control. 

The measurement points for this identification type are: 

Noise injection 
point 

Measurement points 

Inputs Outputs 

Theoretical position Theoretical position (M0) Real position (M1) 

Real speed (M11) 

Real current (MF31) Theoretical current Injected noise (MF236) 
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As for the previous identification type (§7.2.3), the transfer functions available for analysis are: 

• Mechanical position defining the force vs. position; and 

• Mechanical speed defining the force vs. speed. 

 

 
 

7.3.5. Motor’s coils 

This Motor’s coils identification type is suited for analyzing the electrical transfer function of the first 

phase of the motor and it is realized in position open loop mode. 

The measurement points for this identification type are: 

Noise injection 
point 

Measurement points 

Inputs Outputs 

Theoretical current Phase 1 theoretical voltage (MF29) Real current (MF31) 

 

There is only one transfer function for analysis: Motor’s coils. 

 



 ComET4 – Commissioning Software 
 User’s Manual 215 

ETEL Doc. / Version N / 31/03/23 

 
 

7.3.6. Full Transfer Func. 

The Full Transfer Func. is a combination of the following identification types: 

• Position loop; 

• Current loop; and 

• Mechanical TF. (pos loop). 

It is suited for analyzing the stability margins and bandwidth of the system, the immunity to 
disturbances, the mechanical behavior (resonances and anti-resonances) and finally the stiffness of 
the system. It is the most efficient way of doing all these analysis with a single identification. 

This identification is realized in position closed loop mode, with the possibility of selecting between 

injecting the noise at the level of the theoretical position or theoretical current using the Noise added 
on Current Reference checkbox control. 

Immediately after clicking on the Start button to execute the identification, the following warning 

message is displayed to inform the user that the stiffness transfer function will be calculated using 

the motor Kt factor set on the Controller. Simply click on the OK button to proceed with the 

identification or Cancel to abort. 
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The transfer functions available are the same as those for the identification types Position loop, 

Current loop and Mechanical TF. (pos loop), with an additional Stiffness transfer function. 

 

 
 

7.3.7. Advanced Identification 

This type of identification provides the possibility to define ad-hoc transfer functions. The user must 
specify: 

1. Input signals: axis number and register type, index and depth; 
2. Output signals: axis number and register type, index and depth; 
3. Noise injection point: axis number and injection point: 

a. Theoretical position: Pos. Reference; 

b. Theoretical current in open loop mode: Cur. Reference (with Pos. loop open); 
c. Theoretical current in closed loop mode: Added on Cur. Reference (with Pos. loop 

open). 
4. Display or not the Nyquist plot together with the Bode plot. 
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The transfer functions are then computed between the output signals and the input signals. Since it 
is possible to select input and output signals from different axes, crossed-identification analysis are 
possible with this option. 

The button  enables the user to hide the advanced options, leaving more space for the Bode and 
Nyquist plots. Click on the button  to revert the view. 
 

7.3.8. Save acquisition data 

The identification information can be saved to a text file and imported into the ATP Analysis tool. 

With the interface focus on the Identification tool window, select the menu entry File → Save 
Acquisition…. 

 

 

1 2 

3 
4 
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Type in the file name in the Save As dialog box and click on the Save button. Then, fill in the 

information in the Save File Format dialog box and finally press on the OK button to save the 

identification data. 

 

 

 

 

Alternatively, the identification information can be exported to Excel (*.csv file format) by selecting 

the menu option File → Export Acquisition to Excel…. 

 

7.4. Monitor 

The Monitor tool is one of the simplest tools available in ComET4 for monitoring and troubleshooting 
an application. 

To launch the Monitor tool, go to the Menu option Tools → Acquisition → Monitor: 

 

 
 

Compared to the Scope, the Monitor tool can be used to monitor a wider selection of register types 
(basic and advanced) belonging to any axis, but only the most recently sampled value is displayed. 
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First, select the axis from the left-most drop-down list. 

 

 
 

Then, choose the register type from the second drop-down list, as well as register’s index and depth 
from the next list controls. 

 

 
 

The register types supported by the Monitor tool are: 

Register type Description Integer Long Float Double 

K Parameter K KL KF KD 

M Monitoring M ML MF  

X User variable X XL XF XD 

C Common C CL CF CD 

L Look-up table L   LD 

T Trace T TL TF TD 

P Mapping P    

E Trigger  EL   

 

Finally, select the units used to display the register’s values from the right-most drop-down list. 

 

 
 

To add a new monitor to the tool, simply right-click on the tool’s window and select the Add new 
monitor option from the context menu. 
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For the inverse operation, first select which monitor(s) to remove by checking the correspondent 
checkbox control to the left of the axis drop-down list, then right-click on the tool’s window and select 

the option Remove selected monitor from the context menu. 

 

 
 

It is possible to hide the register description text to gain screen real estate for displaying more 

monitorings. Simply right-click on the tool’s window and deselect the option Memo text visible from 

the context menu. Select the option again to revert the action. 

 

 
 

NOTE 
The Monitor tool can display as many registers as wanted. But, there is a practical limit 
since the tool window size is constrained to ComET4’s desktop area and there is no 
vertical scrollbar. 
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The user can also adapt the font size used by the Monitor tool for visual convenience. Again, from 

the same context menu, select the option Modify font and choose the new font size. 

 

 
 

Finally, the last option available for configuring is the rate used to refresh the monitor(s) values in 

the Monitor window. To modify this setting, bring up the context menu once again by right-clicking 
on the tool’s window and select a refresh interval value between 250 milliseconds and 5 seconds 

from the list under the Update interval option. 

 

 
 

7.5. Logging 

The Logging tool allows the user to view and log to a file all events (information, warnings and errors) 
occurring on the Controller with which the connection is established. 

To launch the Logging tool, go to the Menu option Tools → Acquisition → Logging: 
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The log file is located in the folder C:\Users\xxx\comet4.log, where xxx refers to the Windows user 
name. A maximum file size can be configured, so that when this limit is reached, a new file is 
automatically created. The user can also choose to erase the log file each time ComET4 is launched. 

To modify the Logging tool settings go to File → Preferences → Logging tool (refer to Section §2.5.7): 

Preferences: Logging tool configuration options 

 

Controller information View and log information shared by the Controller. 

Controller warnings View and log Controller warnings (related to monitoring M66). 

Controller errors View and log Controller errors (related to monitoring M64). 

Internal information ComET4/EDI4 internal information: useful for troubleshooting. 

Internal warnings ComET4/EDI4 internal warnings: useful for troubleshooting. 

Internal errors ComET4/EDI4 internal errors: useful for troubleshooting. 

Internal helps ComET4/EDI4 internal debug info: useful for troubleshooting. 

Internal stacktraces ComET4/EDI4 internal stack trace: useful for troubleshooting. 
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7.6. ULTIMET ADVANCED logs 

The ULTIMET ADVANCED motion controller is capable of logging relevant information about its 
execution flow and internal state. These logs can be particularly useful for troubleshooting the 
behavior of the Controller. 

Refer to the ULTIMET ADVANCED Motion Controller User’s Manual for more information about the 
ULTIMET ADVANCED logs. 

 

 
 

To upload the ULTIMET ADVANCED log files select the Menu option Controller → Upload Logs. 

 

 

 

 

 
 

Next, select how many log files to upload using the Quantity drop-down list or check the Upload all 
Logs checkbox to upload all the log files stored in the Controller. 

 

NOTE Internal events are useful for troubleshooting purposes by ETEL’s Support team. 

TIP 
When reporting an issue with the ULTIMET ADVANCED motion controller, please 
provide these log files to ETEL’s Support team. 

NOTE 
Menu option Controller → Upload Logs is only enabled when a connection is established 

with an ULTIMET ADVANCED motion controller. 
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To initiate the uploading click on the Upload button and type in the name of the target file where the 

log files will be saved followed by the Save button. 

 

 
 

The uploaded log files are compressed to a single zip file for convenience. Therefore, the target file 
name must use the *.zip extension otherwise the following error is raised and the upload process 

is interrupted. 

 

 
 

NOTE 
Only the most recently created logs files will be uploaded, except if the option Upload all 
Logs is selected. 
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If the selected target file already exists, the following warning message is displayed. Click on the 

Yes button to proceed with the upload (overwriting the contents of the existing file) or the No button 

to cancel the action. 

 

 
 

Once the upload is completed, click on the Close button to close the dialog box. The log files can be 

now extracted from the target zip file. 
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8. Embedded programming 

8.1. Sequence 

When required by the application, the user can write a program to be executed by the Controller. 
This program is called a Sequence because it consists of a list of instructions that are executed 
sequentially by the Controller. 

A Sequence is written in a specific language developed by ETEL and can be saved as text file. It 
can contain several functions and each function can be executed separately or combined with others 
to build a more complex program. 

In order to be executed, the Sequence has to be compiled, downloaded and saved on the Controller. 
The most straightforward way of doing this it is to use ComET4. 

 

 

 

 
 

8.1.1. Writing a Sequence 

The user can use the Editor tool to write a Sequence. There are several ways to launch the Editor 
tool, such as: 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → Editor → Open. 

 

 

NOTE 
The Sequence Compiler is only supported under Windows 32-bit environment. 
Compilation of a Sequence is not possible on any other environment. 

NOTE 
Refer to the AccurET Modular Position Controller Operation & Software Manual and 
UltimET Light Motion Controller User’s Manual for a comprehensive explanation about 
programming Controllers using Sequences. 

NOTE 
The ULTIMET ADVANCED motion controller cannot execute Sequences. Instead, the 
user can program a Customer Software Module (CSM). Refer to Section §8.2 for further 
information about a CSM. 
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To modify a Sequence already stored in a Controller, the user can: 

• Open the Editor tool and directly upload the Sequence from the Controller to the Editor by 

selecting the Menu option Controller → Sequence → Upload to Editor or clicking the button 

 from the Toolbar Registers/Sequence group; or 

• Upload the Sequence into a file by selecting the Menu option Controller → Sequence → 
Upload to File. The file can then be opened for edition in the Editor tool. 

 

 
 

It is possible to manage the Sequence version used in each Controller. The configuration of the 

version number can be done using the Editor tool or any other third-party editor before downloading 
the Sequence to the Controller. The Sequence file header contains the version of the Sequence, 
see the e.g. below. 

# COMET special parameters 

# ISO linear units : m, m/s, m/s², V, A, s (used in case of interpolation) 

# ISO rotary units : t, t/s, t/s², V, A, s 

# User sequence version axis 0 : 1.00A 

 

 

// Initialization 

void init(void) 

{ 

    K61 = 1;    // Position reference mode 

TIP Compiled Sequence source files are usually saved using the extension *.cseq. 
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In order to set the version number, the user must either modify the current header (if present) or 

create a new one by selecting the Menu option Edit → Insert Version Header→ Insert Sequence 
Version Header. 

 

 
 

8.1.2. Executing a Sequence 

The Sequence must be first downloaded to the Controller before it can be executed. Refer to 
Sections §8.1.5 and §10.2.1 for further details on how to download a Sequence to a Controller. 

Once the Sequence has been downloaded to the Controller, the user can trigger its execution by 

sending the JMP command using the Terminal tool (refer to the AccurET Modular Position Controller 

Operation & Software Manual and UltimET Light Motion Controller User’s Manual for further details 

on how to start a Sequence). 

 

8.1.3. Debugging a Sequence 

The Editor tool allows the user to debug a Sequence running on the Controller with which the 

connection is established by means of the Debug Axis button. 
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The Sequence must have been downloaded prior to initiating the debug or else the following error 
message pops up. 

 

 
 

Also, it is not possible to connect to a Controller and debug the Sequence that is currently running 
on that Controller. If an attempt is made to debug an already running Sequence, the following error 
message is displayed. 

 

 
 

WARNING 

Please read carefully this User Manual prior to using the debugging functionality. Using 
the debugging tools is complex and requires expertise. 

Misusing the debugging tools on a machine might result in material damage. Debugging 
is done under the user’s responsibility. 

The debugging tools do not comply with any safety norm. Never touch a machine that is 
being debugged or stopped on a breakpoint. Not following this caution might result in 
severe injuries. 

NOTE 
The debug functionality is only supported for UltimET Light and AccurET controllers 
with firmware version 2.07A and above. 
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Once in debug mode, the Editor window displays additional controls: 

1. Mode Selection; 

2. Debug Console; 

3. Stopping Threads Selection; and 

4. Debug Status. 

 

 

 

The Mode Selection allows the user to switch between edition and debug modes: 

Mode Selection 

 Leave the debug mode and return to the edition mode. 

 

The Debug Console allows the user to control the execution of the Sequence in debug mode: 

Debug Console 

 
Label of the Sequence function from where to start the execution (same as the parameter of 
the JMP command). 

 

Thread of the corresponding Controller where the Sequence will be launched (maximum of 2 
threads for an AccurET position controller and 3 threads for an UltimET Light motion 
controller). 

 
Start debugging, stopping when Sequence reaches the next breakpoint (shortcut F5). 

1 2 3 4 
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Continue execution until next breakpoint is reached or the Sequence ends (shortcut F5). 

 
Execute to next instruction (shortcut F10). 

 
Stop debugging (shortcut Shift + F5). 

 

Before pressing on the Debug Axis button to start the debug mode, the user can check the Show 
Axis Thread Mask checkbox to get access to more advanced debugging capabilities available under 

the Stopping Threads Selection group control (if the Show Axis Thread Mask checkbox is not 

selected, the Stopping Threads Selection group control is not visible in debug mode). 

Stopping Threads Selection 

 

Control the behavior of Sequence threads with regards to specific debugging 
events. E.g. select which threads from which axis is going to stop when a 

breakpoint is reached or when the Stop execution button on the Debug Console 

group control is pressed. 

When a Sequence stops its execution on a breakpoint, it signals this event over 
TransnET. Every Controller connected to the same TransnET bus running a 
Sequence checks this signal every cycle. Depending on configuration set via the 

Stopping Threads Selection control, the Sequence threads of each Controller 

will react accordingly, i.e. stop or continue execution. 

This functionality allows the user to specify several threads that must not stop 
when there is a Sequence that has been interrupted. This could be the case e.g. 
of threads in charge of collision avoidance. By default, all threads of all axes react 
to a debug event (i.e. threads will stop if a breakpoint is reached or the debug 
mode stopped). 

At least one thread on the current debugging axis must be selected, otherwise 
the following error message is displayed: 
 

 

 
More direct access to select which threads of the axis being debug will stop when 
a debug event occurs. 

 

As the name indicates, the Debug Status provides information about the current status of the debug 

mode: 

Debug Status 

 Ready to start the execution of the Sequence in debug mode. 

 Sequence is being executed. 

 Sequence execution has stopped because it reached a breakpoint. 

 Sequence execution has reached the end (it is no longer being executed). 

 The user has pressed the Stop execution button. 
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These are the debugging functionalities available in ComET4: 

• Set/Remove breakpoints; 

• Execute a Sequence, which will run until the next breakpoint is reached or to the end; 

• Execute a Sequence step-by-step; 

• Jump into a function (step over is not supported); 

• Stop the debug mode; 

• Specify which threads on which axis will react to debug events, such as reaching a breakpoint 
or stopping the debug mode; 

• Quit the debug mode and switch to edition mode. 

 

These are the recommended steps to follow for debugging a Sequence: 

1. Configure for each connected Controller the behavior of the threads to debug events. Use the 

drop-down list in the Stopping Threads Selection group control. 

 

2. Specify the label of the Sequence function from where to start the execution and the thread of 
the corresponding Controller where the Sequence will be launched. 

  

3. Set a breakpoint by double-clicking on the mouse’s left button close to the left border of the 

Editor window, on the line where the breakpoint must be set. A red dot appears to indicate that 
a breakpoint was set. Repeat this operation to set additional breakpoints. 
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4. Click on the Start execution button  to initiate the debugging of the Sequence. This button 

changes icon to indicate that the debugging is in progress and the Debug Status group control 

status shows that a breakpoint has been reached. A small blue arrow on the left of the Editor 
window highlights the line where the execution has stopped. 

 

 

 

 

5. From here on, the user can follow one of the following options: 

NOTE 

As soon as a breakpoint is set on a Sequence, the Controller sets Bit #19 (Sequence 

debugger: breakpoints present) on monitoring M66 (warning code). 

Breakpoints are never saved and restored from flash along with the Sequence. But it can 
happen that the communication between the application (i.e. ComET4) and the 
Controller is lost before having the opportunity to clear existing breakpoints. 

It is the application’s responsibility to check monitoring M66 before starting Sequences 

to make sure none will stop unexpectedly on a breakpoint. If some breakpoints are still 
present, the Controller will display a warning: 

 

WARNING 

The execution of a Sequence will stop when reaching a breakpoint, but this will not stop 
an axis in motion due to a previous command. However, once this motion is completed, 
the axis will remain stopped because the Sequence is blocked at the breakpoint 
instruction. 

This fact must be taken into account in the case this Controller is connected via 
TransnET to other Controllers in charge of the motion of other axes. It is important to 
evaluate the risk of collision between axes under such circumstances. 
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a. Continue executing until next breakpoint by clicking on the Continue execution button 

; 

b. Start a step-by-step execution by clicking on the Execute next instruction button . To 

leave the step-by-step mode, click on the Continue execution button ; the execution 

will continue until the next breakpoint. 

 

6. To let the Sequence run freely, remove all breakpoints (by double-clicking on the red dots) and 

click on the Continue execution button. Without any breakpoint set, the Start/Continue 
execution and Execute next instruction buttons are greyed. The only option available is to Stop 
execution button . 

 

7. Once the user clicks on the Stop execution button , the following warning message is 

displayed to inform that this action will stop all threads running on the current axis being 
debugged, as well as those threads related to other connected axes that were configured to 
react to debug events. 

Click on the Yes button to proceed with the action of stopping the debug mode or on the Cancel 
button to abort the action. 
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It is not possible to debug simultaneously two or more axes. Take e.g. the case that a Sequence 
running on axis 0 of a Controller is being debugged. If the user connects to another axis (e.g. axis 
1) and attempts to run the debugger on that axis, an error message pops up to inform the user that 

the Editor tool is already running in debug mode on axis 0. Press the OK button to clear the error 

message. 

 

 

 

 

 

NOTE 

The debugging is carried on the axis indicated in the mainframe Toolbar Local 
connection drop-down list. The Stopping Threads Selection drop-down list in the Editor 
tool does not define the axis being debugged. 
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To return to edition mode click on the Switch to Editing mode button (only possible after having 

stopped the debugging by clicking on the Stop execution button ). If there are still breakpoints set, 

a warning message pops up to remind the user to remove all breakpoints before leaving the debug 
mode. 

 

 
 

When initiating the debug mode, if there are threads on any axis that are not set to react to debug 
events (e.g. thread 2 of axis 1 not set), a warning message is displayed to inform the user. 

 

 
 

 

8.1.4. Pre-compiling a Sequence 

In order to be executed, the Sequence has to be compiled, downloaded and saved on the Controller. 
Usually, these three steps are realized as a single action during the “standard” process of 
downloading a Sequence. 

However, it is possible to compile a Sequence, store the result of this compilation in a file and 
download this file at a later stage to the Controller. 

Using pre-compiled Sequences has basically two advantages: 

• The downloading process becomes faster because the compilation step is skipped, as the 
Sequence has already been compiled; of course, the “bigger” the Sequence, the more 
noticeable this gain is; and 

• IP protection: there is one pre-compilation option which ensures that the result of the 
compilation is strip-off of any Sequence source code, making it totally safe to exchange the 
pre-compiled file with other users (this option for IP protection is also available when 
downloading a Sequence using the “standard” process; refer to next Section §10.2.1 for 
further information). 

There two options available to pre-compile a Sequence: 

1. Select the Menu option Controller → Sequence → Pre-compile from File. 
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2. Select the Menu option Controller → Sequence → Pre-compile from Editor. 

 

 

 

The only difference between the two dialog boxes that pop up is that for the Pre-compile from Editor 
option there is no need to select the Sequence source file as it is taken directly from the Editor 
window detaining the scope. 

Click on the corresponding Browse button(s) to select respectively the compiled Sequence source 

file (only for the option Pre-compile from File) and the pre-compiled Sequence result file. 

 

 
 

TIP Pre-compiled Sequence files are usually saved with the extension *.eseq. 
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To ensure full IP protection in regard to the Sequence source code, select the checkbox Source 
code protection. This guarantees that the pre-compiled Sequence file includes no reference to the 

original source code from which it was generated. In other words, when such pre-compiled 
Sequence file is downloaded to the Controller, only the compiled code is downloaded, not the source 
code. As such, it is not possible to upload from the Controller the corresponding Sequence source 
code because it does not exist, providing full IP protection to the owner of the Sequence. 

There are three possible alternative processes to generate a pre-compiled Sequence: 

 The user must select the target axes for the compilation. It is an online compilation process, as it 
requires a valid connection to be established with all the axes referenced in the Sequence. 
 

 
 
This compilation process can be used with any Sequence, regardless of the type of units it is using 
(ISO or incremental). Since there is a connection established with the axes, the compiler can retrieve 
the correct metadata required to handle properly the ISO conversions. 

 This compilation process allows the user to realize an offline compilation of the Sequence. In other 
words, there is no need for a connection to be established with the axes referenced in the Sequence, 
but the user must supply a parameter set corresponding to their configuration. 
 

 
 
The parameter set must contain at least the following register types for all the axes referenced in the 
Sequence: 
K, KL, KF and KD; 

C, CL, CF and CD; 

M, MF, ML. 

As with the previous, this compilation process is suited for whatever Sequence, regardless of the 
type of units it is using (ISO or incremental). The compiler can retrieve from the parameter set the 
correct metadata required to handle properly the ISO conversions. 

 This compilation process also allows the user to realize an offline compilation as the previous Offline 
ISO sequence process, but there is no need to provide a parameter set. Instead, the user selects 

generic target Controllers with their default parameter set. Click on the Configure button to select the 

target devices. 
 

 
 

To add a new device, simply click on the Add Device button and select the axis number, Controller 

model and firmware version from the corresponding drop-down lists. To remove a device, first check 

the corresponding checkbox to the left of the device (or devices) and click on the Remove selected 
Device button. 

This compilation process cannot handle a Sequence using ISO units. The following error message 
will be displayed if this is the case. 
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The pre-compiler tool will generate an error if it does not have information about a specific axis 
referenced in the Sequence. 

 

 
 

Once everything is properly configured, the user just needs to click on one of the two buttons 

Configure for master (only available if an UltimET Light motion controller is part of the configuration) 

or Configure for drive (drive is another term to designate an AccurET position controller) to generate 

the pre-compiled Sequence. 

If the target file already exists, the following warning message is displayed. 

 

 
 

Click on Yes to proceed or No to abort the compilation and chose another target file. 

Upon a successful compilation, the following information message is displayed. Clicking on the OK 

button will close this message and pre-compiler dialog box as well. 

 

NOTE 

The user must provide information about all axes being referenced in the Sequence. 

This can be done via an online connection to these axes (for the Connected devices 

option), via a specific parameter set containing information about all these axes (for the 

Offline ISO sequence option) or, finally, via the selection of target devices matching these 

axes (for the Other option). 
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However, if the Sequence contains an error (e.g. a syntax error), the compiler will flag it with an error 
message. 

 

 
 

8.1.5. Download to controller 

Once a Sequence has been written, the user can follow one of the three possible options to 
download it to the Controller for execution: 

1. If the Sequence to be executed is currently being edited in the Editor tool, simply select the 

Menu option Controller → Sequence → Download from Editor or alternatively click the button 

 from the Toolbar Registers/Sequence group; 

2. If the Sequence has already been saved to a file, select the Menu option Controller → 
Sequence → Download from File and the select the Sequence source file *.cseq to 

download; 

3. If the Sequence has been pre-compiled, select the Menu option Controller → Sequence → 
Download Pre-compiled File and select the pre-compiled Sequence *.eseq to download. 

Refer to the previous Section §8.1.4 for further details on how to pre-compile a Sequence. 

 

Refer to Section §10.2.1 for further details on how to pursue with the download of a Sequence to a 
Controller. 

 

8.2. Customer Software Module 

A Customer Software Module (CSM) is a FreeRTOS application based on the ETEL Device Interface 
(EDI) library. 

Contrary to a Sequence that consists of a list of instructions written in a specific language developed 
by ETEL and executed sequentially by the Controller, a CSM is an embedded software application 
written in C based on EDI, with multithreading capabilities and running on a Real-Time Operating 
System (FreeRTOS). It, therefore, allows the user to develop much more advanced functionalities 
when compared to a Sequence. 
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The ULTIMET ADVANCED motion controller is the only Controller in ETEL’s product range that 
supports CSMs as an alternative to the traditional Sequences. This motion controller is based on a 
quad-core ARM processor, with one of these cores dedicated to the user’s CSM. 

 

 
 

For more information about a CSM, refer to the ULTIMET ADVANCED Motion Controller User’s 
Manual. 

 

8.2.1. Development environment 

Contrary to a Sequence that can be written and debugged using the Editor tool (refer to Sections 
§8.1.1 and §8.1.3 for information about writing and debugging Sequences), the development 
toolchain for a CSM is more complex and it is not integrated in ComET4. 

The Xilinx SDK environment is required for the development of a CSM. ETEL provides a CSM 
template containing basic functionality to support developers creating their first embedded 
application for the ULTIMET ADVANCED motion controller. The CSM is compiled and linked with 
the EDI library ported to the FreeRTOS operating system. This process generates two binary files: 

• csm.elf: used during the development phase since it can be launched, debugged and tested 
using the Xilinx SDK environment; 

• csm.bin: used in the final product environment, where the CSM is loaded and started from a 
host application (it can be ComET4 or a user application running on the host PC). 

The user can use ComET4 to download the csm.bin file to the ULTIMET ADVANCED motion 
controller. 

For more information about the environment required for the development of a CSM, refer to the 
ULTIMET ADVANCED Motion Controller User’s Manual. 

 

8.2.2. Download to controller 

To download a CSM to the ULTIMET ADVANCED, select the Menu option Controller → Download 
Customer Software Module. 

 

 

CORE 0 CORE 1 

UltimET Advanced 

firmware 

UltimET Advanced 

firmware 

CORE 2 CORE 3 

UltimET Advanced 

firmware 

Customer Software 

Module running on 

FreeRTOS 
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On the dialog box that appears the user can find information about the currently loaded CSM (if any) 

and by clicking on the Browse button a new CSM binary file can be selected for downloading to the 

Controller. 

 

 
 

It is important to note that the selected file must have the *.bin extension, otherwise the following 

error is raised. 

 

NOTE 
Menu option Controller → Download Customer Software Module is only enabled when 

a connection is established with an ULTIMET ADVANCED motion controller. 
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Then, click on the Download button to initiate the transfer of the CSM file to the Controller. 

 

 
 

A progress bar is displayed to inform the user of the progress of the downloading operation and an 
information message is displayed once the download is successfully completed. Just click on the 

OK button to close this message and then on the Close button on close the dialog box. 

 

NOTE 

A part from the file extension, the tool used to download the CSM does not perform any 
verification on the authenticity and integrity of the binary file. If the user mistakenly 
selects a binary file other than a CSM, no error will be raised during the downloading 
process. However, the ULTIMET ADVANCED motion controller will not be able to 
execute it. 
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Now, the CSM is ready to be executed. For further information on how to start a CSM refer to the 
ULTIMET ADVANCED Motion Controller User’s Manual. 
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9. I/Os Configuration & Control 

The table below summarizes the I/O configurations supported by ETEL Controllers and optional I/O 
board. 

Product 
Standard Digital Fast Digital Analog 

Input Output Input Output Input Output 

AccurET Modular 48 

4 per axis 
(+24V) 

2 per axis 
(+24V) 

6 
(+5V) 

4 
(+5V) 

  

AccurET Modular 300   

AccurET Modular 400-600 
5 per axis 

(+24V) 
2 per axis 

(+24V) 
4 diff. pairs 

(RS422) 
4 diff. pairs 

(RS422) 
  

AccurET Modular VHP 48 

4 per axis 
(+24V) 

2 per axis 
(+24V) 

6 (+5V) 
+ 

4 diff. pairs 
(RS422) 

4 (+5V) 
+ 

4 diff. pairs 
(RS422) 

4 diff. pairs 
(±10V) 

4 diff. pairs 
(±10V) 

AccurET Modular VHP 100 

UltimET Light PCI   

4 diff. pairs 
(RS422) 

4 diff. pairs 
(RS422) 

  

UltimET Light PCIe     

UltimET Light TCPIP   
2 diff. pairs 

(RS422) 
2 diff. pairs 

(RS422) 
  

ULTIMET ADVANCED   
8  diff. pairs (RS485) 

programmable direction 
  

AccurET optional I/O board 
8 

(+24V, +5V) 
8 

(+24V, +Vext) 
  

4 diff. pairs 
(±10V) 

4 diff. pairs 
(±10V) 

 

 
 

9.1. Configuration: AccurET 

The I/O Configuration tool allows the user to configure the behavior of the analog I/Os available on 
the AccurET Modular VHP 48/100 position controllers and on any other AccurET position controller 
equipped with an optional I/O board. 

  

NOTE 

The I/O arrangement of ACCURET+ position controllers running firmware 3.5x is the 
same as the AccurET Modular position controllers. 

ACCURET+ position controllers are not compatible with the AccurET optional I/O board. 

For more information, refer to the AccurET Modular Position Controller Operation & 
Software Manual. 
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To launch the I/O Configuration tool select the Menu option Tools → I/O → Configuration: 

 

 
 

When ComET4 is connected to any AccurET position controller equipped with analog I/Os, the view 

of the I/O Configuration tool is composed of two panels, one reserved for the configuration of the 
analog outputs and another for the analog inputs (the screenshots below refer to an AccurET 
position controller equipped with an optional I/O board). 

 

  

 

9.1.1. Analog outputs 

The user starts by selecting which analog output to configure. 

 

 
 

Next, the user must select between one of the two modes of operation available: 

• Direct reference mode; or 

• Indirect reference mode. 
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The selection of mode of operation is done via the blue switch button. 

 

 

 

Analog output operation modes 

 

In the Direct Reference mode (default mode), the reference of the analog output is given 

directly by the value of parameter CF107 (AOUT) for an AccurET Modular VHP 48/100 

position controller or parameter C7 (XOUT) for an AccurET equipped with an optional I/O 

board. 

This value is displayed in the Direct Reference field and it can be adjusted using the I/O Control 

tool, under the analog panel (refer to Section §9.3.2 for further details). 

 

In the Indirect Reference mode, the reference of the analog output can be given by any X, K, 

C or M registers named as Source Register. 
 

 
 
This source register corresponds to the value of parameters C130 (source register type), C131 

(source register index) and C132 (source register axis) for an AccurET Modular VHP 48/100 

position controller or the equivalent C30, C31 and C32 parameters for an AccurET equipped 

with an optional I/O board. 

 

The user can adjust the output signal amplitude suited for his application by clicking on the yellow 

button signal adaptation. 

When hovering with the mouse pointer over the offset or gain fields, a tooltip is displayed with a 

description of the parameter corresponding to each field (respectively parameters CF127 and 

CF128 for an AccurET Modular VHP 48/100 position controller and parameters CF27 and CF28 

for an AccurET equipped with an optional I/O board). 

The values of the offset and gain fields are automatically computed after pressing the Apply button, 

taking into account the range set by the user for the analog output signal before and after the signal 
adaptation. This action also sets the corresponding offset and gain registers on the Controller. 

Click on the Get button to retrieve the offset and gain registers set on the Controller and update the 

corresponding offset and gain fields. To return to the analog output main configuration panel, click 

on the Up button . 
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Finally, the user must save the configuration to the Controller. For this, select the Menu option 

Controller → Save Configuration to Controller or click on the Save configuration to controller 
toolbar button . On the Save on Controller dialog box that pops-up, select the Controller to save, 

select the radio button control corresponding to the SAV = 2 command for saving all the Registers 

and then click on the Save button. 

Alternatively, this command can also be typed in the Terminal tool. Refer to Section §10.3 for more 
information about saving a Controller’s configuration. 

 

NOTE 
The I/O Configuration tool does not perform any verification of the values entered by the 
user. If the signal range defined by the user is beyond the capabilities of the electronics, 
the output signal will saturate at the supported min/max values. 
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9.1.2. Analog inputs 

The user must first select the analog input to configure from the selection drop-down list. 

 

 
 

Next, by clicking on the signal adaptation yellow button the user can adjust the input signal 

amplitude suited for his application. 

 

 
 

When hovering with the mouse pointer over the offset or gain fields, a tooltip is displayed with a 

description of the parameter corresponding to each field (respectively parameters CF117 and 

CF118 for an AccurET Modular VHP 48/100 position controller and parameters C17 and CF18 for 

an AccurET equipped with an optional I/O board). 
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The values of the offset and gain fields are automatically computed after pressing the Apply button, 

taking into account the range set by the user for the analog input signal before and after the signal 
adaptation. This action also sets the corresponding offset and gain registers on the Controller. 

Click on the Get button to retrieve the offset and gain registers set on the Controller and update the 

corresponding offset and gain fields. To return to the analog input main configuration panel, click on 

the Up button . 

Finally, the user must save the configuration to the Controller. For this, select the Menu option 

Controller → Save Configuration to Controller or click on the Save configuration to controller 
toolbar button . On the Save on Controller dialog box that pops-up, select the Controller to save, 

select the radio button control corresponding to the SAV = 2 command for saving all the Registers 

and then click on the Save button. 

Alternatively, this command can also be typed in the Terminal tool. Refer to Section §10.3 for more 
information about saving a Controller’s configuration. 

 

 
 

9.2. Configuration: UltimET 

The I/O Configuration tool allows the user to configure the behavior of the UltimET Light motion 
controller local I/Os, as well as to configure the interface of this Controller to external I/O modules 
from the company WAGO. 

To launch the I/O Configuration tool select the Menu option Tools → I/O → Configuration: 

 

 
 

When ComET4 is connected to an UltimET Light motion controller, the view of the I/O Configuration 

tool is composed of two panels, External and Local, reserved for the configuration of the external I/O 

modules and local I/Os, respectively. 

 

NOTE 
Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about management of the analog inputs and outputs. 
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9.2.1. Local I/Os 

In the Local panel view the user can configure the functionality of the UltimET Light’s native digital 

I/Os. 

 

 

 

Digital I/Os operation modes 

 

Configure the UltimET Light to raise an error depending on the state 
(programmable “high” or “low”) of the digital inputs DIN1 and/or DIN2. 

This can be used for protection purposes, where a protection related third-
party device can control the UltimET Light’s execution. In addition, the 
error propagation mechanism can be set in such a way to also impact the 
operation of any AccurET connected to the same TransnET 
communication bus. 

 

Configure the UltimET Light to drive the state (programmable “high” or 
“low”) of the digital outputs DOUT1 and/or DOUT2 whenever it falls into 

error. 

This can be used to inform protection related third-party devices that the 
UltimET Light is in error. 

 

Configure the UltimET Light to generate up to two synchronization signals 
in phase with the TransnET cycle. The user can configure the frequency of 
such signals (not independently). 
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Click on the Apply to UltimET button to apply the configuration to the UltimET Light motion 

controller. To revert to the initial configuration click on the button Restore Initial (if the new 

configuration was not yet saved to the Controller). 

Finally, the user must save the configuration to the Controller. For this, select the Menu option 

Controller → Save Configuration to Controller or click on the Save configuration to controller 
toolbar button . On the Save on Controller dialog box that pops-up, select the Master Controller, 

select the radio button control corresponding to the SAV = 2 command for saving all the Registers 

and then click on the Save button. 

 

9.2.2. External I/O modules 

The External panel reserved for configuring the external I/O modules is further sub-divided in 4 sub-

panels: 

• Communication; 

• Modules; 

• Digital; 

• Analog. 

 

9.2.2.1. Communication sub-panel 

These are the settings that must be configured by the user under the Communication sub-panel: 

General 

 Enable the external I/Os feature (switch on all the features related to 
external I/Os). It corresponds to setting *K727 (*EIOEN) to “1”. 

The new value is taken into account only after the next switch on of the 
Controller. The activation state may be checked through the monitoring 
*M698 (*IOENBLD). 

 

TCP/IP Addresses 

 Set the UltimET Light client IP address. It corresponds to setting *K721 

(*IPCLADR). 

This address must be in the same network range as the WAGO module IP 
address (e.g. UltimET Light client IP address is 192.168.10.140, WAGO 
module IP address is 192.168.1.10 and sub-net mask is 255.255.0.0). 

 Set the WAGO IP address as defined in the module. It corresponds to 
setting *K722 (*IOIPADR). 

 Set the external I/Os sub-net mask. It corresponds to setting *K725 

(*IOSUBNET). 

 If necessary for the application, set the IP address of the default gateway. 
It corresponds to setting *K726 (*IOGATEWY). It is not useful for point-

to-point connection. 

 

Modbus Configuration 
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 Set the external I/Os refresh rate expressed in milliseconds. It corresponds 
to setting *K729 (*IOREFRESH). This parameter is set to 10 milliseconds 

by default. 

 Set the external I/Os number of repetition of UDP messages before raising 
an error. It corresponds to setting *K734 (*IONBREP). 

 

 
 

If the user modifies the checkbox Enable external IO feature the following message is displayed to 

inform that the change will only be taken into account once the UltimET Light motion controller is 
rebooted. 

 

 
 

If the user does not respect the notation for the IP addresses, the following error is raised. 
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For the remaining edit controls, if the user inputs an invalid character and hits the return key, the 
new value will not be accepted and the edit control will revert to the last valid value. 

 

9.2.2.2. Modules sub-panel 

This sub-panel contains information about the detected configuration: 

• Reference of the WAGO coupler; 

• Number of modules detected; 

• Number of DINs, DOUTs, AINs and AOUTs available through these modules. 

 

The column concerning the module description in the modules listing (Mod. Desc.) is obtained from 

ETEL’s or user’s description files based on the module’s reference. 
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Right-click on the modules list to open a context menu enabling the following actions: 

• Insert or Append a module to the hardware configuration; 

• Delete a module from the hardware configuration; 

• Edit the modules list. 

 

 
 

Selecting either the menu option Insert Module or Append Module opens the following dialog box 

from which the user can insert/append a new module by typing in a new reference in the Reference 

drop-down list edit field and completing the missing information or, alternatively, insert/append an 

already existing module by selecting it from the Reference drop-down list. 

 

 
 

Selecting the menu option Delete Module deletes a module from the hardware configuration. 

 

 
  

NOTE 
The Delete Module option does not remove the module from the description file. It only 

removes this particular module from the hardware configuration list. 
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Selecting the menu option Edit Module List opens the following dialog box: 

 

 
 

With this dialog box, the user can add and remove modules from the known user modules list which 
is created from the user’s description file without actually impacting the existing hardware 

configuration. The user cannot add or remove an ETEL native module. In the Reference drop-down 

list, ETEL native modules are prefixed with the label “Etel:”, while the user modules are prefixed with 
the label “User:” (automatically inserted whenever a user inserts a new module). 

Click on the Save button to save the changes to the user modules description file. With the Restore 

button, the user can revert to the list of modules existing at the moment the I/O Configuration tool 
was launched. 

Clicking on the Save Modules Definitions button also writes the new definitions to the user modules 

description file. With the Restore Initial button, the user can revert the list to its initial condition when 

the I/O Configuration tool was launched. 

 

 

 

9.2.2.3. Digital sub-panel 

This sub-panel is purely informative listing the digital I/Os: 

Column Nr. Column Header Description 

1 Mod. Idx Module’s index in the hardware configuration list. 

2 Mod. Ref Module’s reference. 

3 IO in Mod. I/O index in the list of I/Os belonging to the same module. 

4 IO Idx I/O index in the list of all digital I/Os available in the hardware configuration list. 

 

NOTE 

Clicking on the Restore Initial button also reverts the analog I/Os gain and offset settings 

to their initial values. Refer to the Analog sub-panel Section further below for additional 

information on this topic. 
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9.2.2.4. Analog sub-panel 

In this sub-panel the user can set the gain and offset of the analog I/Os. If these have never been 
set before, the tool displays the default values based on the modules’ characteristics. The user can 
modify these settings according to his application. 
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To modify the gain and offset of one of the analog I/Os, select the corresponding I/O from the listing, 
right-click and select the only option available from the context menu. 

 

 
 

Then, adjust the software raw and physical ranges and the gain and offset settings are automatically 

computed. Press on the OK button to accept the settings. 
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Finally, click on the Apply to UltimET button to take these settings into account. 

 

 
 

Clicking on the Restore Initial button to revert the analog I/Os gain and offset settings to their initial 

values. However, this action will also revert the modules list configured in the Modules sub-panel to 

their initial state. 

If the user only wants to revert the analog I/Os gains and offsets to their initial state, the workaround 

is to save the modules’ list by clicking on the Save Modules Definitions button, close the I/O 

Configuration tool by clicking on the top right most button  and press on the Yes button on the 

warning message that pops-up. 

 

 
 

Then, re-open the I/O Configuration tool and return to the Analog sub-panel on the External panel. 

The gains and offsets have the same values as before the changes made by the user. 

Finally, after having configured all the I/O settings, the user must save the configuration to the 

Controller and reboot it. For the first step, select the Menu option Controller → Save Configuration 
to Controller or click on the Save configuration to controller toolbar button . On the Save on 
Controller dialog box that pops-up, select the Master Controller, select the radio button control 

corresponding to the SAV = 2 command for saving all the Registers and then click on the Save 

button. 

To reboot, simply power cycle the UltimET Light motion controller. For the PCI/PCIe version this 
means powering off and on the computer hosting the Controller. For the TCP/IP version this means 
powering off and on the AccurET hosting the UltimET Light. 

 

NOTE 
When clicking on the Apply to UltimET button the values are taken immediately into 

account, but not saved to the UltimET Light motion controller. In order words, the values 
will be lost once the Controller is powered off. 
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9.3. Control 

The I/O Control tool allows the user to view the value of the input signals and control the value of 
the output signals available on a Controller, an AccurET optional I/O board (if available) or any 
external I/O modules interfacing an UltimET Light motion controller (if available). 

There are several ways to launch the I/O Control tool, such as: 

1. On the Toolbar Tools group, click on the button . 

 

2. Select the Menu option Tools → I/O → Control. 

 

 

The I/O Control tool window contains 3 panels: 

1. Digital; 
2. Analog; 

3. Setting. 

 

 
 

NOTE 

To properly reboot an UltimET Light PCI/PCIe motion controller it is not sufficient to 
restart the computer hosting the Controller. The user must shut down the computer to 

ensure that the motherboard does not continue powering the UltimET Light PCI/PCIe 
card. 

1 2 3 
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9.3.1. Digital panel 

The digital panel allows the user to: 

• Monitor the digital inputs of the selected Controller and optional I/O board, if present; 

• Set the state of the digital outputs of the selected Controller and optional I/O board, if present. 

 

The view below corresponds to the digital panel when connected to an AccurET position controller 
with an optional I/O board. The collection of digital input signals DIN/FDIN and digital output signals 

DOUT/FDOUT are native to the Controller, while the collection of digital signals XDIN/XDOUT belong 

to the optional I/O board. 

 

 
 

When the letter r (for reserved) is displayed next to a digital output, it means it is being used to drive 

a specific signal (e.g. 1Vpp sin, cos, index, …). When hovering with the mouse pointer over the 
corresponding output a tooltip is displayed with a description of the signal being driven. 
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The radio button controls reflect the status of the individual I/Os of a collection: 

• A radio button set means that the corresponding input or output state is driven “high”; 

• A radio button unset means that the corresponding input or output state is driven “low”. 

The edit control below the radio buttons contains the hexadecimal representation of the respective 
I/O collection, with each individual I/O belonging to this collection corresponding to a bit (“high” state 
is equivalent to bit = “1” and “low” state is equivalent to bit = “0”). E.g., the value of 0x08 for the 
FDOUT collection means that the state of the output FDOUT4 “high” (bit = “1”). 

The view below corresponds to the digital panel when connected to an UltimET Light PCI/PCIe 
motion controller with an external I/O module (WAGO coupler). 
 

 
 

The External Inputs and External Outputs group frames contain as many ’sub-’ group frames as 

digital I/O modules connected. The title of each “sub-” group frame contains the module’s reference, 

NOTE 

Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about the signals that can be driven by the DOUT and FDOUT digital 

outputs. 
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followed by its index (within brackets) relative to the full hardware configuration, starting counting 
from the WAGO coupler and including any analog modules. 

Each digital I/O is also numbered with its position within the configuration, also starting counting 
from the WAGO coupler (but only accounting for the digital I/Os). 

While the Enable I/O Update Cycle checkbox is not selected, the display shows the actual state of 

the I/Os and no changes can be made. An output signal whose value is attempted to be modified 
will revert to its current state. 

As soon as the checkbox is selected (which is equivalent to sending the command *EIOSTA = 1 

to the UltimET Light), changes are taken into account and the I/O Control tool displays the value 
set for the output. Of course, the value of input signals can never be modified, regardless if the 

checkbox is selected or not. The I/O Control tool always displays their current state. 

The values of a given module can be modified by either toggling individually the outputs using the 
radio button controls or by introducing the hexadecimal value in the corresponding edit control. 

 

 
 

9.3.2. Analog panel 

The analog panel allows the user to: 

• Monitor the analog inputs of the selected Controller and optional I/O board, if present; 

• Set the level of the analog outputs of the selected Controller and optional I/O board, if present. 

 

The view below corresponds to the analog panel when connected to an AccurET position controller 
with an optional I/O board. In this particular example, the collection of analog signals XAIN/XAOUT 

belong to the optional I/O board, as the AccurET Modular 48 being used does not include any 
analog I/Os. 

 

NOTE 
Refer to Section §9.1.2 for details on how to configure an UltimET Light motion 
controller to use external I/O modules. 
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The level of the analog outputs can be adjusted using the slider controls or inputting directly the 
value expressed in Volts (V) in the corresponding edit control. Values are saturated to the minimum 
and maximum limits (±10V). 

The view below corresponds to the analog panel when connected to an UltimET Light motion 
controller with an external I/O module (WAGO coupler). 
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The External Inputs and External Outputs group frames contain as many ’sub-’ group frames as 

analog I/O modules connected. The title of each “sub-” group frame is the same as in the digital 
panel (i.e. module’s reference, followed by its index in the current configuration), except it also 
includes a prefix corresponding to the index of the I/O within its type in the current configuration. 

Again, while the Enable I/O Update Cycle checkbox is not selected, the display shows the actual 

level of the I/Os and no changes can be made. An output signal whose value was attempted to be 
modified will revert to its current level. 

As soon as the checkbox is selected (which is equivalent to sending the command *EIOSTA = 1 

to the UltimET Light), changes are taken into account and the I/O Control tool displays the value 
set for the output. Of course, the value of input signals can never be modified, regardless if the 

checkbox is selected or not. The I/O Control tool always displays their current level. 

The level of the analog outputs can be controlled using the slider controls or inputting directly the 
value expressed in Volts (V) in the corresponding edit control. Values are saturated to the minimum 
or maximum limits resulting from the modules’ number of bits and range, and the gains and offsets 
set by the user. 

In the example below, a few analog outputs are directly connected to the analog inputs just above 
them and one can directly observe the impact of adjusting the level of the output signals on the 
corresponding input signals. 
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9.3.3. Setting panel 

The setting tab allows the user to activate or deactivate the specific functions dedicated to the I/Os. 
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Redirects the user to the Setting tool wizard panel #3 (Motor environment), sub-panel Home & 
Limit switches. Refer to Section §4.1.3 for further details. 

If home and/or limits switches are required by the application, the user can define which analog 
inputs are used for reading their condition. 

 

Redirects the user to the Setting tool wizard panel #9 (Protections), sub-panel Misc. protections. 

Refer to Section §4.1.9 for further details. 

The user can define if a Controller can only deliver power to a motor if a certain state of a digital 
input is observed. A typical use case is to have a sensor detecting the condition of a door giving 
access to safety critical parts of a machine and if door is opened, the Controller powers off the 
motors to reduce the risk of injuring the user. 

 

Redirects the user to the Setting tool wizard panel #3 (Motor environment), sub-panel 

Temperature sensor. Refer to Section §4.1.3 for further details. 

The user can configure the connection of a thermal sensor to one of the digital inputs for detecting 
e.g. motor overheating. 

 

Redirects the user to the Setting tool wizard panel #9 (Protections), sub-panel Misc. protections. 

Refer to Section §4.1.9 for further details. 

The user can define to use digital outputs to indicate error status of the Controller. 

 

 

 

 

NOTE 
All options available in the Setting panel are disabled when connected to an UltimET 

Light motion controller. 
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10. Controller configuration 

10.1. Registers 

Registers store all the Controller’s internal values. Each register has an identification number 
preceded by one or two letters corresponding to its type/sub-type. There are ten main types of 
Registers, four basic (often used) and six advanced (reserved for specific applications). 

The basic Registers’ types are: 

• K, for parameters; 

• M, for monitorings; 

• X, for user variables; and 

• C, for common (only available on the AccurET position controllers). 

Belonging to the group of advanced Registers’ type are: 

• E, for triggers (only available on the AccurET position controllers); 

• L, for look-up tables; 

• T, for traces; 

• P, for mapping (only available on the AccurET position controllers); 

• Y, are advanced user registers (only available on the UltimET Light/ADVANCED motion 

controllers); and 

• W and R, equivalent to K and M registers, but dedicated to a given ETEL Software Module 

(only available on the ULTIMET ADVANCED motion controller). 

For more information about Registers, refer to the AccurET Modular Position Controller Operation & 
Software Manual and UltimET Light/ADVANCED Motion Controller User’s Manuals. 

It is possible to manage the Registers versions used in each Controller. The configuration of the 

version number can be done using the Editor tool or any other third-party editor before downloading 
the Registers to the Controller. The Registers file header contains the version of each register type 
present in the file, see e.g. below. 

 

# COMET special parameters 

# ISO linear units : m, m/s, m/s², V, A, s 

# ISO rotary units : t, t/s, t/s², V, A, s 

# ComET version: 4.22A 

# ETEL Parameters Upload 

# Written by "edi-tra" v4.18A 

# Date: Tue Jun 30 12:11:12 2020 

# User K,KL,KF,KD register version axis 0 : 1.01A 

# User C,CL,CF,CD register version axis 0 : 1.01A 

# User X,XL,XF,XD register version axis 0 : 2.00B 

# User LD lookup table version axis 0 : 3.00A 

 

In order to set the version number, the user must either modify the current header (if present) or 

create a new one by selecting the Menu option Edit → Insert Version Header. 
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10.1.1. Download to controller 

To download Registers to the Controller, the user can select one of the two options available: 

1. Select the Menu option Controller → Registers → Download from File. 

Use this option when the Registers are stored in a file. 

 

2. Select the Menu option Controller → Registers → Download from Editor or click on the button 

 of the Toolbar Registers/Sequence group. Use this option if the Registers to download are 

currently being edited in the Editor tool. 
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Going for option 1 (Download from File), the user must select the Registers file to download and 

click on the Open button. 

 

 
 

Next, the following dialog box is displayed. 
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The user must select the axis or axes onto which download the Registers and configure the 
downloading options: 

Download options 

 The user can select which register types (and sub-types) to 
download in two different ways (by default, all register types 
included in the file are selected): 
- by entering directly in the edit control the register type (using 

commas to separate between types); or 
- by clicking on the button  and selecting the register types 

from the list available in the dialog box that appears. 
 

 
 
This dialog box is only displayed if an axis has been previously 
selected, otherwise the following error is raised. 
 

NOTE 
The procedure to follow from this point forward is the same regardless if the download 

is done from a file or from the Editor tool. 



 ComET4 – Commissioning Software 
272 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 

 Select this option to erase from the Controller all Registers of the 
selected register types before downloading the new Registers. Be 
aware that this is an irreversible action. 

 Select this option to save to the Controller’s flash memory the 
Registers just downloaded. Be aware that only the Registers of the 
selected register types will be saved. 

 Select this option to perform a hardware reset of the Controller(s) 
after downloading. Be aware that all unsaved Registers and 
Sequences will be lost (in case of AccurET position controllers, the 
hardware reset impacts both axes). 

 

Finally, clicking on the Download button starts the transfer of the Registers to the Controller(s), with 

a progress bar giving an indication of the status. 

 

 
 

Of course, the user can always interrupt the downloading procedure by clicking on the progress 
dialog box close button on the top right corner. 

 

 
 

Once the download completed, the tool can be closed clicking on the Close button. 

 

NOTE 

Be aware that interrupting the process of downloading the Registers to a Controller might 
leave it in an inconsistent condition, with a configuration which is a mix between “old” 
and “new” Registers. 
In such case, it is highly recommended to perform subsequently a full successful 
download of the Registers to ensure full consistency of the configuration. 
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10.1.2. Upload from controller 

To upload Registers from the Controller, the user can select one of the two options available: 

1. Select the Menu option Controller → Registers → Upload to File. 

Use this option to save the Registers directly to a file. 

 

2. Select the Menu option Controller → Registers → Upload to Editor or click on the button  of 

the Toolbar Registers/Sequence group. Use this option to upload the Registers directly to the 

Editor tool for edition. 

 

 

Going for option 1 (Upload to File), the user must select the target file to use for saving the Registers 

and click on the Save button. If the target file already exists, the user will be asked to confirm the use 

of the file or abort the action. 
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Going for option 2 (Upload to Editor), if the Editor tool is currently loaded with an unsaved file, the 

user will be given the option to save it before performing the upload of the Registers to the Editor 
tool. 

Next, the following dialog box is displayed. 

 

TIP Registers (parameters) files are usually saved using the extension *.par. 
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The user must select the axis or axes from which to upload the Registers and configure the uploading 
options: 

Upload options 

 The user can select which register types (and sub-
types) to upload in two different ways: 
- by entering directly in the edit control the register 

type (using commas to separate between types); 
or 

- by clicking on the button  and selecting the 
register types from the list available in the dialog 
box that appears. 

 

 

NOTE 
The procedure to follow from this point forward is the same regardless if the upload is 

done to a file or to the Editor tool. 
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 Force the upload of all Registers of whatever type. 

 Do not upload Monitoring (M) registers. 

 Do not store the axis number together with the 
registers (e.g. K0.0 = 0 is stored as K0 = 0). The 

resulting file is more generic and can be downloaded 
to other similar Controllers which happen to have 
different axis identifier. 

 Convert the uploaded registers to ISO values (as 
opposed to the native Incremental values). 

 Sort registers by category. 

 

Upload all indexes or select a range of indexes. 

 

Upload all depths or only valid depths or only depths 
1, 2, 4 or 8. 

 

Finally, clicking on the Upload button starts the transfer of the Registers from the Controller (s), with 

a progress bar giving an indication of the status. 

 

 
 

Of course, the user can always interrupt the uploading procedure by clicking on the progress dialog 
box close button on the top right corner. 

Once the upload completed, the tool can be closed clicking on the Close button. 

 

10.2. Sequence 

A Sequence is a program to be executed by a Controller. It consists of a list of instructions written 
in a specific language developed by ETEL that are executed sequentially by the Controller. In order 
to be executed, the Sequence has to be compiled and then downloaded to the Controller. For more 
information about Sequences, refer to Section §8.1. 

 

10.2.1. Download to controller 

To download a Sequence to the Controller, the user can select one of the three options available: 

1. Select the Menu option Controller → Sequence → Download from File. 

Use this option if the Sequence has already been saved to a file. 



 ComET4 – Commissioning Software 
 User’s Manual 277 

ETEL Doc. / Version N / 31/03/23 

 

2. Select the Menu option Controller → Sequence → Download from Editor or click on the button 

 of the Toolbar Registers/Sequence group. Use this option if the Sequence to download is 

currently being edited in the Editor tool. 

 

3. Select the Menu option Controller → Sequence → Download Pre-compiled File. 

This option is only valid for a Sequence that has been pre-compiled. Refer to Section §8.1.4 
for further details on how to pre-compile a Sequence. 

 

 

Going for option 1 (Download from a File), the user must select the Sequence file to download and 

click on the Open button. 
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Next, the following dialog box is displayed. 

 

 

 

 
 

The user must select the axis or axes onto which download the Sequence and configure the 
downloading options: 

NOTE 

The procedure to follow from this point on is the same regardless of the option chosen. 

A minor detail concerning option 3 (Download Pre-compiled File), the previous dialog 

box has an additional control on the top part for the user to select the pre-compiled 
Sequence to download. 



 ComET4 – Commissioning Software 
 User’s Manual 279 

ETEL Doc. / Version N / 31/03/23 

Download options 

 

Download Sequence without saving it to the flash memory. If the 
Controller is powered off, the Sequence is lost and must be 
downloaded again to be executed. 

 
After downloading, the Sequence is saved to the flash memory and 
remains on the Controller even after being powered off. 

 

After downloading, the Sequence is saved to the flash memory and 
remains on the Controller even after being powered off. 
Furthermore, no source code is downloaded and saved on the 
Controller (IP protection). 

 

 
 

Finally, clicking on the Download button starts the Sequence compilation (except if the user has 

selected the option to download a pre-compiled Sequence), followed by the transfer to the Controller 

and finally saving into flash memory (except if Do not save sequence in Flash Mem. download option 

was selected). A progress bar gives an indication of the status and an information message is 
displayed once the download is successfully completed. 

 

 
 

Returning to the main dialog box, the user can find information about the usage of the Controller’s 
RAM (volatile) memory in terms of: 

• Percentage of memory being used by the compiled code; 

• Percentage of memory being used for the source code (displays Not downloaded if the option 

Download ONLY Compiled code was selected); 

• Percentage of memory being used for data. 

 

NOTE 

A Sequence can be saved at any time by clicking on the Toolbar Macros  button (saves 

only the current axis) or the Save configuration to controller  button (can save multiple 

axes). 
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It is possible to download a Sequence to more than one axis of an AccurET position controller if the 
ISO conversions are the same. Otherwise, an error is raised. 

 

 
 

However, it is not possible to download a Sequence simultaneously to an AccurET position 
controller axis and to an UltimET Light motion controller. The following error will be raised. 

 

 
 

10.2.2. Upload from controller 

To upload a Sequence from the Controller, the user can select one of the two options available: 

1. Select the Menu option Controller → Sequence → Upload to File. 

Use this option to save the Sequence directly to a file. 
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2. Select the Menu option Controller → Sequence → Upload to Editor or click on the button  of 

the Toolbar Registers/Sequence group. Use this option to upload the Sequence directly to the 

Editor tool for edition. 

 

 

Going for option 1 (Upload to File), the user must select the target file used for saving the Sequence 

and click on the Save button. If the target file already exists, the user will be asked to confirm 

overwriting of the file or abort the action. 
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Going for option 2 (Upload to Editor), if the Editor tool is currently loaded with an unsaved file, the 

user will be given the option to save it before performing the upload of the Sequence to the Editor 
tool. 

Next, the following dialog box displayed: 

 

 

 

 
 

The user must select the axis from which to upload the Sequence (only one axis can be selected at 

a time) and press the Upload button to start transferring the Sequence from the Controller. The 

progress bar gives an indication of the status of the upload. 

Of course, the user can always interrupt the uploading procedure by clicking on the progress dialog 
box close button on the top right corner. 

Once the upload completed, the dialog box closes automatically without further action required from 
the user. 

 

10.3. Save Configuration to Controller 

To save the Controller’s configuration, follow one of two options: 

1. Select the Menu option Controller → Save Configuration to Controller, or 

TIP Compiled Sequence source files are usually saved using the extension *.cseq. 

NOTE The procedure to follow from this point on is the same regardless of the option chosen. 
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2. Click on the Toolbar Save configuration to controller button . 

 

 
 

The user must select the axis or axes to save and configure which information to be saved on the 
Controller(s) flash memory: 

Information type to save 

 Save all information. This is equivalent to the SAV = 0 command. 

 

Save Sequences and Look-up Table (L) registers. This is equivalent 

to a SAV = 1 command. 

NOTE: Sequences are not supported by ULTIMET ADVANCED 
controllers. 

 

Save Parameter (K), User Variable (X), Common (C) and Trigger (E) 

registers. This is equivalent to a SAV = 2 command. 

NOTE: C and E parameters are not supported by UltimET Light and 

ULTIMET ADVANCED controllers. These controllers also save the 
Advanced User (Y) registers. ULTIMET ADVANCED controllers with 

an ESM module also save the ESM (W) registers. 

 
Save Parameter (K) registers. This is equivalent to a SAV = 3 

command. 
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NOTE: AccurET controllers also save the Trigger (E) registers. 

 

Save Common (C) registers. This is equivalent to a SAV = 4 

command. 
NOTE: Not applicable to UltimET Light and ULTIMET ADVANCED 
controllers. 

 

Save User Variable (X) registers. This is equivalent to a SAV = 5 

command. 
NOTE: UltimET Light and ULTIMET ADVANCED controllers also 
save the Advanced User (Y) registers. 

 
Save Look-up Table (L) registers. This is equivalent to a SAV = 6 

command. 

 
Save Sequences. This is equivalent to a SAV = 7 command. 

NOTE: Not applicable to ULTIMET ADVANCED controllers. 

 

Save Parameter (K) and Trigger (E) registers. This is equivalent to a 

SAV = 8 command. 

NOTE: Only applicable to AccurET controllers. 

 

Save Mapping (P) registers. This is equivalent to a SAV = 9 

command. 
NOTE: Only applicable to AccurET controllers. 

 

Save ESM (W) registers (ULTIMET ADVANCED only). This is 

equivalent to a SAV = 10 command. 

NOTE: Only applicable to ULTIMET ADVANCED controllers with an 
ESM module. 

 

Click on the Save button to save the configuration of the Controller to its non-volatile (flash) memory 

according to the options selected. 

The user can choose to reset the Controller after saving. 

 

 
 

If only one Controller axis is selected the following warning message informs the user that any 
unsaved settings of the non-selected axis will be lost if the Controller is reset after saving. 

 

 
 

A progress bar gives an indication of the status and an information message is displayed once the 
saving is completed successfully. 
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10.4. Download Firmware 

To update the Controller’s firmware select the Menu option Controller → Download Firmware: 

 

 
 

ComET4’s Download Firmware wizard tool guides the user through the process of downloading a 
new firmware to one or multiple Controllers. 

 

10.4.1. Panel #1: EULA 

On the first panel the user is presented with the End-User License Agreement (EULA) terms. 
 



 ComET4 – Commissioning Software 
286 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 
 

To proceed to the next panel, click on the Next button after having accepted the terms of the license 

agreement. 

 

10.4.2. Panel #2: Recommendations 

This panel contains very important recommendations that the user should follow to ensure a 
successful upgrade of the Controller(s): 

• It is strongly recommended to power cycle the Controller (switch off and back on) before 
downloading a Firmware; 

• Stop all running Sequences or CSM before downloading a Firmware. 

• Do not interrupt the communication with the Controller while downloading a Firmware. 

• Do not remove the Controller’s control input power supply while downloading a Firmware. 
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To proceed to the next panel, click on the Next button. 

 

10.4.3. Panel #3: Firmware file 

This third panel allows the user to select the new firmware file or use the one already selected. 

 

 
 

Use the Browse button to select another firmware file. 
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Once the firmware file has been selected, to proceed to the next panel, click on the Next button.  

 

10.4.4. Panel #4: Download options 

The user must verify and confirm the firmware version to download to the Controller(s) and configure 
the downloading options. 

 

 

NOTE 

A firmware file always bears a *.far file extension. But, the Download Firmware tool 

can also be used to download a Controller backup *.bar file (refer to Section §10.5 for 

further information). 
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These are the available options to configure: 

Download options 

 
Select this option to erase the flash memory block reserved for the Sequences. This ensures 
that no Sequences remain on the Controller(s) after the firmware update. 

 Select this option to erase the memory block reserved for the parameters (Registers). This 
ensures that a after the firmware update the Controller(s) has (have) default values for all 
Registers. 

 This option is reserved for advanced users. If selected, when clicking on the Next button 

there is an additional panel that is added to the normal flow. This panel depicted below 
allows the user to select which blocks of the firmware to download. 
 

 

 

To proceed to the next panel, click on the Next button. 

 

10.4.5. Panel #5: Connection 

In this panel, the user decides the type of connection to use, either the Controller is directly 
connected to the computer running ComET4 or can be reached via the Local network. 
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Connection options 

 If selected, when clicking on the Next button there is an additional panel that is added to 

the normal flow. This panel depicted below allows the user to select the connection port. 
 

 

 If selected, the user must enter the hostname or select one from the list (if any). 
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To proceed to the next panel, click on the Next button. 

 

10.4.6. Panel #6: Targets 

In this last panel the user specifies the target Controller(s) that will be updated with the new firmware. 

 

 

 

Target options 

 Download the firmware to all Controllers (typically when 
connected to an UltimET Light/ADVANCED motion controller, all 
the axes connected to the TransnET bus can be updated with a 
new firmware). 

 

Specify to which axes download the firmware. 

 To be used to recover a Controller after a previous problem with 
the download of a firmware (not applicable to the ULTIMET 
ADVANCED motion controller for which there is another way for 
recovering from a firmware download issue). 
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Finally, clicking on the Download button starts downloading the firmware to the Controller(s), with 

the following sequence of actions taking place: 

1. Closing connection; 
2. Re-opening connection in bridge boot mode (specific connection mode required to update 

the firmware); 
3. Analyzing new firmware to validate the compatibility with the target Controller(s) and compare 

it with the current firmware running on the Controller(s); if the new and current firmware are 
the same, the download is not executed; 

4. Downloading of the new firmware blocks to the Controller(s); 
5. Closing of connection. 

A progress bar gives an indication of the status of each these actions. 

 

 
 

An information message is displayed once the download is successfully completed. 

 

 

NOTE 
For further details about downloading a firmware to a Controller and how to recover it in 
case of a problem, refer to the AccurET Modular Position Controller Operation & 
Software Manual and UltimET Light/ADVANCED User’s Manual. 
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If the firmware to download is the same as the one already running on the Controller(s), the download 
is not executed and the following information message is presented. 

 

 
 

If the firmware to download is not compatible with the target Controller(s), the download is aborted 
and the following error is raised. 

 

 
 

10.5. Controller backup 

To back up the configuration of a Controller select the Menu option Controller → Controller Backup: 

 

 
 

ComET4’s Controller Backup wizard guides the user through the process of backing up the 
configuration of a Controller. 

 

NOTE 

A Controller must be rebooted after a firmware update. While in the case of AccurET 
position controllers, the rebooting is realized as part of the firmware downloading process 
(except if USB is the selected connection type), to properly reboot an UltimET Light 
PCI/PCIe motion controller it is mandatory to shut down the computer to ensure that the 
motherboard does not continue powering the Controller. 
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10.5.1. Panel #1: Recommendations 

The wizard’s first panel is purely informative. It contains an important recommendation that the user 
should observe before realizing the configuration backup: power cycle the Controller off and on to 
ensure that it is in a well-known configuration. 

 

 

 

 
 

To proceed to the next panel, click on the Next button. 

 

10.5.2. Panel #2: Connection 

In this panel, the user decides the type of connection to be used, either the Controller is directly 
connected to the computer running ComET4 or can be reached via the Local network. 

 

NOTE 

To properly reboot an UltimET Light PCI/PCIe motion controller it is not sufficient to 
restart the computer hosting the Controller. The user must shut down the computer to 
ensure that the motherboard does not continue powering the UltimET Light PCI/PCIe 
card. 
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Connection options 

 If selected, when clicking on the Next button there is an additional panel that is added to the 

normal flow. This panel depicted below allows the user to select the connection port. 
 

 

 If selected, the user must enter the hostname or select one from the list (if any). 
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To proceed to the next panel, click on the Next button. 

 

10.5.3. Panel #3: Upload source 

The third panel allows the user to select the Controller to backup. The options are either backing up 
a controller (i.e. AccurET position controller), in which case the axis number must be specified, or 
a Master (i.e. UltimET Light/ADVANCED motion controller). 

 

  

 

The user must check the The controller is in “wait for program” state checkbox (or equivalently 

The Master is in “wait for program” state checkbox) to recover a controller (or Master) after a 

previous problem with a firmware download (this option is not applicable for an ULTIMET 
ADVANCED motion controller). 
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To proceed to the next panel, click on the Next button. 

 

10.5.4. Panel #4: Backup options 

In this panel the user can select what will be backed up from the controller. The screenshot on the 
left depicts the backup options available for the AccurET and UltimET Light controllers, while the 
screenshot on the right depicts the backup options available for the ULTIMET ADVANCED 
controller. 

 

  

 

Backup options 

 Backup the Controller’s firmware and metadata. For the case of an ULTIMET ADVANCED 
motion controller, the backup will also include the contents of the flash memory, the VxWorks 
real-time operating system image and the registers/configuration of existent ETEL Software 
Modules (ESM). 

 Backup the Controller’s K, X, C, E, Y and W register types. 

 
Backup of C and E register types only applies to AccurET position controllers. 

Backup of Y register type only applies to UltimET Light/ADVANCED motion controllers. 

Backup of W register type only applies to ULTIMET ADVANCED motion controllers. 

 Backup the Controller’s Sequence programs only applies to AccurET and UltimET Light 
controllers. 

 Backup the Controller’s Customer Software Module (CSM) only applies to ULTIMET 
ADVANCED motion controllers. 

 Backup the Controller’s L register type. 

 Backup the Controller’s P register type only applies to AccurET position controllers. 

 Backup the Firmware license file only applies to ULTIMET ADVANCED motion controllers. 
 
NOTE: a Firmware license file is unique and linked to a specific ULTIMET ADVANCED 
motion controller through its serial number (refer to the ULTIMET ADVANCED User’s Manual 

NOTE 
For further details about downloading a firmware to a Controller and how to recover it in 
case of a problem, refer to the AccurET Modular Position Controller Operation & 
Software Manual and UltimET Light/ADVANCED User’s Manual. 
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for further information). Uncheck this option if this backup is intended to be downloaded to 
another controller with a different serial number. 

 Backup the IP addresses only applies to ULTIMET ADVANCED motion controllers. 

 Backup memory blocks reserved for future use. It might be useful to backup such blocks as 
in more recent firmware versions these blocks could be used for some other purpose. 

 Backup memory blocks not currently used. It might be useful to backup such blocks as in 
more recent firmware versions these blocks could be used for some other purpose. 

 This option is reserved for advanced users. If selected, when clicking on the Next button there 

is an additional panel that is added to the normal flow. This panel depicted below allows the 
user to select which blocks to backup. 
 

 

 

10.5.5. Panel #5: Backup file 

This panel allows the user to select the backup file. 

 

 
 

Use the Browse button to select the file where the backup will be stored. 



 ComET4 – Commissioning Software 
 User’s Manual 299 

ETEL Doc. / Version N / 31/03/23 

 

 

 

 
 

In case the file already exists, the user is informed with the following a warning message. Click on 

the Yes button to accept overwriting the existing file with the backup that is going to be uploaded. 

 

 
 

Once the backup file has been selected, to start the backup procedure click on the Next button. 

A progress bar gives an indication of the status of the backup. 

 

 
 

And an information message is displayed once the backup is successfully completed. 

 

NOTE A backup file should bear the *.bar file extension. 
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10.6. System Configuration Manager 

The System Configuration Manager tool allows the user to manage the entire configuration of a 

motion system. To launch this tool select the Menu option Controller → System Configuration 
Manager. 

 

 
 

With this tool the user can: 

 
Make an image of the configuration of all the Controllers connected to a selected bus (or buses) 
into a backup *.zip file. 

 
Extract from the backup *.zip file the system configuration image and download it to a 

compatible set of Controllers. 

 
Verify if the set of Controllers connected to the selected bus (or buses) is hardware compatible 
with a given system configuration image. 

 
Verify if the software configuration (firmware, registers, Sequences…) of set of Controllers 
connected to the selected bus (or buses) corresponds to a given system configuration image. 

 

The System Configuration Manager tool is well suited for managing a system’s software configuration 
in a series production environment. 

 

10.6.1. Backup 

To back up a system configuration, the user must select the Backup System Configuration checkbox 

in the first panel of the System Configuration Manager wizard. 

NOTE 
To restore a backup to a Controller use the Download Firmware tool. Refer to Section 
§10.4 for further details. 
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To proceed to the next panel, click on the Next button. The tool starts searching for the available 

connection buses and displays the ones found on the second panel. 
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The user can select and operate on several buses at the same time. To scan for all available buses 

just click on the Scan all buses button. 
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The list on the left displays all the available buses and the list on the right displays the selected 
buses. To add a bus to the selected bus list, the user must first select the bus in the available bus 
list and then click on the arrow pointing to the right placed in between both lists. 

To remove an item from the selected buses, the user needs to select the bus to be removed in the 
selected bus list and then click on the arrow pointing to the left placed in between both lists. 

 

  

 

To change the order of the selected buses in the list, the user can use the arrows pointing up or 
down on the right of the panel. 
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Finally, the user can also enter an IP address manually: 

 
Add a bus to the list of selected buses. 

 
Remove a bus from the list of selected buses. 

 

Move up a bus in the list of selected buses (the configuration backup starts from the bus on 
the top most of the list). 

 
Move down a bus in the list of selected buses. 

 
Find a bus by introducing directly its IP address. 

 

To proceed to the next panel, click on the Next button. 

On the next panel, the user must select the file where to store the system configuration backup by 

clicking on the Browse button. 

 

 
 

In case the file already exists, the user is informed with the following warning message. Click on the 

Yes button to accept overwriting the existing file with the new backup. 
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The user can also define which information to backup: 

 Backup the firmware and metadata of the Controllers connected to a selected bus (or 
buses). When backing up an ULTIMET ADVANCED motion controller, it also backs up the 
flash memory, the image of the VxWorks real-time operating system and the internal 
parameters of any existent ETEL Software Module (ESM). This option is always selected. 

 Backup the K, C, E and W register types of the Controllers connected to a selected bus (or 

buses). Backup the IP addresses. This option is always selected. 
 
Backup of C and E register types only applies for AccurET position controllers. 

Backup of W register type only applies for ULTIMET ADVANCED motion controllers. 

Backup of IP addresses only applies for ULTIMET ADVANCED motion controllers. 

 Backup the X and Y register types of the Controllers connected to a selected bus (or buses). 

Backup of Y register type only applies for UltimET Light/ADVANCED motion controllers. 

 Backup the Sequence programs or Customer Software Module (CSM) of the Controllers 
connected to a selected bus (or buses). 
 
Backup of Sequences does not apply for ULTIMET ADVANCED motion controllers. 
Backup of CSM only applies for ULTIMET ADVANCED motion controllers. 

 Backup the L register type of the Controllers connected to a selected bus (or buses). 

 Backup the P register type of the Controllers connected to a selected bus (or buses). 

Backup of P register type only applies for AccurET position controllers. 

 

 

 
 

Once the backup file has been selected and the backup options configured, to start the system 

configuration backup procedure click on the Next button. 

A progress bar gives an indication of the status of the backup. 

 

NOTE 

The backup options that are displayed may vary with the type of Controllers present on 
the connection bus (AccurET only, UltimET Light or ULTIMET ADVANCED). 

The example above corresponds to the case where an ULTIMET ADVANCED motion 
controller is present on the selected bus (or buses). 

NOTE 

When cloning the configuration from one system to another, the user must be aware that 
some data may need to be reconfigured on the new system after the download. Typical 
examples are linked to the Look-up and Mapping register types (e.g. scale mapping, 
stage mapping and cogging correction tables are valid on a given system only; they are 
machine dependent). 
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And an information message is displayed once the backup is successfully completed. 

 

 
 

Click on the Show details button to view details of the system configuration backup. 
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10.6.2. Download 

To download a system configuration to a motion system, the user must select the Download System 
Configuration checkbox in the first panel of the System Configuration Manager wizard. 

 

 

 

 
 

To proceed to the next panel, click on the Next button. 

On the second panel the user is presented with the End-User License Agreement (EULA) terms. 
 

NOTE All unsaved Registers or Sequences will be lost during this operation. 



 ComET4 – Commissioning Software 
308 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 
 

To proceed to the next panel, click on the Next button after having accepted the terms of the license 

agreement. 

On the next panel, the user must select the system configuration backup file by clicking on the 

Browse button. 
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To proceed to the next panel, click on the Next button. The tool starts searching for the available 

connection buses and displays the ones found on the next panel. To scan for all available buses just 

click on the Scan all buses button. 
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This panel is divided in three areas: 

• In the top part appears a list of the contents of the system configuration backup file; 

• On the left part appears a list of all available buses; 

• On the right part appears the list of selected buses. 

The user must select from the list of available buses the bus (or buses) on to which download the 
system configuration file. 

To add a bus to the selected bus list, the user must first select the bus in the available bus list and 
then click on the arrow pointing to the right placed in between both lists (it is also possible to remove 
an item from the selected buses by selecting the bus to be removed in the selected bus list and then 
clicking on the arrow pointing to the left placed in between both lists). 
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To change the order of the selected buses in the list, the user can use the arrows pointing up or 
down on the right of the panel. 

Finally, the user can also enter an IP address manually: 

 
Add a bus to the list of selected buses. 

 
Remove a bus from the list of selected buses. 

 

Move up a bus in the list of selected buses (the configuration backup starts from the bus on 
the top most of the list). 

 
Move down a bus in the list of selected buses. 

 
Find a bus by introducing directly its IP address. 

 

 
 

Once the bus (or buses) has been selected matching the contents of the system configuration 

backup file, click on the Next button to start the downloading procedure. 

The download procedure is executed with the following sequence of events: 

NOTE 

The selected buses must be in the same order as listed in the system configuration file 

otherwise the System Configuration Manager tool will not be able to download the 
configuration. 
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• First, a verification is performed to the hardware compatibility between the system 
configuration backup file and the selected bus (or buses); if the selected bus (or buses) does 
not match to what is backed up in the system configuration file, an error is raised (refer to 
Section §10.6.3 for further information on how the hardware compatibility check is done); 

• Second, the tool verifies if the software configuration (i.e. Firmware, Registers, Sequences…) 
running on the Controllers already matches with what is included in the system configuration 
file, in which case the download is needless (refer to Section §10.6.4 for further information 
on how the software configuration check is done); 

• Finally, if the hardware matches and the software is not up to date, the real download is 
initiated. 

A progress bar gives an indication of the status of the download. 

 

 
 

And an information message is displayed once the download is successfully completed. 

 

 

 

 
 

Click on the Show details button to view details of the system configuration download. 

NOTE 

A Controller must be rebooted after a firmware update. While in the case of AccurET 
position controllers, the rebooting is realized as part of the firmware downloading 
process, to properly reboot an UltimET Light PCI/PCIe motion controller it is mandatory 
to shut down the computer to ensure that the motherboard does not continue powering 
the Controller. 
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In this particular example it is possible to see that the software configuration verification has detected 
that the firmware version was up to date, so the corresponding download was skipped. 

Now, assuming the case where the user selects a bus (or buses) not matching the contents of the 
system configuration backup file. 

 

 
 

During the hardware compatibility check, it will be detected that the select bus (or buses) does not 
match the hardware description included in the system configuration backup file and an error is 
raised. 
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In this particular example, no Master device (corresponding to axis 63) is present in the selected bus 

connection. Click of the Show details button for additional information about the issue. 

 

10.6.3. Check hardware 

The hardware compatibility check will compare, for each Controller present on the selected bus (or 
buses), the Controller’s part number (stored in monitoring M85) and axis number (stored in 

monitoring M87). 

To perform this verification, the user must select the Check Hardware compatibility checkbox in the 

first panel of the System Configuration Manager wizard. 
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To proceed to the next panel, click on the Next button. 

On the second panel, the user must select the system configuration backup file by clicking on the 

Browse button. 

 

 
 

To proceed to the next panel, click on the Next button. The tool starts searching for the available 

connection buses and displays the ones found on the next panel. To scan for all available buses just 

click on the Scan all buses button. 
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This panel is divided in three areas: 

• In the top part appears a list of the contents of the system configuration backup file; 

• On the left part appears a list of all available buses; 

• On the right part appears the list of selected buses. 

The user must select from the list of available buses the bus (or buses) to which perform a hardware 
compatibility check. 

To add a bus to the selected bus list, the user must first select the bus in the available bus list and 
then click on the arrow pointing to the right placed in between both lists (it is also possible to remove 
an item from the selected buses by selecting the bus to be removed in the selected bus list and then 
clicking on the arrow pointing to the left placed in between both lists). 
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To change the order of the selected buses in the list, the user can use the arrows pointing up or 
down on the right of the panel. 

Finally, the user can also enter an IP address manually: 

 
Add a bus to the list of selected buses. 

 
Remove a bus from the list of selected buses. 

 

Move up a bus in the list of selected buses (the configuration backup starts from the bus on 
the top most of the list). 

 
Move down a bus in the list of selected buses. 

 
Find a bus by introducing directly its IP address. 

 

 
 

Once the bus (or buses) has been selected, click on the Next button to start the hardware 

compatibility check. 

 

NOTE 
The selected buses must be in the same order as listed in the system configuration file 
otherwise the hardware compatibility check will fail. 
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A progress bar gives an indication of the status of the check. 

 

 
 

And an information message is displayed once the hardware compatibility is verified. 

 

 
 

Click on the Show details button to view details of the hardware compatibility check. 

 

 
 

In this particular example the hardware is compatible. 

Now, assuming the case where the user selects another bus (or buses) which is not compatible. 
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During the hardware compatibility check, it will be detected that the select bus (or buses) does not 
match the hardware description included in the system configuration backup file and an error is 
raised. 

 

 
 

In this particular example, no Master device (corresponding to axis 63) is present in selected bus 

connection. Click of the Show details button for additional information about the issue. 
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10.6.4. Check software 

The software check consists of comparing the version of Registers and Sequences using the flash 
memory blocks checksums. These checksums are computed from the data present in the flash 
memory blocks and the value of monitoring M282 which can be set by the version header of the 

downloaded Registers or Sequence file (refer to Sections §10.1 and §10.2 for further information on 
how to add version headers to Registers and Sequence files, respectively). If the flash memory 
blocks checksums match the checksums on the system configuration image backup, it means that 
the Controller’s software is up to date and, therefore, a software download is not required. 

 

 
 

The software check is automatically preceded by a hardware compatibility check (refer to the 
previous Section §10.6.3 for information about the hardware compatibility check). 

To perform this software verification, the user must select the Check Software up-to-date checkbox 

in the first panel of the System Configuration Manager wizard. 

 

NOTE 
It is the user’s responsibility to create the version headers for the Registers and 
Sequence files and update these according to his own traceability rules. 
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To proceed to the next panel, click on the Next button. 
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On the second panel, the user must select the system configuration backup file by clicking on the 

Browse button. 

 

 
 

To proceed to the next panel, click on the Next button. 
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The tool starts searching for the available connection buses and displays the ones found on the next 

panel. To scan for all available buses just click on the Scan all buses button. 

 

 
 

This panel is divided in three areas: 

• In the top part appears a list of the contents of the system configuration backup file; 

• On the left part appears a list of all available buses; 

• On the right part appears the list of selected buses. 

The user must select from the list of available buses the bus (or buses) to which perform a software 
check. 

To add a bus to the selected bus list, the user must first select the bus in the available bus list and 
then click on the arrow pointing to the right placed in between both lists (it is also possible to remove 
an item from the selected buses by selecting the bus to be removed in the selected bus list and then 
clicking on the arrow pointing to the left placed in between both lists). 
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To change the order of the selected buses in the list, the user can use the arrows pointing up or 
down on the right of the panel. 

Finally, the user can also enter an IP address manually: 

 
Add a bus to the list of selected buses. 

 
Remove a bus from the list of selected buses. 

 

Move up a bus in the list of selected buses (the configuration backup starts from the bus on 
the top most of the list). 

 
Move down a bus in the list of selected buses. 

 
Find a bus by introducing directly its IP address. 

 

 
 

Once the bus (or buses) has been selected, click on the Next button to start the software check. 

 

A progress bar gives an indication of the status of the software check. 

NOTE 
The selected buses must be in the same order as listed in the system configuration file 
otherwise the software check will fail. 
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And an information message is displayed once the software check is completed. 

 

 
 

Click on the Show details button to view details of the software check. 
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In this particular example the software is up to date. 

Now, assuming the case where the user selects another bus (or buses) which is not compatible. 

 

 
 

During the hardware compatibility check, it will be detected that the select bus (or buses) do not 
match the hardware description included in the system configuration backup file and an error is 
raised. 
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In this particular example, no Master device (corresponding to axis 63) is present in selected bus 

connection. Click of the Show details button for additional information about the issue. 
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11. Utilities 

ComET4 disposes of a few useful utilities that are presented in this Chapter. 

 

11.1. Registers Editor 

The Registers Editor tool allows the user to view and edit the Registers of a Controller. To launch 
this tool, follow one of two possible options: 

1. On the Toolbar Tools group, click on the button , or 

 

2. Select the Menu option Tools → Registers Editor. 

 

 

The Registers Editor tool main window is divided in 2 areas: 

1. TreeView control; 

2. Registers listing; 

 

 
 

1 

2 
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In the TreeView control, the Registers are grouped according to the following classification: 

 K register type and sub-types. 

C register type and sub-types (only available on the AccurET position controllers). 

 M register type and sub-types. 

 X register type and sub-types. 

 T register type and sub-types. 

 L register type and sub-types. 

 E register type (EL sub-type, only available on the AccurET position controllers). 

 

 
 

In addition, to further assist the user finding the right Register to view/edit, the Parameters and 

Monitoring Registers have been further classified according to categories that are representative 

of their function. 

When the connection is established with an AccurET position controller, these are the categories 

used to classify the Parameters and Monitoring: 

Category Parameters Monitoring 

 ✓ ✓ 

 ✓ ✓ 

 ✓  

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

NOTE 
These register types are not available in the Registers Editor tool: P, Y, W and R. 

Refer to Section §10.1 for further information about Registers. 
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  ✓ 

  ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓  

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

  ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

 ✓ ✓ 

  ✓ 

 

When the connection is established with an UltimET Light/ADVANCED motion controller, these are 

the categories used to classify the Parameters and Monitoring: 

Category 
UltimET Light ULTIMET ADVANCED 

Parameters Monitoring Parameters Monitoring 

 ✓ ✓ ✓ ✓ 

 ✓ ✓ ✓ ✓ 

    ✓ 

  ✓  ✓ 

 ✓ ✓ ✓ ✓ 

 ✓ ✓   

 ✓ ✓ ✓ ✓ 

 ✓ ✓  ✓ 

 ✓ ✓ ✓ ✓ 

 ✓ ✓ ✓  

  ✓  ✓ 

   ✓ ✓ 

 ✓  ✓ ✓ 

  ✓  ✓ 

 ✓ ✓ ✓ ✓ 
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 ✓ ✓ ✓ ✓ 

  ✓   

 

The user can modify a Register by simply changing its value in the Value column in the Register 

listing area and hitting the Enter key. 

The example below depicts how to modify the optional board digital outputs (register XDOUT) value 

to 0x8. The resulting effect can be visualized with the I/O Control tool. 

 

 
 

If a modification has been made, the user must save the configuration to the Controller otherwise it 

will be lost at the next reboot. For this, select the Menu Controller → Save Configuration to 
Controller or click on the Save configuration to controller toolbar button . On the Save on 
Controller dialog box that pops-up, select which axis to save, select the radio button control that 

best fits to configuration to be saved and finally click on the Save button. 

Alternatively, the corresponding command can also be typed in the Terminal tool. Refer to Section 
§10.3 for more information about saving a Controller’s configuration. 
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11.2. Terminal 

The Terminal tool allows the user to send commands to a Controller and to inquire or modify the 
values of Registers. To launch this tool, follow one of two possible options: 

1. On the Toolbar Tools group, click on the button , or 

 

2. Select the Menu option Tools → Terminal. 

 

 

 
 

The Terminal tool is a command line alike utility. To send a command, the user must type it in the 

Terminal window respecting the following syntax: 

 

<cmd_name>.<axis>[=<P1>][,<P2>] 

<cmd_name> Command name 

<axis> Axis number 

<P1> Parameter #1 

<P2> Parameter #2 

 

Press ’Enter’ to send the command to the Controller. 
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The icon displayed on the left margin of the command line provide feedback to the user: 

Icon Example Meaning 

  Command line default prompt. User can type in a command. 

 ,  Command to execute an action/modify a Register executed by the Controller. 

  

Command to execute an action/modify a Register not executed by the Controller (e.g. 
certain commands, like the power on, cannot be executed when the Controller is in 
error). 

  
Command to read a Register executed by the Controller. The Register value is 
returned and displayed in the command line. 

  
Reply from the Controller to a command not received (usually because the connection 
with the Controller is broken). 

  Reply from the Controller to a command still pending. 

 

11.3. Unit Converter 

The Unit Converter tool is a simple utility for converting values of the kinematic quantities position, 
speed, acceleration and jerk from the Controller’s internal units (designated increments) to ISO units 
and vice versa. 

 

 
 

To launch this tool, go to the Menu option Tools → Unit Converter: 

 

 

NOTE 

The fields in between ’square brackets’ are optional and certain commands might require 
more than 2 parameters. 

Refer to the AccurET Modular Position Controller Operation & Software Manual and 
UltimET Light/ADVANCED Motion Controllers User’s Manuals for more information 
about the commands and their syntaxes. 

NOTE 
Refer to the AccurET Modular Position Controller Operation & Software Manual for 
further information about units conversion. 
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Start by selecting the axis from the left-most drop-down list. 

 

 
 

Then, choose the kinematic quantity from the second drop-down list 

 

 
 

and select the ISO units from the right-most drop-down list. 

 

 
 

Finally, input the value in increments and get the equivalent conversion in ISO units 

 

 
 

or vice-versa 

 

 
 

To add a new conversion, simply right-click on the tool’s window and select the Add a new converter 
option from the context menu. 
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For the inverse operation, first select which physical quantities(s) to remove by checking the 
correspondent checkbox control to the left of the axis drop-down list, then right-click and select the 

option Remove selected converters from the context menu. 

 

 
 

With the button controls, the user can: 

 
Specify the direction of the conversion from increments to ISO units. 

 
Specify the direction of the conversion from ISO units to increments. 

 
Get from the Controller the value of the Registers: 
M6 or ML6 (theoretical position in user scale) and apply to the kinematic quantity position (if selected); 

KL211 (absolute maximum speed) and apply to the kinematic quantity speed (if selected); 

KL212 (absolute maximum acceleration) and apply the kinematic quantity acceleration (if selected). 

 
Set the Controller’s Registers: 
KL210 (target position) with the value of the kinematic quantity position (if selected); 

KL211 (absolute maximum speed) with the value of the kinematic quantity speed (if selected); 

KL212 (absolute maximum acceleration) with the value of the kinematic acceleration (if selected). 

 

11.4. System Reporting 

The System Reporting tool generates an HTML report file with a description of the electronics setup 
of a given motion system. 

 

 
  

NOTE 
The Unit Converter tool can display as many units as wanted. But, there is a practical 
limit since the tool window size is constrained to ComET4’s desktop area and there is 
no vertical scrollbar. 

TIP 
Consider generating a System Reporting file whenever contacting ETEL’s Support team 
for support on troubleshooting an issue with an application. 
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To launch this tool, go to the Menu option Tools → System Reporting: 

 

 
 

The user can choose to include in the report a listing of the Controllers’ M (Monitoring) and K (Parameters) 

Registers by checking the option Includes controller’s registers in the report. 

 

 
 

An excerpt of a generated HTML report file is presented below. It is composed of the following 4 
sections: 

• General information: includes the date/time the report was generated and information about 
the project and customer; 

• Connection information: includes information about the type of connection used; 

• Hardware information: includes information about the electronics setup; 

• Parameters information: includes the listing of the Controllers’ M and K Registers. This section 

only appears if the user has selected the option to include these Registers in the report. 

 

General information 
Date/Time 2020-xx-xx 08h00 

Project Application X 

Customer Customer Y 

Comment Configuration of Application X 

 
Connection information 
Software ComET 4.22A 

URL USB 

Bus master USB 

 
Hardware information 
Node number 0 1 
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Node name Axis 0 Axis 1 

Article number EA-P2M-048-05/10A-0100-01 EA-P2M-048-05/10A-0100-01 

Serial number 40930067 40930067 

Firmware version 3.18A 3.18A 

Boot version 2.01A 2.01A 

Optional board ACCURET OPTIONAL IO BOARD ACCURET OPTIONAL IO BOARD 

Serial number - - 

Firmware version - - 

Boot version - - 

Controller reference mode standard standard 

Active Software Limits yes no 

Active Limit switches no no 

Active trigger no no 

Programmed sequence yes no 

Error state no error no error 

Warning state no warning no warning 

Motor powered no no 

Homing done no no 

Move in progress no no 

Device is waiting no no 

Device active sequence thread 0x0 0x0 

 
Parameters information 
# COMET special parameters 

# ISO linear units : m, m/s, m/s², V, A, s 

# ISO rotary units : t, t/s, t/s², V, A, s 

# ETEL Parameters Upload 

# Written by "edi-tra" v4.19 

# Date: Tue Jul  7 14:11:36 2020 

# User K,KL,KF,KD register version axis 0 : 1.00A 

# User C,CL,CF,CD register version axis 0 : 1.00A 

 

# Axis 0: 

#  - dev.product.category=EA-P2M-048-05/10 

#  - dev.soft.version=3.18A 

#  - ext.product.category=AccurET Optional IO Board 

#  - ext.soft.version=1.00A 

 

# Type K (#2)    ; Parameter integer 32 bits 

 

K0.0=0 

K1.0=0 

K2.0=0 

 

... 

 

# Axis 1: 

#  - dev.product.category=EA-P2M-048-05/10 

#  - dev.soft.version=3.18A 

#  - ext.product.category=AccurET Optional IO Board 

#  - ext.soft.version=1.00A 

 

# Type K (#2)    ; Parameter integer 32 bits 

 

K0.1=0 

K1.1=0 

K2.1=0 

 

... 



 ComET4 – Commissioning Software 
338 User’s Manual 

ETEL Doc. / Version N / 31/03/23 

 

 

 

11.5. Processor Load 

The Process Load tool allows the user to: 

• Estimate the load of a Controller’s processor for a given configuration; 

• Measure the real load of a Controller’s processor for a given configuration. 

 

 
 

To launch this tool, go to the Menu option Tools → Processor Load: 

 

 
 

The tool is divided in two panels: 

3. Load Estimation; and 
4. Load Measurement. 

 

NOTE 
The HTML report file is automatically presented in an Internet Explorer window after 
generation. 

NOTE The ACCURET+ position controllers are not supported. 
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11.5.1. Load estimation 

The estimation of the load of a Controller’s processor can be very helpful when designing a new 

application. The load estimation provided by the Processor Load tool gives an indication to the user 
about the Controller’s ability to handle in a “timely” manner all the features enabled for the given 
hardware and firmware. This part of the tool can be used off-line. 

The Load estimation panel is further sub-divided in two other panels: 

1. Hardware & Firmware; and 
2. Software Features. 

 

  

 

11.5.1.1. Hardware & Firmware sub-panel 

On the Hardware & Firmware panel, the user must select the Controller model and firmware version 

from the Device type and Firmware drop-down lists, respectively. 

1 
2 

1 
2 
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Then, define for both Controller axis which hardware features are being used: 

Hardware features 

 Type of position feedback used for the main, secondary and auxiliary encoders. The options are: 
- Disabled; 
- 1 Vpp; 
- TTL and TTL with smoothed filter (only available for the main encoder); 
- EnDat 2.1 and 2.2; 
- Any register of type int32, float and int64. 

 

 

 Type of motor being controlled. The options are: 
- 1-phase; 
- 2-phases; 
- 3-phases. 

 Is there an option I/O board installed? The options are: 
None; 
Installed: XAOUT directly set; 
XAOUT indirectly set through a 32-bit and 64-bit Register. 

 

An estimation of the load expressed in µs for any hardware feature enabled is displayed on the right 
side. The result after configuration might look like this. 

 

NOTE 
The Processor Load tool will use the firmware located in ComET4’s firmware pool. 
It is only compatible with firmware versions 3.12A and above. 
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11.5.1.2. Software Features sub-panel 

On the Software Features panel, the user has to define which software features are going to be 

used in his application. The list of features is extensive (refer to the AccurET Modular Position 
Controller Operation & Software Manual for further information): 

Software features 

 Are there any Regulator filters being used? The options are: 
- Disabled; 
- Enabled: 1 up to 7 filters used. 

 Is the CAM feature being used? The options are: 
- Not used; 
- Used. 

 Is the cogging compensation being used? The options are: 
- Not used; 
- Used: linear (i.e. enabled for a linear axis) or rotary correction (i.e. enabled for a rotary axis). 

 Which type of connection is being used by the Controller? The options are: 
- USB only; 
- TransnET only or with USB as well; 
- Ethernet only or with USB as well; 
- EtherCAT only or with USB as well. 

 Is the Master/Slave position compensation being used? The options are: 
- Disabled; 
- Enabled: on int32, float, int64 or double. 

 Is the compensation on real position being used? The options are: 
- Disabled; 
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- Enabled: on int32, float, int64 or double. 

 Is the position external reference mode being used? The options are: 
- Disabled; 
- Enabled: filtered or not filtered on int32, float, int64 or double. 

 Is the dual encoder feedback feature being used? The options are: 
- Disabled; 
- Enabled: Permanent or Intermittent modes. 

 Is the dynamic braking feature being used? The options are: 
- Disabled; 
- In case of error; 
- When motor power off. 

 Is the encoder stretch feature being used? The options are: 
- Disabled; 
- Enabled. 

 Is feedforward compensation being used? The options are: 
- Disabled; 
- Enabled: including dry friction with or without hysteresis. 

 Is the Controller being used for force control? The options are: 
- Disabled; 
- Enabled. 

 Is the gain scheduling feature being used? The options are: 
- Disabled; 
- Enabled: Kdp and/or Kip gain scheduling; 
- Enabled: Advanced gain scheduling. 

 Is the Controller configured for Gantry control? The options are: 
- Disabled; 
- Enabled: Gantry levels 1 or 2. 

 Is advanced gantry feedforward being used? The options are: 
- Disabled; 
- Enabled: Gantry levels 1 or 2. 

 Is the external motor braking control through digital output (DOUT) being used? The options are: 

- Disabled; 
- Enabled. 

 Is motor protection being used? The options are: 
- Disabled; 
- Enabled: temperature check on digital inputs. 

 Is a motion being executed? The options are: 
- Disabled; 
- Not moving; 
- Moving (Linear S-Curve); 
- Moving (Rotary S-Curve). 

 Is movement limit control enabled? The options are: 
- Disabled; 
- Enabled: limit switches on DIN, L1/L2 or L/H pin signals. 

 Is movement limit control enabled? The options are: 
- Disabled; 
- Enabled: K36 =1, 2 or 4. 

 Which type of position controller is being used? The options are: 
- Disabled; 
- Enabled: state regulator or stepper. 

 Is the position capture feature being used? The options are: 
- Disabled; 
- Enabled: main, secondary or auxiliary encoders. 

 Is the calculation of the power consumption enabled? The options are: 
- Disabled; 
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- Enabled. 

 Is the power sag detection feature being used? The options are: 
- Disabled; 
- Enabled without power sag; 
- Enabled with power sag. 

 Is the Controller reading Real-Time Values (RTV)? The options are: 
- Disabled; 
- Enabled: 1 to 16 slots used. 

 Is the Controller writing Real-Time Values (RTV)? The options are: 
- Disabled; 
- Enabled: 1 to 15 slots used. 

 Is scale mapping being used? The options are: 
- Disabled; 
- Enabled: linear or rotary scale. 

 Are Sequences being used? The options are: 
- Disabled; 
- Enabled: default allocation time, one or two threads, running on external or internal stack; 
- Enabled: maximum allocation time, one or two threads, running on external or internal stack; 

 Is the Serial Peripheral Interface (SPI) bus being used? The options are: 
- Disabled; 
- Enabled. 

 Is stage mapping being used? The options are: 
- Disabled; 
- Enabled: 1D, 2D or 3D mapping. 

 Is the stage protection feature being used? The options are: 
- Disabled; 
- Enabled: with step or ramp brake on the speed. 

 Are there any trajectory filters being used? The options are: 
- Disabled; 
- Enabled: linear movement, 1 up to 4 filters defined; 
- Enabled: rotary movement, 1 up to 4 filters defined. 

 Is the application using 1D triggers? The options are: 
- Disabled; 
- Enabled: trigger, trigger status, trigger with missed event, publish position for trigger, trigger with 

missed event and/or position from any register. 

 Is the application using 2D triggers? The options are: 
- Disabled; 
- Enabled: trigger, trigger with missed event and/or position from any register. 

 

On the right side is displayed an estimation of the load (in µs) for any software feature enabled. 

If a feature is not available in the list, it is possible to enter manually the estimated processor load 

time using Other Function(s) Time edit control. 

On the top section of the Load Estimation panel is displayed the estimated load (average and peak) 
for the given configuration as a percentage of the total capacity. 
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11.5.2. Load measurement 

The load of Controller’s processor can actually be measured with the Processor Load tool as well. 

Just select the second panel Load Measurement and click on the START button. The average and 

peak load values are measured for a moment and then displayed. 

 

 
 

 

NOTE 
This tool performs only an estimation of the load. Depending on the synchronization 
between different functions, the value estimated may vary from the real value. 
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12. Service & Support 

For any inquiry regarding technical, commercial and service information relating to ETEL products, 
please contact your ETEL representative. 

 
HEADQUARTER / SWITZERLAND BELGIUM CHINA 

ETEL S.A. 
Zone industrielle 
CH-2112 Môtiers 

Phone: +41 (0)32 862 01 00 
E-mail: etel@etel.ch 
http://www.etel.ch 

HEIDENHAIN nv/sa 
Pamelse Klei 47 
1760 Roosdaal 

Phone: +32 54 34 31 58 
E-mail: sales@heidenhain.be 

DR. JOHANNES HEIDENHAIN (CHINA) 
Co., Ltd 

No. 6, Tian Wei San Jie, Area A, Beijing 
Tianzhu Airport, Industrial Zone Shunyi 

District, Beijing 101312 
Phone: +86 400 619 6060 

E-mail: sales@heidenhain.com.cn 

CZECH Republic FRANCE GERMANY 

HEIDENHAIN s.r.o. 
Dolnomecholupská 12b 

102 00 Praha 10 - Hostivar 
Phone: +420 272 658 131 

E-mail:heidenhain@heidenhain.cz 

HEIDENHAIN FRANCE SARL 
2 avenue de la cristallerie 

92310 Sèvres 
Phone: +33 (0)1 41 14 30 09 
E-mail: sales@heidenhain.fr 

DR. JOHANNES HEIDENHAIN GmbH 
Technisches Büro Südwest II 

Verkauf ETEL S.A. 
Schillgasse 14 

78661 Dietingen 
Phone: +49 (0)741 17453-0 

E-mail: tbsw.etel@heidenhain.de 

GREAT-BRITAIN ISRAEL (Representative) ITALY 

HEIDENHAIN (GB) Ltd. 
200 London Road, Burgess Hill, 

West Sussex RH 15 9RD 
Phone: +44 (0)1444 247711 

E-mail: sales@heidenhain.co.uk 

MEDITAL COMOTECH Ltd. 
36 Shacham St., 

P.O.B 7772, Petach Tikva Israel 
4951729 

Phone: +972 3 923 3323 
E-mail: comotech@medital.co.il 

ETEL S.A. 
Piazza della Repubblica 11 

28050 Pombia 
Phone: +39 0321 958 965 

E-mail: etel@etelsa.it 

JAPAN KOREA SINGAPORE 

HEIDENHAIN K.K. 
Hulic Kojimachi Bldg. 9F 

3-2 Kojimachi, Chiyoda-ku 
Tokyo - 102-0083 

Phone: +81 3 3234 7781 
E-mail: sales@heidenhain.co.jp 

HEIDENHAIN KOREA Ltd. 
2F Namsung Plaza 

(9th Ace Techno Tower), 130, Digital-ro, 
Geumcheon-Gu, Seoul, Korea 08589 

Phone: + 82 2 2028-7430 
E-mail: etelsales@heidenhain.co.kr 

HEIDENHAIN PACIFIC PTE. LTD 
51 Ubi Crescent, 

Singapore 408593 
Phone: +65 6749 3238 

E-mail: info@heidenhain.com.sg 

SPAIN (Representative) SWEDEN SWITZERLAND 

Farresa Electronica, S.A. 
C/ Les Corts, 36 bajos 
ES-08028 Barcelona 

Phone: +34 93 409 24 91 
E-mail: farresa@farresa.es 

HEIDENHAIN Scandinavia AB 
Storsätragränd 5 

127 39 Skärholmen 
Phone: +468 531 93 350 

E-mail: sales@heidenhain.se 

ETEL S.A. 
Zone industrielle 
CH-2112 Môtiers 

Phone: +41 (0)32 862 01 33 
E-mail: sales@etelsa.ch 

TAIWAN THE NETHERLANDS UNITED STATES 

HEIDENHAIN CO., LTD. 
No. 29, 33rd road, 

Taichung Industrial Park 
Taichung 40768, Taiwan, R.O.C. 

Phone: +886 4 2358 8977 
E-mail: info@heidenhain.tw 

HEIDENHAIN NEDERLAND B.V. 
Copernicuslaan 34 

6716 BM Ede 
Phone: +31 (0)318 581800 

E-mail: verkoop@heidenhain.nl 

HEIDENHAIN CORPORATION 
333 E. State Parkway Schaumburg, IL 

60173 
Phone: +1 847 490 1191 

E-mail: info@heidenhain.com 

 

The technical hotline based at ETEL S.A.'s headquarters can be reached by: 

• Phone: +41 (0)32 862 01 12 

• Fax: +41 (0)32 862 01 01 

• E-mail: support@etel.ch 

Refer to your corresponding ETEL S.A. representative for more information about the technical 
documentation. 

ETEL S.A. organizes training courses for customers on request, including theoretical presentations 
of our products and practical demonstrations at our facilities. 
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13. Frequently Asked Questions 

 

How to establish the communication? 
Refer to Section §3.1. 

How to setup a system? 
Refer to Sections §3.2 and §4.1. 

How to check the status of the user’s application? 
Refer to Section §2.3. 

How to make a simple movement? 
Refer to Section §3.4. 

How to adjust the encoder signals? 
Refer to Section §4.1.5. 

How to know the electronics configuration? 
Refer to Section §11.4. 

How to edit, modify and save the registers of the controller? 
Refer to Sections §10.1, §11.1 and §11.2. 

How to make an emergency stop? 
Refer to Section §3.5. 

How to monitor the controller’s registers? 
Refer to Sections §7.1, §7.2 and §7.4. 

How to define the protections? 
Refer to Section §4.1.9. 

How to monitor and manage the I/Os? 
Refer to Section §9. 

How to generate an S-curve profile? 
Refer to Section §6.1. 

How to send a command? 
Refer to Sections §3.3 and §11.2. 

How to write and execute a Sequence? 
Refer to Sections §8.1.1 and §8.1.2. 

How to debug a Sequence? 
Refer to Section §8.1.3. 

How to pre-compile a Sequence? 
Refer to Section §8.1.4. 

How to select the units? 
Refer to Sections §2.5.3, §7.1 and §7.2. 

How to know the events occurred on a controller? 
Refer to Section §7.5. 

How to download a new firmware? 
Refer to Section §10.4. 

How to backup and restore the controller configuration? 
Refer to Section §10.5. 

How to customize the ComET interface? 
Refer to Section §10.6. 

How to adjust the regulation of the system? 
Refer to Section §4.2. 

How to configure the analog I/Os? 
Refer to Section §9.2. 

How to manage the system configuration? 
Refer to Section §10.6. 

How to do a scale mapping? 
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Refer to Section §4.2.5. 

How to make a stage mapping? 
Refer to Section §4.2.6. 

How to tune the advanced feedforward parameters? 
Refer to Section §4.2.4. 

How to make a frequency analysis of the system? 
Refer to Section §7.3. 

How to visualize scope acquisition? 
Refer to Sections §7.1 and §7.2. 

How to measure the processor load? 
Refer to Section §11.5. 

How to configure the force control? 
Refer to Section §5.1. 

How to set the QuiET active isolation system? 
Refer to Section §5.2. 

How to set up a ZxT module? 
Refer to Section §5.3. 

How to download a Customer Software Module? 
Refer to Section §8.2.2. 

How to upload log files from the ULTIMET ADVANCED motion controller? 
Refer to Section §7.6. 
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Active isolation system. See Tools, QuiET 
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Feedforward Tuning 
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Console. See Tools, Console 
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Controller restore, 300 
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Debug, 228 
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Editor. See Tools, Editor 
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Embedded programming 

Customer Software Module, 240 
Sequence, 226 

Emergency stop, 46 
Encoder’s signals, 59 
Events, 221 
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Fast Fourier Transform, 205 
Feedforward parameters, 79 
FFT, 205 
Filters, 77 
Firmware 

Download/Upload, 285 

Force control. See Tools, Force Control 
Frequency analysis, 206 
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Help, 21 
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I/O 
Configuration, 245, 250 
Control, 260 
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Identification, 206 
Inputs, 245, 249, 250, 252 
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ISO units, 34, 189, 196 
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Log files, 223 
Logging tool. See Tools, Logging 
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Nyquist diagram, 207 

O 

Outputs, 245, 246, 250, 252 
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Position loop, 74, 210 
Power Spectrum, 205 
Pre-compiled Sequence, 236 
Processor load, 338 
Protections, 66, 71 
PS, 205 
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QuiET tool. See Tools, QuiET 
Control setting, 150 
Feedforward calibration, 152 
Leveling, 147 
Performance, 153 
Transmissibility, 150 
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Registers 
Download, 269 
Upload, 273 

Registers edition and modification, 331 
Registers editor. See Tools, Registers Editor 
Regulation. See Tools, Regulation 

S 

Save configuration, 282 
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Scale mapping. See Tools, Scale Mapping 
Scope. See Tools, Scope 
Scope acquisition, 184 
S-curve profile. See Tools, S-Curve Profile 
Sequence 

Debug, 228 
Download, 276 
Upload, 280 

Setting. See Tools, Setting 
Simple movement, 45 
Stage mapping. See Tools, Stage Mapping 
Startup. See Tools, Startup 
Status bar, 25 
Step response, 75 
System configuration manager. See Tools, System 

Configuration Manager 
System reporting. See Tools, System Reporting 
System requirements, 14 

T 

Terminal, 44, 332 
Tools, 20 

Advanced Feedforward Tuning, 79 
Console, 176 
Controller Backup, 293 
Editor, 226 
Filter Design, 77 
Force Control, 113 
I/O Configuration, 245 
I/O Control, 260 
Identification, 206 
Logging, 221 
Monitor, 218 
Processor Load, 338 
QuiET, 144 
Registers Editor, 328 
Regulation, 71 

Scale Mapping, 85 
Scope, 183 
S-Curve Profile, 172 
Setting, 51 
Stage Mapping, 93 
Startup, 27 
System Configuration Manager, 300 
System Reporting, 335 
Terminal, 332 
Unit Converter, 333 
Viewer, 194 
ZxT, 154 

Traces, 183, 188 
Trigger 

Delay, 187 
Mode, 185 
Source, 185 

U 

Units 
Configuration, 34 
Conversion, 333 
Selection, 189, 196 

V 

Viewer. See Tools, Viewer 

Z 

ZxT tool. See Tools, ZxT 
Feedforward tuning, 168 
Homing, 157 
Identification, 162 
Simulation, 166 
Stage mapping, 171 
Stroke limits, 157 
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